GLSA 200410-15: Squid: Remote DoS vulnerability
Posted on: 10/18/2004 02:41 PM

A Squid security update is available for Gentoo Linux

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 200410-15
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: Squid: Remote DoS vulnerability
Date: October 18, 2004
Bugs: #67167
ID: 200410-15

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Squid contains a vulnerability in the SNMP module which may lead to a denial of service.

Background
==========

Squid is a full-featured Web proxy cache designed to run on Unix systems. It supports proxying and caching of HTTP, FTP, and other URLs, as well as SSL support, cache hierarchies, transparent caching, access control lists and many other features.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 www-proxy/squid < 2.5.7 >= 2.5.7

Description
===========

A parsing error exists in the SNMP module of Squid where a specially-crafted UDP packet can potentially cause the server to restart, closing all current connections. This vulnerability only exists in versions of Squid compiled with the 'snmp' USE flag.

Impact
======

An attacker can repeatedly send these malicious UDP packets to the Squid server, leading to a denial of service.

Workaround
==========

Disable SNMP support or filter the port that has SNMP processing (default is 3401) to allow only SNMP data from trusted hosts.

To disable SNMP support put the entry snmp_port 0 in the squid.conf configuration file.

To allow only the local interface to process SNMP, add the entry "snmp_incoming_address 127.0.0.1" in the squid.conf configuration file.

Resolution
==========

All Squid users should upgrade to the latest version:

# emerge sync

# emerge -pv ">=www-proxy/squid-2.5.7"
# emerge ">=www-proxy/squid-2.5.7"

References
==========

[ 1 ] iDEFENSE Advisory
http://www.idefense.com/application/poi/display?id=152type=vulnerabilitiesflashstatus=true

Availability
============

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200410-15.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at http://bugs.gentoo.org.

License
=======

Copyright 2004 Gentoo Foundation, Inc; referenced text belongs to its owner(s).

The contents of this document are licensed under the Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/1.0


Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/glsa_200410_15_squid_remote_dos_vulnerability.html)