GLSA 200409-16: Samba: Denial of Service vulnerabilities
Posted on: 09/13/2004 06:46 PM

A Samba security update has been released for Gentoo Linux

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 200409-16
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: Samba: Denial of Service vulnerabilities
Date: September 13, 2004
ID: 200409-16

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=======

Two Denial of Service vulnerabilities have been found and fixed in Samba.

Background
=========

Samba is a freely available SMB/CIFS implementation which allows seamless interoperability of file and print services to other SMB/CIFS clients. smbd and nmbd are two daemons used by the Samba server.

Affected packages
================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 net-fs/samba < 3.0.7 >= 3.0.7
< 3.0

Description
==========

There is a defect in smbd's ASN.1 parsing. A bad packet received during the authentication request could throw newly-spawned smbd processes into an infinite loop (CAN-2004-0807). Another defect was found in nmbd's processing of mailslot packets, where a bad NetBIOS request could crash the nmbd process (CAN-2004-0808).

Impact
=====

A remote attacker could send specially crafted packets to trigger both defects. The ASN.1 parsing issue can be exploited to exhaust all available memory on the Samba host, potentially denying all service to that server. The nmbd issue can be exploited to crash the nmbd process, resulting in a Denial of Service condition on the Samba server.

Workaround
=========

There is no known workaround at this time.

Resolution
=========

All Samba 3.x users should upgrade to the latest version:

# emerge sync

# emerge -pv ">=net-fs/samba-3.0.7"
# emerge ">=net-fs/samba-3.0.7"

References
=========

[ 1 ] CAN-2004-0807
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0807
[ 2 ] CAN-2004-0808
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0808

Availability
===========

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200409-16.xml

Concerns?
========

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at http://bugs.gentoo.org.

License
======

Copyright 2004 Gentoo Foundation, Inc; referenced text belongs to its owner(s).

The contents of this document are licensed under the Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/1.0


Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/glsa_200409_16_samba_denial_of_service_vulnerabilities.html)