GLSA 200409-08: Ruby: CGI::Session creates files insecurely
Posted on: 09/03/2004 06:44 PM

A Ruby security update is available for Gentoo Linux

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 200409-08
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: Ruby: CGI::Session creates files insecurely
Date: September 03, 2004
Bugs: #60525
ID: 200409-08

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=======

When used for CGI scripting, Ruby creates session files in /tmp with the permissions of the default umask. Depending on that umask, local users may be able to read sensitive data stored in session files.

Background
=========

Ruby is an Object Oriented, interpreted scripting language used for many system scripting tasks. It can also be used for CGI web applications.

Affected packages
================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 dev-lang/ruby < 1.8.2_pre2 *>= 1.6.8-r11
*>= 1.8.0-r7
>= 1.8.2_pre2

Description
==========

The CGI::Session::FileStore implementation (and presumably CGI::Session::PStore), which allow data associated with a particular Session instance to be written to a file, writes to a file in /tmp with no regard for secure permissions. As a result, the file is left with whatever the default umask permissions are, which commonly would allow other local users to read the data from that session file.

Impact
=====

Depending on the default umask, any data stored using these methods could be read by other users on the system.

Workaround
=========

By changing the default umask on the system to not permit read access to other users (e.g. 0700), one can prevent these files from being readable by other users.

Resolution
=========

All Ruby users should upgrade to the latest version:

# emerge sync

# emerge -pv ">=dev-lang/ruby-your_version"
# emerge ">=dev-lang/ruby-your_version"

References
=========

[ 1 ] CAN-2004-0755
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0755

Availability
===========

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200409-08.xml

Concerns?
========

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at http://bugs.gentoo.org.

License
======

Copyright 2004 Gentoo Foundation, Inc; referenced text belongs to its owner(s).

The contents of this document are licensed under the Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/1.0


Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/glsa_200409_08_ruby_cgisession_creates_files_insecurely.html)