GLSA 200408-27: Gaim: New vulnerabilities
Posted on: 08/27/2004 04:43 PM

A Gaim update is available for Gentoo Linux

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 200408-27
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: Gaim: New vulnerabilities
Date: August 27, 2004
Bugs: #61457
ID: 200408-27

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=======

Gaim contains several security issues that might allow an attacker to execute arbitrary code or commands.

Background
=========

Gaim is a multi-protocol instant messaging client for Linux which supports many instant messaging protocols.

Affected packages
================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 net-im/gaim < 0.81-r5 >= 0.81-r5

Description
==========

Gaim fails to do proper bounds checking when:

* Handling MSN messages (partially fixed with GLSA 200408-12).

* Handling rich text format messages.

* Resolving local hostname.

* Receiving long URLs.

* Handling groupware messages.

* Allocating memory for webpages with fake content-length header.

Furthermore Gaim fails to escape filenames when using drag and drop installation of smiley themes.

Impact
=====

These vulnerabilites could allow an attacker to crash Gaim or execute arbitrary code or commands with the permissions of the user running Gaim.

Workaround
=========

There is no known workaround at this time. All users are encouraged to upgrade to the latest available version of Gaim.

Resolution
=========

All gaim users should upgrade to the latest version:

# emerge sync

# emerge -pv ">=net-im/gaim-0.81-r5"
# emerge ">=net-im/gaim-0.81-r5"

References
=========

[ 1 ] Gaim security issues
http://gaim.sourceforge.net/security/index.php

Availability
===========

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200408-27.xml

Concerns?
========

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at http://bugs.gentoo.org.

License
======

Copyright 2004 Gentoo Foundation, Inc; referenced text belongs to its owner(s).

The contents of this document are licensed under the Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/1.0


Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/glsa_200408_27_gaim_new_vulnerabilities.html)