GLSA 200405-17: Multiple vulnerabilities in metamail
Posted on: 05/22/2004 04:19 AM

A metamail update has been released for Gentoo Linux

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 200405-17
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: High
Title: Multiple vulnerabilities in metamail
Date: May 21, 2004
Bugs: #42133
ID: 200405-17

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=======

Several format string bugs and buffer overflows were discovered in metamail, potentially allowing execution of arbitrary code remotely.

Background
=========

Metamail is a program that decodes MIME encoded mail. It is therefore often automatically called when an email is received or read.

Affected packages
================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 net-mail/metamail < 2.7.45.3 >= 2.7.45.3

Description
==========

Ulf Harnhammar found two format string bugs and two buffer overflow bugs in Metamail.

Impact
=====

A remote attacker could send a malicious email message and execute arbitrary code with the rights of the process calling the Metamail program.

Workaround
=========

There is no known workaround at this time.

Resolution
=========

All users of Metamail should upgrade to the latest stable version:

# emerge sync

# emerge -pv ">=net-mail/metamail-2.7.45.3"
# emerge ">=net-mail/metamail-2.7.45.3"

References
=========

[ 1 ] CAN-2004-0104
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0104
[ 2 ] CAN-2004-0105
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0105

Availability
===========

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200405-17.xml

Concerns?
========

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at http://bugs.gentoo.org.

License
======

Copyright 2004 Gentoo Technologies, Inc; referenced text belongs to its owner(s).

The contents of this document are licensed under the Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/1.0


Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/glsa_200405_17_multiple_vulnerabilities_in_metamail.html)