GLSA 200404-18: Multiple Vulnerabilities in ssmtp
Posted on: 04/27/2004 05:16 AM

A ssmtp update has been released for Gentoo Linux

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 200404-18
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: High
Title: Multiple Vulnerabilities in ssmtp
Date: April 26, 2004
Bugs: #47918, #48435
ID: 200404-18

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=======

There are multiple format string vulnerabilities in the SSMTP package, which may allow an attacker to run arbitrary code with ssmtp's privileges (potentially root).

Background
=========

SSMTP is a very simple mail transfer agent (MTA) that relays mail from the local machine to another SMTP host. It is not designed to function as a full mail server; its sole purpose is to relay mail.

Affected packages
================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 net-mail/ssmtp <= 2.60.4-r2 >= 2.60.7

Description
==========

There are two format string vulnerabilities inside the log_event() and die() functions of ssmtp. Strings from outside ssmtp are passed to various printf()-like functions from within log_event() and die() as format strings. An attacker could cause a specially-crafted string to be passed to these functions, and potentially cause ssmtp to execute
arbitrary code.

Impact
=====

If ssmtp connects to a malicious mail relay server, this vulnerability can be used to execute code with the rights of the mail sender, including root.

Workaround
=========

There is no known workaround at this time. All users are advised to upgrade to the latest available version of ssmtp.

Resolution
=========

All users are advised to upgrade to the latest available version of ssmtp.

# emerge sync

# emerge -pv ">=net-mail/ssmtp-2.60.7"
# emerge ">=net-mail/ssmtp-2.60.7"

References
=========

[ 1 ] Secunia Advisory
http://secunia.com/advisories/11378/
[ 2 ] CVE Reference
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0156
[ 3 ] Debian Advisory
http://lists.debian.org/debian-security-announce/debian-security-announce-2004/msg00084.html

Availability
===========

This GLSA and any updates to it are
available for viewing at the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200404-18.xml

Concerns?
========

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at http://bugs.gentoo.org.

License
======

Copyright 2004 Gentoo Technologies, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/1.0


Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/glsa_200404_18_multiple_vulnerabilities_in_ssmtp.html)