GLSA 200404-15: XChat 2.0.x SOCKS5 Vulnerability
Posted on: 04/19/2004 06:36 AM

A XChat update has been released for Gentoo Linux

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 200404-15
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Low
Title: XChat 2.0.x SOCKS5 Vulnerability

Date: April 19, 2004
Bugs: #46856
ID: 200404-15

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=======

XChat is vulnerable to a stack overflow that may allow a remote attacker to run arbitrary code.

Background
=========

XChat is a multiplatform IRC client.

Affected packages
================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
net-irc/xchat < 2.0.8-r1 >= 2.0.8-r1

Description
==========

The SOCKS 5 proxy code in XChat is vulnerable to a remote exploit. Users would have to be using XChat through a SOCKS 5 server, enable SOCKS 5 traversal which is disabled by default and also connect to an attacker's custom proxy server.

Impact
=====

This vulnerability may allow an attacker to run arbitrary code within the context of the user ID of the XChat client.

Workaround
=========

A workaround is not currently known for this issue. All users are advised to upgrade to the latest version of the affected package.

Resolution
=========

All XChat users should upgrade to the latest stable version:

# emerge sync

# emerge -pv ">=net-irc/xchat-2.0.8-r1"
# emerge ">=net-irc/xchat-2.0.8-r1"

Note that users of the gtk1 version of xchat (1.8.*) should upgrade to xchat-1.8.11-r1:

# emerge sync

# emerge -pv "=net-irc/xchat-1.8.11-r1"
# emerge "=net-irc/xchat-1.8.11-r1"

References
=========

[ 1 ] http://mail.nl.linux.org/xchat-announce/2004-04/msg00000.html

Availability
===========

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200404-15.xml

Concerns?
========

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at http://bugs.gentoo.org.

License
======

Copyright 2004 Gentoo Technologies, Inc; referenced text belongs to its owner(s).

The contents of this document are licensed under the Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/1.0


Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/glsa_200404_15_xchat_20x_socks5_vulnerability.html)