GLib 2.7.7 released
Posted on: 08/05/2005 05:22 PM

GLib 2.7.7 is now available for download at:

ftp://ftp.gtk.org/pub/gtk/v2.7/

glib-2.7.7.tar.bz2 md5sum: 1524e5300d6bbdc6682be057744ddc53
glib-2.7.7.tar.gz md5sum: b62b3e91b04a93c8c717f733b79843ed

This is another release candidate for GLib 2.8.

Notes:

* We consider this release to be a release candidate for
2.8.0. The only area where changes between this release
and the final 2.8.0 are still likely is the the atomic
reference counting changes in GObject.

* Installing this version will overwrite your existing
copy of GLib 2.6. If you have problems, you'll need
to reinstall GLib 2.6.6.

* GLib 2.8 will be source and binary compatible with
the GLib 2.6.x series. The new API additions in GLib
2.7.x are finalized at this point, and GLib 2.7.x
should be considered API frozen. Unless serious issues
with the new APIs come up, there will be no API
changes between this release and the 2.8.0 release.

* Bugs should be reported to http://bugzilla.gnome.org.


About GLib
=========

GLib is the low-level core library that forms the basis for projects such as GTK+ and GNOME. It provides data structure handling for C, portability wrappers, and interfaces for such runtime functionality as an event loop, threads, dynamic loading, and an object system.

More information about GLib is available at:

http://www.gtk.org/

An installation guide for the GTK+ libraries, including GLib, can be found at:

http://developer.gnome.org/doc/API/2.0/gtk/gtk-building.html


Overview of Changes from GLib 2.7.6 to GLib 2.7.7
================================================
* Make atomic operations on s390 work [Matthias]
* Fix C++ guards in gstdio.h [Tor Lillqvist]


August 5, 2005



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/glib_277_released.html)