gaim (SSA:2005-242-03)
Posted on: 08/31/2005 04:35 AM

New gaim packages are available for Slackware 9.0, 9.1, 10.0, 10.1, and -current to fix some security issues. including:

AIM/ICQ away message buffer overflow
AIM/ICQ non-UTF-8 filename crash
Gadu-Gadu memory alignment bug

Sites that use GAIM should upgrade to the new version.

More details about these issues may be found in the Common Vulnerabilities and Exposures (CVE) database:

Here are the details from the Slackware 10.1 ChangeLog:
patches/packages/gaim-1.5.0-i486-1.tgz: Upgraded to gaim-1.5.0.
This fixes some more security issues.
For more information, see:
(* Security fix *)

Where to find the new packages:

Updated package for Slackware 9.0:

Updated package for Slackware 9.1:

Updated package for Slackware 10.0:

Updated package for Slackware 10.1:

Updated package for Slackware -current:

MD5 signatures:

Slackware 9.0 package:
676bad766cfddb50c7453554d66b1748 gaim-1.5.0-i386-1.tgz

Slackware 9.1 package:
d2cc0baba627ba9dbf3f218bdeacc630 gaim-1.5.0-i486-1.tgz

Slackware 10.0 package:
98d55471ed0a2f9def7fcded90860839 gaim-1.5.0-i486-1.tgz

Slackware 10.1 package:
bc6891f4acb22530c472218f5d9493fb gaim-1.5.0-i486-1.tgz

Slackware -current package:
b9a55d4359183b81e1150bea6e13b61e gaim-1.5.0-i486-1.tgz

Installation instructions:

Upgrade the package as root:
# upgradepkg gaim-1.5.0-i486-1.tgz


Slackware Linux Security Team

Printed from Linux Compatible (