Freeciv/Stunnel Updates for Gentoo
Posted on: 02/06/2014 08:38 PM

The follwing updates are available for Gentoo Linux: [ GLSA 201402-08 ] stunnel: Multiple vulnerabilities and [ GLSA 201402-07 ] Freeciv: User-assisted execution of arbitrary code

[ GLSA 201402-08 ] stunnel: Multiple vulnerabilities
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201402-08
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: stunnel: Multiple vulnerabilities
Date: February 06, 2014
Bugs: #460278
ID: 201402-08

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in stunnel, the worst of which
may cause a Denial of Service condition.

Background
==========

The stunnel program is designed to work as an SSL encryption wrapper
between a client and a local or remote server.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 net-misc/stunnel < 4.56-r1 >= 4.56-r1

Description
===========

Multiple vulnerabilities have been discovered in stunnel. Please review
the CVE identifiers referenced below for details.

Impact
======

A remote attacker could cause a Denial of Service condition or disclose
potentially sensitive information.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All stunnel users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-misc/stunnel-4.56-r1"

References
==========

[ 1 ] CVE-2012-2686
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-2686
[ 2 ] CVE-2013-0166
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-0166
[ 3 ] CVE-2013-0169
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-0169
[ 4 ] CVE-2013-1762
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-1762

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201402-08.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2014 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5





[ GLSA 201402-07 ] Freeciv: User-assisted execution of arbitrary code
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201402-07
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: Freeciv: User-assisted execution of arbitrary code
Date: February 06, 2014
Bugs: #329949
ID: 201402-07

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A vulnerability in Freeciv may allow a remote attacker to execute
arbitrary code.

Background
==========

Freeciv is an open-source empire building strategy game.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 games-strategy/freeciv < 2.2.1 >= 2.2.1

Description
===========

The Lua component of Freeciv does not restrict which modules may be
loaded by scenario scripts.

Impact
======

A remote attacker could entice a user to open a specially crafted
scenario file, possibly resulting in execution of arbitrary code or
reading of arbitrary files with the privileges of the process.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Freeciv users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=games-strategy/freeciv-2.2.1"

NOTE: This is a legacy GLSA. Updates for all affected architectures are
available since July 26, 2010. It is likely that your system is already
no longer affected by this issue.

References
==========

[ 1 ] CVE-2010-2445
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2010-2445

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201402-07.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2014 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5







Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/freecivstunnel_updates_for_gentoo.html)