FLSA-2004:1268: Updated libtool resolves security vulnerability
Posted on: 05/19/2004 04:49 AM

An updated libtool package has been released for Red Hat Linux 7.2 - 8.0

------------------------------------------------------------------------
Fedora Legacy Update Advisory

Synopsis: Updated libtool resolves security vulnerability
Advisory ID: FLSA:1268
Issue date: 2004-05-18
Product: Red Hat Linux
Keywords: Security
Cross references: https://bugzilla.fedora.us/show_bug.cgi?id=1268
------------------------------------------------------------------------


----------------------------------------------------------------------
1. Topic:

Updated libtool packages that fix local tmp vulnerabilities are now available.

2. Relevent releases/architectures:

Red Hat Linux 7.2 - i386
Red Hat Linux 7.3 - i386
Red Hat Linux 8.0 - i386

3. Problem description:
The libtool package contains the GNU libtool, a set of shell scripts which automatically configure UNIX and UNIX-like architectures to generically build shared libraries. Libtool provides a consistent, portable interface which simplifies the process of using shared libraries.

If you are developing programs which will use shared libraries, you should install libtool.

The chmod utility has a race (that access to the temporary directory could be gained after it is created but before it is chmoded)

Fedora Legacy would like to thank Seth Vidal for bringing this issue to our attention.

4. Solution:

Before applying this update, make sure all previously released errata relevant to your system have been applied.

To update all RPMs for your particular architecture, run:

rpm -Fvh [filenames]

where [filenames] is a list of the RPMs you wish to upgrade. Only those RPMs which are currently installed will be updated. Those RPMs which are not installed but included in the list will not be updated. Note that you can also use wildcards (*.rpm) if your current directory *only* contains
the desired RPMs.

Please note that this update is also available via yum and apt. Many people find this an easier way to apply updates. To use yum issue:

yum update

or to use apt:

apt-get update; apt-get upgrade

This will start an interactive process that will result in the appropriate RPMs being upgraded on your system. This assumes that you have yum or apt-get configured for obtaining Fedora Legacy content. Please visit http://www fedoralegacy.org/docs for directions on how to configure yum
and apt-get.

5. Bug IDs fixed:

http://bugzilla.fedora.us - 1268 - Symlink Vulnerability in GNU libtool
<1.5.2

6. RPMs required:

Red Hat Linux 7.2:

SRPM:
http://download.fedoralegacy.org/redhat/7.2/updates/SRPMS/libtool-1.4-9.legacy.src.rpm

i386:
http://download.fedoralegacy.org/redhat/7.2/updates/i386/libtool-1.4-9.legacy.i386.rpm
http://download.fedoralegacy.org/redhat/7.2/updates/i386/libtool-libs-1.4-9.legacy.i386.rpm

Red Hat Linux 7.3:

SRPM:
http://download.fedoralegacy.org/redhat/7.3/updates/SRPMS/libtool-1.4.2-13.legacy.src.rpm

i386:
http://download.fedoralegacy.org/redhat/7.3/updates/i386/libtool-1.4.2-13.legacy.i386.rpm
http://download.fedoralegacy.org/redhat/7.3/updates/i386/libtool-libs-1.4.2-13.legacy.i386.rpm

Red Hat Linux 8.0:

SRPM:
http://download.fedoralegacy.org/redhat/8.0/updates/SRPMS/libtool-1.4.2-14.legacy.src.rpm

i386:
http://download.fedoralegacy.org/redhat/8.0/updates/i386/libtool-1.4.2-14.legacy.i386.rpm
http://download.fedoralegacy.org/redhat/8.0/updates/i386/libtool-libs-1.4.2-14.legacy.i386.rpm


7. Verification:

SHA1 sum Package Name
- ---------------------------------------------------------------------------

13e868d1a6e24f185e747b62e11819971c441da5
7.2/updates/SRPMS/libtool-1.4-9.legacy.src.rpm
2732828598e0be48ed39f54e7cc42370c662d9cd
7.2/updates/i386/libtool-1.4-9.legacy.i386.rpm
34fdec6bd3246b51dc2993f7b01194952717f145
7.2/updates/i386/libtool-libs-1.4-9.legacy.i386.rpm

94580dd2607afce8ab7e615b937234977a2345c5
7.3/updates/SRPMS/libtool-1.4.2-13.legacy.src.rpm
705a844d64e11e4c7d13d70e2b7957bbb403a33f
7.3/updates/i386/libtool-1.4.2-13.legacy.i386.rpm
815821f416de6969939854dfa1a9215a93408040
7.3/updates/i386/libtool-libs-1.4.2-13.legacy.i386.rpm

6b9c3e628278b0fc5966dd4f4911ad1edae438ef
8.0/updates/SRPMS/libtool-1.4.2-14.legacy.src.rpm
96d900b337cab85040da9062593a43fee24849c1
8.0/updates/i386/libtool-1.4.2-14.legacy.i386.rpm
e39aa95f8a3a643bb9d5ea707b11b65868a2e3b7
8.0/updates/i386/libtool-libs-1.4.2-14.legacy.i386.rpm

These packages are GPG signed by Fedora Legacy for security. Our key is available from http://www.fedoralegacy.org/about/security.php

You can verify each package with the following command:

rpm --checksig -v <filename>

If you only wish to verify that each package has not been corrupted or tampered with, examine only the sha1sum with the following command:

sha1sum <filename>

8. References:
http://www.redhat.com/archives/fedora-legacy-list/2004-February/msg00109.html
https://bugzilla.fedora.us/show_bug.cgi?id=1268


9. Contact:

The Fedora Legacy security contact is secnotice@fedoralegacy.org. More
project details at http://www.fedoralegacy.org


Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/flsa_20041268_updated_libtool_resolves_security_vulnerability.html)