Firefox/Seamonkey/Thunderbird Update for RHEL
Posted on: 07/21/2010 01:27 PM

Red Hat has released the following security advisories for Red Hat Enterprise Linux

- [RHSA-2010:0547-01] Critical: firefox security update
- [RHSA-2010:0546-01] Critical: seamonkey security update
- [RHSA-2010:0544-01] Moderate: thunderbird security update
- [RHSA-2010:0545-01] Critical: thunderbird security update

[RHSA-2010:0547-01] Critical: firefox security update
=====================================================================
Red Hat Security Advisory

Synopsis: Critical: firefox security update
Advisory ID: RHSA-2010:0547-01
Product: Red Hat Enterprise Linux
Advisory URL: https://rhn.redhat.com/errata/RHSA-2010-0547.html
Issue date: 2010-07-20
CVE Names: CVE-2010-0654 CVE-2010-1205 CVE-2010-1206
CVE-2010-1207 CVE-2010-1208 CVE-2010-1209
CVE-2010-1210 CVE-2010-1211 CVE-2010-1212
CVE-2010-1213 CVE-2010-1214 CVE-2010-1215
CVE-2010-2751 CVE-2010-2752 CVE-2010-2753
CVE-2010-2754
=====================================================================

1. Summary:

Updated firefox packages that fix several security issues are now available
for Red Hat Enterprise Linux 4 and 5.

The Red Hat Security Response Team has rated this update as having critical
security impact. Common Vulnerability Scoring System (CVSS) base scores,
which give detailed severity ratings, are available for each vulnerability
from the CVE links in the References section.

2. Relevant releases/architectures:

RHEL Desktop Workstation (v. 5 client) - i386, x86_64
Red Hat Enterprise Linux (v. 5 server) - i386, ia64, ppc, s390x, x86_64
Red Hat Enterprise Linux AS version 4 - i386, ia64, ppc, s390, s390x, x86_64
Red Hat Enterprise Linux Desktop (v. 5 client) - i386, x86_64
Red Hat Enterprise Linux Desktop version 4 - i386, x86_64
Red Hat Enterprise Linux ES version 4 - i386, ia64, x86_64
Red Hat Enterprise Linux WS version 4 - i386, ia64, x86_64

3. Description:

Mozilla Firefox is an open source web browser. XULRunner provides the XUL
Runtime environment for Mozilla Firefox.

Several flaws were found in the processing of malformed web content. A web
page containing malicious content could cause Firefox to crash or,
potentially, execute arbitrary code with the privileges of the user running
Firefox. (CVE-2010-1208, CVE-2010-1209, CVE-2010-1211, CVE-2010-1212,
CVE-2010-1214, CVE-2010-1215, CVE-2010-2752, CVE-2010-2753)

A memory corruption flaw was found in the way Firefox decoded certain PNG
images. An attacker could create a specially-crafted PNG image that, when
opened, could cause Firefox to crash or, potentially, execute arbitrary
code with the privileges of the user running Firefox. (CVE-2010-1205)

Several same-origin policy bypass flaws were found in Firefox. An attacker
could create a malicious web page that, when viewed by a victim, could
steal private data from a different website the victim has loaded with
Firefox. (CVE-2010-0654, CVE-2010-1207, CVE-2010-1213, CVE-2010-2754)

A flaw was found in the way Firefox presented the location bar to a user. A
malicious website could trick a user into thinking they are visiting the
site reported by the location bar, when the page is actually content
controlled by an attacker. (CVE-2010-1206)

A flaw was found in the way Firefox displayed the location bar when
visiting a secure web page. A malicious server could use this flaw to
present data that appears to originate from a secure server, even though it
does not. (CVE-2010-2751)

A flaw was found in the way Firefox displayed certain malformed characters.
A malicious web page could use this flaw to bypass certain string
sanitization methods, allowing it to display malicious information to
users. (CVE-2010-1210)

For technical details regarding these flaws, refer to the Mozilla security
advisories for Firefox 3.6.7. You can find a link to the Mozilla advisories
in the References section of this erratum.

All Firefox users should upgrade to these updated packages, which contain
Firefox version 3.6.7, which corrects these issues. After installing the
update, Firefox must be restarted for the changes to take effect.

4. Solution:

Before applying this update, make sure all previously-released errata
relevant to your system have been applied.

This update is available via the Red Hat Network. Details on how to
use the Red Hat Network to apply this update are available at
http://kbase.redhat.com/faq/docs/DOC-11259

5. Bugs fixed (http://bugzilla.redhat.com/):

568231 - CVE-2010-0654 firefox: cross-domain information disclosure
608238 - CVE-2010-1205 libpng: out-of-bounds memory write
608763 - CVE-2010-1206 Firefox: Spoofing attacks via vectors involving 'No Content' status code or via a windows.stop call
615455 - CVE-2010-1211 Mozilla miscellaneous memory safety hazards
615456 - CVE-2010-1212 Mozilla miscellaneous memory safety hazards
615458 - CVE-2010-1208 Mozilla DOM attribute cloning remote code execution vulnerability
615459 - CVE-2010-1209 Mozilla Use-after-free error in NodeIterator
615462 - CVE-2010-1214 Mozilla Plugin parameter EnsureCachedAttrParamArrays remote code execution vulnerability
615463 - CVE-2010-1215 Mozilla Arbitrary code execution using SJOW and fast native function
615464 - CVE-2010-2752 Mozilla nsCSSValue::Array index integer overflow
615466 - CVE-2010-2753 Mozilla nsTreeSelection dangling pointer remote code execution vulnerability
615471 - CVE-2010-1213 Mozilla Cross-origin data disclosure via Web Workers and importScripts
615472 - CVE-2010-1207 Mozilla Same-origin bypass using canvas context
615474 - CVE-2010-1210 Mozilla Characters mapped to U+FFFD in 8 bit encodings cause subsequent character to vanish
615480 - CVE-2010-2751 Mozilla SSL spoofing with history.back() and history.forward()
615488 - CVE-2010-2754 Mozilla Cross-origin data leakage from script filename in error messages

6. Package List:

Red Hat Enterprise Linux AS version 4:

Source:
ftp://updates.redhat.com/enterprise/4AS/en/os/SRPMS/firefox-3.6.7-2.el4.src.rpm

i386:
firefox-3.6.7-2.el4.i386.rpm
firefox-debuginfo-3.6.7-2.el4.i386.rpm

ia64:
firefox-3.6.7-2.el4.ia64.rpm
firefox-debuginfo-3.6.7-2.el4.ia64.rpm

ppc:
firefox-3.6.7-2.el4.ppc.rpm
firefox-debuginfo-3.6.7-2.el4.ppc.rpm

s390:
firefox-3.6.7-2.el4.s390.rpm
firefox-debuginfo-3.6.7-2.el4.s390.rpm

s390x:
firefox-3.6.7-2.el4.s390x.rpm
firefox-debuginfo-3.6.7-2.el4.s390x.rpm

x86_64:
firefox-3.6.7-2.el4.x86_64.rpm
firefox-debuginfo-3.6.7-2.el4.x86_64.rpm

Red Hat Enterprise Linux Desktop version 4:

Source:
ftp://updates.redhat.com/enterprise/4Desktop/en/os/SRPMS/firefox-3.6.7-2.el4.src.rpm

i386:
firefox-3.6.7-2.el4.i386.rpm
firefox-debuginfo-3.6.7-2.el4.i386.rpm

x86_64:
firefox-3.6.7-2.el4.x86_64.rpm
firefox-debuginfo-3.6.7-2.el4.x86_64.rpm

Red Hat Enterprise Linux ES version 4:

Source:
ftp://updates.redhat.com/enterprise/4ES/en/os/SRPMS/firefox-3.6.7-2.el4.src.rpm

i386:
firefox-3.6.7-2.el4.i386.rpm
firefox-debuginfo-3.6.7-2.el4.i386.rpm

ia64:
firefox-3.6.7-2.el4.ia64.rpm
firefox-debuginfo-3.6.7-2.el4.ia64.rpm

x86_64:
firefox-3.6.7-2.el4.x86_64.rpm
firefox-debuginfo-3.6.7-2.el4.x86_64.rpm

Red Hat Enterprise Linux WS version 4:

Source:
ftp://updates.redhat.com/enterprise/4WS/en/os/SRPMS/firefox-3.6.7-2.el4.src.rpm

i386:
firefox-3.6.7-2.el4.i386.rpm
firefox-debuginfo-3.6.7-2.el4.i386.rpm

ia64:
firefox-3.6.7-2.el4.ia64.rpm
firefox-debuginfo-3.6.7-2.el4.ia64.rpm

x86_64:
firefox-3.6.7-2.el4.x86_64.rpm
firefox-debuginfo-3.6.7-2.el4.x86_64.rpm

Red Hat Enterprise Linux Desktop (v. 5 client):

Source:
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Client/en/os/SRPMS/firefox-3.6.7-2.el5.src.rpm
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Client/en/os/SRPMS/xulrunner-1.9.2.7-2.el5.src.rpm

i386:
firefox-3.6.7-2.el5.i386.rpm
firefox-debuginfo-3.6.7-2.el5.i386.rpm
xulrunner-1.9.2.7-2.el5.i386.rpm
xulrunner-debuginfo-1.9.2.7-2.el5.i386.rpm
xulrunner-devel-1.9.2.7-2.el5.i386.rpm

x86_64:
firefox-3.6.7-2.el5.i386.rpm
firefox-3.6.7-2.el5.x86_64.rpm
firefox-debuginfo-3.6.7-2.el5.i386.rpm
firefox-debuginfo-3.6.7-2.el5.x86_64.rpm
xulrunner-1.9.2.7-2.el5.i386.rpm
xulrunner-1.9.2.7-2.el5.x86_64.rpm
xulrunner-debuginfo-1.9.2.7-2.el5.i386.rpm
xulrunner-debuginfo-1.9.2.7-2.el5.x86_64.rpm

RHEL Desktop Workstation (v. 5 client):

Source:
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Client/en/os/SRPMS/xulrunner-1.9.2.7-2.el5.src.rpm

i386:
xulrunner-debuginfo-1.9.2.7-2.el5.i386.rpm
xulrunner-devel-1.9.2.7-2.el5.i386.rpm

x86_64:
xulrunner-debuginfo-1.9.2.7-2.el5.i386.rpm
xulrunner-debuginfo-1.9.2.7-2.el5.x86_64.rpm
xulrunner-devel-1.9.2.7-2.el5.i386.rpm
xulrunner-devel-1.9.2.7-2.el5.x86_64.rpm

Red Hat Enterprise Linux (v. 5 server):

Source:
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Server/en/os/SRPMS/firefox-3.6.7-2.el5.src.rpm
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Server/en/os/SRPMS/xulrunner-1.9.2.7-2.el5.src.rpm

i386:
firefox-3.6.7-2.el5.i386.rpm
firefox-debuginfo-3.6.7-2.el5.i386.rpm
xulrunner-1.9.2.7-2.el5.i386.rpm
xulrunner-debuginfo-1.9.2.7-2.el5.i386.rpm
xulrunner-devel-1.9.2.7-2.el5.i386.rpm

ia64:
firefox-3.6.7-2.el5.ia64.rpm
firefox-debuginfo-3.6.7-2.el5.ia64.rpm
xulrunner-1.9.2.7-2.el5.ia64.rpm
xulrunner-debuginfo-1.9.2.7-2.el5.ia64.rpm
xulrunner-devel-1.9.2.7-2.el5.ia64.rpm

ppc:
firefox-3.6.7-2.el5.ppc.rpm
firefox-debuginfo-3.6.7-2.el5.ppc.rpm
xulrunner-1.9.2.7-2.el5.ppc.rpm
xulrunner-1.9.2.7-2.el5.ppc64.rpm
xulrunner-debuginfo-1.9.2.7-2.el5.ppc.rpm
xulrunner-debuginfo-1.9.2.7-2.el5.ppc64.rpm
xulrunner-devel-1.9.2.7-2.el5.ppc.rpm
xulrunner-devel-1.9.2.7-2.el5.ppc64.rpm

s390x:
firefox-3.6.7-2.el5.s390.rpm
firefox-3.6.7-2.el5.s390x.rpm
firefox-debuginfo-3.6.7-2.el5.s390.rpm
firefox-debuginfo-3.6.7-2.el5.s390x.rpm
xulrunner-1.9.2.7-2.el5.s390.rpm
xulrunner-1.9.2.7-2.el5.s390x.rpm
xulrunner-debuginfo-1.9.2.7-2.el5.s390.rpm
xulrunner-debuginfo-1.9.2.7-2.el5.s390x.rpm
xulrunner-devel-1.9.2.7-2.el5.s390.rpm
xulrunner-devel-1.9.2.7-2.el5.s390x.rpm

x86_64:
firefox-3.6.7-2.el5.i386.rpm
firefox-3.6.7-2.el5.x86_64.rpm
firefox-debuginfo-3.6.7-2.el5.i386.rpm
firefox-debuginfo-3.6.7-2.el5.x86_64.rpm
xulrunner-1.9.2.7-2.el5.i386.rpm
xulrunner-1.9.2.7-2.el5.x86_64.rpm
xulrunner-debuginfo-1.9.2.7-2.el5.i386.rpm
xulrunner-debuginfo-1.9.2.7-2.el5.x86_64.rpm
xulrunner-devel-1.9.2.7-2.el5.i386.rpm
xulrunner-devel-1.9.2.7-2.el5.x86_64.rpm

These packages are GPG signed by Red Hat for security. Our key and
details on how to verify the signature are available from
https://www.redhat.com/security/team/key/#package

7. References:

https://www.redhat.com/security/data/cve/CVE-2010-0654.html
https://www.redhat.com/security/data/cve/CVE-2010-1205.html
https://www.redhat.com/security/data/cve/CVE-2010-1206.html
https://www.redhat.com/security/data/cve/CVE-2010-1207.html
https://www.redhat.com/security/data/cve/CVE-2010-1208.html
https://www.redhat.com/security/data/cve/CVE-2010-1209.html
https://www.redhat.com/security/data/cve/CVE-2010-1210.html
https://www.redhat.com/security/data/cve/CVE-2010-1211.html
https://www.redhat.com/security/data/cve/CVE-2010-1212.html
https://www.redhat.com/security/data/cve/CVE-2010-1213.html
https://www.redhat.com/security/data/cve/CVE-2010-1214.html
https://www.redhat.com/security/data/cve/CVE-2010-1215.html
https://www.redhat.com/security/data/cve/CVE-2010-2751.html
https://www.redhat.com/security/data/cve/CVE-2010-2752.html
https://www.redhat.com/security/data/cve/CVE-2010-2753.html
https://www.redhat.com/security/data/cve/CVE-2010-2754.html
http://www.redhat.com/security/updates/classification/#critical
http://www.mozilla.org/security/known-vulnerabilities/firefox36.html#firefox3.6.7

8. Contact:

The Red Hat security contact is . More contact
details at https://www.redhat.com/security/team/contact/

Copyright 2010 Red Hat, Inc.


[RHSA-2010:0546-01] Critical: seamonkey security update
=====================================================================
Red Hat Security Advisory

Synopsis: Critical: seamonkey security update
Advisory ID: RHSA-2010:0546-01
Product: Red Hat Enterprise Linux
Advisory URL: https://rhn.redhat.com/errata/RHSA-2010-0546.html
Issue date: 2010-07-20
CVE Names: CVE-2010-1205 CVE-2010-1211 CVE-2010-1214
CVE-2010-2751 CVE-2010-2753 CVE-2010-2754
=====================================================================

1. Summary:

Updated seamonkey packages that fix several security issues are now
available for Red Hat Enterprise Linux 3 and 4.

The Red Hat Security Response Team has rated this update as having critical
security impact. Common Vulnerability Scoring System (CVSS) base scores,
which give detailed severity ratings, are available for each vulnerability
from the CVE links in the References section.

2. Relevant releases/architectures:

Red Hat Desktop version 3 - i386, x86_64
Red Hat Enterprise Linux AS version 3 - i386, ia64, ppc, s390, s390x, x86_64
Red Hat Enterprise Linux AS version 4 - i386, ia64, ppc, s390, s390x, x86_64
Red Hat Enterprise Linux Desktop version 4 - i386, x86_64
Red Hat Enterprise Linux ES version 3 - i386, ia64, x86_64
Red Hat Enterprise Linux ES version 4 - i386, ia64, x86_64
Red Hat Enterprise Linux WS version 3 - i386, ia64, x86_64
Red Hat Enterprise Linux WS version 4 - i386, ia64, x86_64

3. Description:

SeaMonkey is an open source web browser, email and newsgroup client, IRC
chat client, and HTML editor.

Several flaws were found in the processing of malformed web content. A web
page containing malicious content could cause SeaMonkey to crash or,
potentially, execute arbitrary code with the privileges of the user running
SeaMonkey. (CVE-2010-1211, CVE-2010-2753, CVE-2010-1214)

A memory corruption flaw was found in the way SeaMonkey decoded certain PNG
images. An attacker could create a specially-crafted PNG image that, when
opened, could cause SeaMonkey to crash or, potentially, execute arbitrary
code with the privileges of the user running SeaMonkey. (CVE-2010-1205)

A same-origin policy bypass flaw was found in SeaMonkey. An attacker could
create a malicious web page that, when viewed by a victim, could steal
private data from a different website the victim has loaded with SeaMonkey.
(CVE-2010-2754)

A flaw was found in the way SeaMonkey displayed the location bar when
visiting a secure web page. A malicious server could use this flaw to
present data that appears to originate from a secure server, even though it
does not. (CVE-2010-2751)

All SeaMonkey users should upgrade to these updated packages, which correct
these issues. After installing the update, SeaMonkey must be restarted for
the changes to take effect.

4. Solution:

Before applying this update, make sure all previously-released errata
relevant to your system have been applied.

This update is available via the Red Hat Network. Details on how to
use the Red Hat Network to apply this update are available at
http://kbase.redhat.com/faq/docs/DOC-11259

5. Bugs fixed (http://bugzilla.redhat.com/):

608238 - CVE-2010-1205 libpng: out-of-bounds memory write
615455 - CVE-2010-1211 Mozilla miscellaneous memory safety hazards
615462 - CVE-2010-1214 Mozilla Plugin parameter EnsureCachedAttrParamArrays remote code execution vulnerability
615466 - CVE-2010-2753 Mozilla nsTreeSelection dangling pointer remote code execution vulnerability
615480 - CVE-2010-2751 Mozilla SSL spoofing with history.back() and history.forward()
615488 - CVE-2010-2754 Mozilla Cross-origin data leakage from script filename in error messages

6. Package List:

Red Hat Enterprise Linux AS version 3:

Source:
ftp://updates.redhat.com/enterprise/3AS/en/os/SRPMS/seamonkey-1.0.9-0.57.el3.src.rpm

i386:
seamonkey-1.0.9-0.57.el3.i386.rpm
seamonkey-chat-1.0.9-0.57.el3.i386.rpm
seamonkey-debuginfo-1.0.9-0.57.el3.i386.rpm
seamonkey-devel-1.0.9-0.57.el3.i386.rpm
seamonkey-dom-inspector-1.0.9-0.57.el3.i386.rpm
seamonkey-js-debugger-1.0.9-0.57.el3.i386.rpm
seamonkey-mail-1.0.9-0.57.el3.i386.rpm
seamonkey-nspr-1.0.9-0.57.el3.i386.rpm
seamonkey-nspr-devel-1.0.9-0.57.el3.i386.rpm
seamonkey-nss-1.0.9-0.57.el3.i386.rpm
seamonkey-nss-devel-1.0.9-0.57.el3.i386.rpm

ia64:
seamonkey-1.0.9-0.57.el3.ia64.rpm
seamonkey-chat-1.0.9-0.57.el3.ia64.rpm
seamonkey-debuginfo-1.0.9-0.57.el3.i386.rpm
seamonkey-debuginfo-1.0.9-0.57.el3.ia64.rpm
seamonkey-devel-1.0.9-0.57.el3.ia64.rpm
seamonkey-dom-inspector-1.0.9-0.57.el3.ia64.rpm
seamonkey-js-debugger-1.0.9-0.57.el3.ia64.rpm
seamonkey-mail-1.0.9-0.57.el3.ia64.rpm
seamonkey-nspr-1.0.9-0.57.el3.i386.rpm
seamonkey-nspr-1.0.9-0.57.el3.ia64.rpm
seamonkey-nspr-devel-1.0.9-0.57.el3.ia64.rpm
seamonkey-nss-1.0.9-0.57.el3.i386.rpm
seamonkey-nss-1.0.9-0.57.el3.ia64.rpm
seamonkey-nss-devel-1.0.9-0.57.el3.ia64.rpm

ppc:
seamonkey-1.0.9-0.57.el3.ppc.rpm
seamonkey-chat-1.0.9-0.57.el3.ppc.rpm
seamonkey-debuginfo-1.0.9-0.57.el3.ppc.rpm
seamonkey-devel-1.0.9-0.57.el3.ppc.rpm
seamonkey-dom-inspector-1.0.9-0.57.el3.ppc.rpm
seamonkey-js-debugger-1.0.9-0.57.el3.ppc.rpm
seamonkey-mail-1.0.9-0.57.el3.ppc.rpm
seamonkey-nspr-1.0.9-0.57.el3.ppc.rpm
seamonkey-nspr-devel-1.0.9-0.57.el3.ppc.rpm
seamonkey-nss-1.0.9-0.57.el3.ppc.rpm
seamonkey-nss-devel-1.0.9-0.57.el3.ppc.rpm

s390:
seamonkey-1.0.9-0.57.el3.s390.rpm
seamonkey-chat-1.0.9-0.57.el3.s390.rpm
seamonkey-debuginfo-1.0.9-0.57.el3.s390.rpm
seamonkey-devel-1.0.9-0.57.el3.s390.rpm
seamonkey-dom-inspector-1.0.9-0.57.el3.s390.rpm
seamonkey-js-debugger-1.0.9-0.57.el3.s390.rpm
seamonkey-mail-1.0.9-0.57.el3.s390.rpm
seamonkey-nspr-1.0.9-0.57.el3.s390.rpm
seamonkey-nspr-devel-1.0.9-0.57.el3.s390.rpm
seamonkey-nss-1.0.9-0.57.el3.s390.rpm
seamonkey-nss-devel-1.0.9-0.57.el3.s390.rpm

s390x:
seamonkey-1.0.9-0.57.el3.s390x.rpm
seamonkey-chat-1.0.9-0.57.el3.s390x.rpm
seamonkey-debuginfo-1.0.9-0.57.el3.s390.rpm
seamonkey-debuginfo-1.0.9-0.57.el3.s390x.rpm
seamonkey-devel-1.0.9-0.57.el3.s390x.rpm
seamonkey-dom-inspector-1.0.9-0.57.el3.s390x.rpm
seamonkey-js-debugger-1.0.9-0.57.el3.s390x.rpm
seamonkey-mail-1.0.9-0.57.el3.s390x.rpm
seamonkey-nspr-1.0.9-0.57.el3.s390.rpm
seamonkey-nspr-1.0.9-0.57.el3.s390x.rpm
seamonkey-nspr-devel-1.0.9-0.57.el3.s390x.rpm
seamonkey-nss-1.0.9-0.57.el3.s390.rpm
seamonkey-nss-1.0.9-0.57.el3.s390x.rpm
seamonkey-nss-devel-1.0.9-0.57.el3.s390x.rpm

x86_64:
seamonkey-1.0.9-0.57.el3.i386.rpm
seamonkey-1.0.9-0.57.el3.x86_64.rpm
seamonkey-chat-1.0.9-0.57.el3.x86_64.rpm
seamonkey-debuginfo-1.0.9-0.57.el3.i386.rpm
seamonkey-debuginfo-1.0.9-0.57.el3.x86_64.rpm
seamonkey-devel-1.0.9-0.57.el3.x86_64.rpm
seamonkey-dom-inspector-1.0.9-0.57.el3.x86_64.rpm
seamonkey-js-debugger-1.0.9-0.57.el3.x86_64.rpm
seamonkey-mail-1.0.9-0.57.el3.x86_64.rpm
seamonkey-nspr-1.0.9-0.57.el3.i386.rpm
seamonkey-nspr-1.0.9-0.57.el3.x86_64.rpm
seamonkey-nspr-devel-1.0.9-0.57.el3.x86_64.rpm
seamonkey-nss-1.0.9-0.57.el3.i386.rpm
seamonkey-nss-1.0.9-0.57.el3.x86_64.rpm
seamonkey-nss-devel-1.0.9-0.57.el3.x86_64.rpm

Red Hat Desktop version 3:

Source:
ftp://updates.redhat.com/enterprise/3desktop/en/os/SRPMS/seamonkey-1.0.9-0.57.el3.src.rpm

i386:
seamonkey-1.0.9-0.57.el3.i386.rpm
seamonkey-chat-1.0.9-0.57.el3.i386.rpm
seamonkey-debuginfo-1.0.9-0.57.el3.i386.rpm
seamonkey-devel-1.0.9-0.57.el3.i386.rpm
seamonkey-dom-inspector-1.0.9-0.57.el3.i386.rpm
seamonkey-js-debugger-1.0.9-0.57.el3.i386.rpm
seamonkey-mail-1.0.9-0.57.el3.i386.rpm
seamonkey-nspr-1.0.9-0.57.el3.i386.rpm
seamonkey-nspr-devel-1.0.9-0.57.el3.i386.rpm
seamonkey-nss-1.0.9-0.57.el3.i386.rpm
seamonkey-nss-devel-1.0.9-0.57.el3.i386.rpm

x86_64:
seamonkey-1.0.9-0.57.el3.i386.rpm
seamonkey-1.0.9-0.57.el3.x86_64.rpm
seamonkey-chat-1.0.9-0.57.el3.x86_64.rpm
seamonkey-debuginfo-1.0.9-0.57.el3.i386.rpm
seamonkey-debuginfo-1.0.9-0.57.el3.x86_64.rpm
seamonkey-devel-1.0.9-0.57.el3.x86_64.rpm
seamonkey-dom-inspector-1.0.9-0.57.el3.x86_64.rpm
seamonkey-js-debugger-1.0.9-0.57.el3.x86_64.rpm
seamonkey-mail-1.0.9-0.57.el3.x86_64.rpm
seamonkey-nspr-1.0.9-0.57.el3.i386.rpm
seamonkey-nspr-1.0.9-0.57.el3.x86_64.rpm
seamonkey-nspr-devel-1.0.9-0.57.el3.x86_64.rpm
seamonkey-nss-1.0.9-0.57.el3.i386.rpm
seamonkey-nss-1.0.9-0.57.el3.x86_64.rpm
seamonkey-nss-devel-1.0.9-0.57.el3.x86_64.rpm

Red Hat Enterprise Linux ES version 3:

Source:
ftp://updates.redhat.com/enterprise/3ES/en/os/SRPMS/seamonkey-1.0.9-0.57.el3.src.rpm

i386:
seamonkey-1.0.9-0.57.el3.i386.rpm
seamonkey-chat-1.0.9-0.57.el3.i386.rpm
seamonkey-debuginfo-1.0.9-0.57.el3.i386.rpm
seamonkey-devel-1.0.9-0.57.el3.i386.rpm
seamonkey-dom-inspector-1.0.9-0.57.el3.i386.rpm
seamonkey-js-debugger-1.0.9-0.57.el3.i386.rpm
seamonkey-mail-1.0.9-0.57.el3.i386.rpm
seamonkey-nspr-1.0.9-0.57.el3.i386.rpm
seamonkey-nspr-devel-1.0.9-0.57.el3.i386.rpm
seamonkey-nss-1.0.9-0.57.el3.i386.rpm
seamonkey-nss-devel-1.0.9-0.57.el3.i386.rpm

ia64:
seamonkey-1.0.9-0.57.el3.ia64.rpm
seamonkey-chat-1.0.9-0.57.el3.ia64.rpm
seamonkey-debuginfo-1.0.9-0.57.el3.i386.rpm
seamonkey-debuginfo-1.0.9-0.57.el3.ia64.rpm
seamonkey-devel-1.0.9-0.57.el3.ia64.rpm
seamonkey-dom-inspector-1.0.9-0.57.el3.ia64.rpm
seamonkey-js-debugger-1.0.9-0.57.el3.ia64.rpm
seamonkey-mail-1.0.9-0.57.el3.ia64.rpm
seamonkey-nspr-1.0.9-0.57.el3.i386.rpm
seamonkey-nspr-1.0.9-0.57.el3.ia64.rpm
seamonkey-nspr-devel-1.0.9-0.57.el3.ia64.rpm
seamonkey-nss-1.0.9-0.57.el3.i386.rpm
seamonkey-nss-1.0.9-0.57.el3.ia64.rpm
seamonkey-nss-devel-1.0.9-0.57.el3.ia64.rpm

x86_64:
seamonkey-1.0.9-0.57.el3.i386.rpm
seamonkey-1.0.9-0.57.el3.x86_64.rpm
seamonkey-chat-1.0.9-0.57.el3.x86_64.rpm
seamonkey-debuginfo-1.0.9-0.57.el3.i386.rpm
seamonkey-debuginfo-1.0.9-0.57.el3.x86_64.rpm
seamonkey-devel-1.0.9-0.57.el3.x86_64.rpm
seamonkey-dom-inspector-1.0.9-0.57.el3.x86_64.rpm
seamonkey-js-debugger-1.0.9-0.57.el3.x86_64.rpm
seamonkey-mail-1.0.9-0.57.el3.x86_64.rpm
seamonkey-nspr-1.0.9-0.57.el3.i386.rpm
seamonkey-nspr-1.0.9-0.57.el3.x86_64.rpm
seamonkey-nspr-devel-1.0.9-0.57.el3.x86_64.rpm
seamonkey-nss-1.0.9-0.57.el3.i386.rpm
seamonkey-nss-1.0.9-0.57.el3.x86_64.rpm
seamonkey-nss-devel-1.0.9-0.57.el3.x86_64.rpm

Red Hat Enterprise Linux WS version 3:

Source:
ftp://updates.redhat.com/enterprise/3WS/en/os/SRPMS/seamonkey-1.0.9-0.57.el3.src.rpm

i386:
seamonkey-1.0.9-0.57.el3.i386.rpm
seamonkey-chat-1.0.9-0.57.el3.i386.rpm
seamonkey-debuginfo-1.0.9-0.57.el3.i386.rpm
seamonkey-devel-1.0.9-0.57.el3.i386.rpm
seamonkey-dom-inspector-1.0.9-0.57.el3.i386.rpm
seamonkey-js-debugger-1.0.9-0.57.el3.i386.rpm
seamonkey-mail-1.0.9-0.57.el3.i386.rpm
seamonkey-nspr-1.0.9-0.57.el3.i386.rpm
seamonkey-nspr-devel-1.0.9-0.57.el3.i386.rpm
seamonkey-nss-1.0.9-0.57.el3.i386.rpm
seamonkey-nss-devel-1.0.9-0.57.el3.i386.rpm

ia64:
seamonkey-1.0.9-0.57.el3.ia64.rpm
seamonkey-chat-1.0.9-0.57.el3.ia64.rpm
seamonkey-debuginfo-1.0.9-0.57.el3.i386.rpm
seamonkey-debuginfo-1.0.9-0.57.el3.ia64.rpm
seamonkey-devel-1.0.9-0.57.el3.ia64.rpm
seamonkey-dom-inspector-1.0.9-0.57.el3.ia64.rpm
seamonkey-js-debugger-1.0.9-0.57.el3.ia64.rpm
seamonkey-mail-1.0.9-0.57.el3.ia64.rpm
seamonkey-nspr-1.0.9-0.57.el3.i386.rpm
seamonkey-nspr-1.0.9-0.57.el3.ia64.rpm
seamonkey-nspr-devel-1.0.9-0.57.el3.ia64.rpm
seamonkey-nss-1.0.9-0.57.el3.i386.rpm
seamonkey-nss-1.0.9-0.57.el3.ia64.rpm
seamonkey-nss-devel-1.0.9-0.57.el3.ia64.rpm

x86_64:
seamonkey-1.0.9-0.57.el3.i386.rpm
seamonkey-1.0.9-0.57.el3.x86_64.rpm
seamonkey-chat-1.0.9-0.57.el3.x86_64.rpm
seamonkey-debuginfo-1.0.9-0.57.el3.i386.rpm
seamonkey-debuginfo-1.0.9-0.57.el3.x86_64.rpm
seamonkey-devel-1.0.9-0.57.el3.x86_64.rpm
seamonkey-dom-inspector-1.0.9-0.57.el3.x86_64.rpm
seamonkey-js-debugger-1.0.9-0.57.el3.x86_64.rpm
seamonkey-mail-1.0.9-0.57.el3.x86_64.rpm
seamonkey-nspr-1.0.9-0.57.el3.i386.rpm
seamonkey-nspr-1.0.9-0.57.el3.x86_64.rpm
seamonkey-nspr-devel-1.0.9-0.57.el3.x86_64.rpm
seamonkey-nss-1.0.9-0.57.el3.i386.rpm
seamonkey-nss-1.0.9-0.57.el3.x86_64.rpm
seamonkey-nss-devel-1.0.9-0.57.el3.x86_64.rpm

Red Hat Enterprise Linux AS version 4:

Source:
ftp://updates.redhat.com/enterprise/4AS/en/os/SRPMS/seamonkey-1.0.9-60.el4.src.rpm

i386:
seamonkey-1.0.9-60.el4.i386.rpm
seamonkey-chat-1.0.9-60.el4.i386.rpm
seamonkey-debuginfo-1.0.9-60.el4.i386.rpm
seamonkey-devel-1.0.9-60.el4.i386.rpm
seamonkey-dom-inspector-1.0.9-60.el4.i386.rpm
seamonkey-js-debugger-1.0.9-60.el4.i386.rpm
seamonkey-mail-1.0.9-60.el4.i386.rpm

ia64:
seamonkey-1.0.9-60.el4.ia64.rpm
seamonkey-chat-1.0.9-60.el4.ia64.rpm
seamonkey-debuginfo-1.0.9-60.el4.ia64.rpm
seamonkey-devel-1.0.9-60.el4.ia64.rpm
seamonkey-dom-inspector-1.0.9-60.el4.ia64.rpm
seamonkey-js-debugger-1.0.9-60.el4.ia64.rpm
seamonkey-mail-1.0.9-60.el4.ia64.rpm

ppc:
seamonkey-1.0.9-60.el4.ppc.rpm
seamonkey-chat-1.0.9-60.el4.ppc.rpm
seamonkey-debuginfo-1.0.9-60.el4.ppc.rpm
seamonkey-devel-1.0.9-60.el4.ppc.rpm
seamonkey-dom-inspector-1.0.9-60.el4.ppc.rpm
seamonkey-js-debugger-1.0.9-60.el4.ppc.rpm
seamonkey-mail-1.0.9-60.el4.ppc.rpm

s390:
seamonkey-1.0.9-60.el4.s390.rpm
seamonkey-chat-1.0.9-60.el4.s390.rpm
seamonkey-debuginfo-1.0.9-60.el4.s390.rpm
seamonkey-devel-1.0.9-60.el4.s390.rpm
seamonkey-dom-inspector-1.0.9-60.el4.s390.rpm
seamonkey-js-debugger-1.0.9-60.el4.s390.rpm
seamonkey-mail-1.0.9-60.el4.s390.rpm

s390x:
seamonkey-1.0.9-60.el4.s390x.rpm
seamonkey-chat-1.0.9-60.el4.s390x.rpm
seamonkey-debuginfo-1.0.9-60.el4.s390x.rpm
seamonkey-devel-1.0.9-60.el4.s390x.rpm
seamonkey-dom-inspector-1.0.9-60.el4.s390x.rpm
seamonkey-js-debugger-1.0.9-60.el4.s390x.rpm
seamonkey-mail-1.0.9-60.el4.s390x.rpm

x86_64:
seamonkey-1.0.9-60.el4.x86_64.rpm
seamonkey-chat-1.0.9-60.el4.x86_64.rpm
seamonkey-debuginfo-1.0.9-60.el4.x86_64.rpm
seamonkey-devel-1.0.9-60.el4.x86_64.rpm
seamonkey-dom-inspector-1.0.9-60.el4.x86_64.rpm
seamonkey-js-debugger-1.0.9-60.el4.x86_64.rpm
seamonkey-mail-1.0.9-60.el4.x86_64.rpm

Red Hat Enterprise Linux Desktop version 4:

Source:
ftp://updates.redhat.com/enterprise/4Desktop/en/os/SRPMS/seamonkey-1.0.9-60.el4.src.rpm

i386:
seamonkey-1.0.9-60.el4.i386.rpm
seamonkey-chat-1.0.9-60.el4.i386.rpm
seamonkey-debuginfo-1.0.9-60.el4.i386.rpm
seamonkey-devel-1.0.9-60.el4.i386.rpm
seamonkey-dom-inspector-1.0.9-60.el4.i386.rpm
seamonkey-js-debugger-1.0.9-60.el4.i386.rpm
seamonkey-mail-1.0.9-60.el4.i386.rpm

x86_64:
seamonkey-1.0.9-60.el4.x86_64.rpm
seamonkey-chat-1.0.9-60.el4.x86_64.rpm
seamonkey-debuginfo-1.0.9-60.el4.x86_64.rpm
seamonkey-devel-1.0.9-60.el4.x86_64.rpm
seamonkey-dom-inspector-1.0.9-60.el4.x86_64.rpm
seamonkey-js-debugger-1.0.9-60.el4.x86_64.rpm
seamonkey-mail-1.0.9-60.el4.x86_64.rpm

Red Hat Enterprise Linux ES version 4:

Source:
ftp://updates.redhat.com/enterprise/4ES/en/os/SRPMS/seamonkey-1.0.9-60.el4.src.rpm

i386:
seamonkey-1.0.9-60.el4.i386.rpm
seamonkey-chat-1.0.9-60.el4.i386.rpm
seamonkey-debuginfo-1.0.9-60.el4.i386.rpm
seamonkey-devel-1.0.9-60.el4.i386.rpm
seamonkey-dom-inspector-1.0.9-60.el4.i386.rpm
seamonkey-js-debugger-1.0.9-60.el4.i386.rpm
seamonkey-mail-1.0.9-60.el4.i386.rpm

ia64:
seamonkey-1.0.9-60.el4.ia64.rpm
seamonkey-chat-1.0.9-60.el4.ia64.rpm
seamonkey-debuginfo-1.0.9-60.el4.ia64.rpm
seamonkey-devel-1.0.9-60.el4.ia64.rpm
seamonkey-dom-inspector-1.0.9-60.el4.ia64.rpm
seamonkey-js-debugger-1.0.9-60.el4.ia64.rpm
seamonkey-mail-1.0.9-60.el4.ia64.rpm

x86_64:
seamonkey-1.0.9-60.el4.x86_64.rpm
seamonkey-chat-1.0.9-60.el4.x86_64.rpm
seamonkey-debuginfo-1.0.9-60.el4.x86_64.rpm
seamonkey-devel-1.0.9-60.el4.x86_64.rpm
seamonkey-dom-inspector-1.0.9-60.el4.x86_64.rpm
seamonkey-js-debugger-1.0.9-60.el4.x86_64.rpm
seamonkey-mail-1.0.9-60.el4.x86_64.rpm

Red Hat Enterprise Linux WS version 4:

Source:
ftp://updates.redhat.com/enterprise/4WS/en/os/SRPMS/seamonkey-1.0.9-60.el4.src.rpm

i386:
seamonkey-1.0.9-60.el4.i386.rpm
seamonkey-chat-1.0.9-60.el4.i386.rpm
seamonkey-debuginfo-1.0.9-60.el4.i386.rpm
seamonkey-devel-1.0.9-60.el4.i386.rpm
seamonkey-dom-inspector-1.0.9-60.el4.i386.rpm
seamonkey-js-debugger-1.0.9-60.el4.i386.rpm
seamonkey-mail-1.0.9-60.el4.i386.rpm

ia64:
seamonkey-1.0.9-60.el4.ia64.rpm
seamonkey-chat-1.0.9-60.el4.ia64.rpm
seamonkey-debuginfo-1.0.9-60.el4.ia64.rpm
seamonkey-devel-1.0.9-60.el4.ia64.rpm
seamonkey-dom-inspector-1.0.9-60.el4.ia64.rpm
seamonkey-js-debugger-1.0.9-60.el4.ia64.rpm
seamonkey-mail-1.0.9-60.el4.ia64.rpm

x86_64:
seamonkey-1.0.9-60.el4.x86_64.rpm
seamonkey-chat-1.0.9-60.el4.x86_64.rpm
seamonkey-debuginfo-1.0.9-60.el4.x86_64.rpm
seamonkey-devel-1.0.9-60.el4.x86_64.rpm
seamonkey-dom-inspector-1.0.9-60.el4.x86_64.rpm
seamonkey-js-debugger-1.0.9-60.el4.x86_64.rpm
seamonkey-mail-1.0.9-60.el4.x86_64.rpm

These packages are GPG signed by Red Hat for security. Our key and
details on how to verify the signature are available from
https://www.redhat.com/security/team/key/#package

7. References:

https://www.redhat.com/security/data/cve/CVE-2010-1205.html
https://www.redhat.com/security/data/cve/CVE-2010-1211.html
https://www.redhat.com/security/data/cve/CVE-2010-1214.html
https://www.redhat.com/security/data/cve/CVE-2010-2751.html
https://www.redhat.com/security/data/cve/CVE-2010-2753.html
https://www.redhat.com/security/data/cve/CVE-2010-2754.html
http://www.redhat.com/security/updates/classification/#critical

8. Contact:

The Red Hat security contact is . More contact
details at https://www.redhat.com/security/team/contact/

Copyright 2010 Red Hat, Inc.


[RHSA-2010:0544-01] Moderate: thunderbird security update
=====================================================================
Red Hat Security Advisory

Synopsis: Moderate: thunderbird security update
Advisory ID: RHSA-2010:0544-01
Product: Red Hat Enterprise Linux
Advisory URL: https://rhn.redhat.com/errata/RHSA-2010-0544.html
Issue date: 2010-07-20
CVE Names: CVE-2010-0174 CVE-2010-0175 CVE-2010-0176
CVE-2010-0177 CVE-2010-1197 CVE-2010-1198
CVE-2010-1199 CVE-2010-1200 CVE-2010-1211
CVE-2010-1214 CVE-2010-2753 CVE-2010-2754
=====================================================================

1. Summary:

An updated thunderbird package that fixes several security issues is now
available for Red Hat Enterprise Linux 4.

The Red Hat Security Response Team has rated this update as having moderate
security impact. Common Vulnerability Scoring System (CVSS) base scores,
which give detailed severity ratings, are available for each vulnerability
from the CVE links in the References section.

2. Relevant releases/architectures:

Red Hat Enterprise Linux AS version 4 - i386, ia64, ppc, s390, s390x, x86_64
Red Hat Enterprise Linux Desktop version 4 - i386, x86_64
Red Hat Enterprise Linux ES version 4 - i386, ia64, x86_64
Red Hat Enterprise Linux WS version 4 - i386, ia64, x86_64

3. Description:

Mozilla Thunderbird is a standalone mail and newsgroup client.

Several flaws were found in the processing of malformed HTML mail content.
An HTML mail message containing malicious content could cause Thunderbird
to crash or, potentially, execute arbitrary code with the privileges of the
user running Thunderbird. (CVE-2010-0174, CVE-2010-1200, CVE-2010-1211,
CVE-2010-1214, CVE-2010-2753)

An integer overflow flaw was found in the processing of malformed HTML mail
content. An HTML mail message containing malicious content could cause
Thunderbird to crash or, potentially, execute arbitrary code with the
privileges of the user running Thunderbird. (CVE-2010-1199)

Several use-after-free flaws were found in Thunderbird. Viewing an HTML
mail message containing malicious content could result in Thunderbird
executing arbitrary code with the privileges of the user running
Thunderbird. (CVE-2010-0175, CVE-2010-0176, CVE-2010-0177)

A flaw was found in the way Thunderbird plug-ins interact. It was possible
for a plug-in to reference the freed memory from a different plug-in,
resulting in the execution of arbitrary code with the privileges of the
user running Thunderbird. (CVE-2010-1198)

A flaw was found in the way Thunderbird handled the "Content-Disposition:
attachment" HTTP header when the "Content-Type: multipart" HTTP header was
also present. Loading remote HTTP content that allows arbitrary uploads and
relies on the "Content-Disposition: attachment" HTTP header to prevent
content from being displayed inline, could be used by an attacker to serve
malicious content to users. (CVE-2010-1197)

A same-origin policy bypass flaw was found in Thunderbird. Remote HTML
content could steal private data from different remote HTML content
Thunderbird has loaded. (CVE-2010-2754)

All Thunderbird users should upgrade to this updated package, which
resolves these issues. All running instances of Thunderbird must be
restarted for the update to take effect.

4. Solution:

Before applying this update, make sure all previously-released errata
relevant to your system have been applied.

This update is available via the Red Hat Network. Details on how to
use the Red Hat Network to apply this update are available at
http://kbase.redhat.com/faq/docs/DOC-11259

5. Bugs fixed (http://bugzilla.redhat.com/):

578147 - CVE-2010-0174 Mozilla crashes with evidence of memory corruption
578149 - CVE-2010-0175 Mozilla remote code execution with use-after-free in nsTreeSelection
578150 - CVE-2010-0176 Mozilla Dangling pointer vulnerability in nsTreeContentView
578152 - CVE-2010-0177 Mozilla Dangling pointer vulnerability in nsPluginArray
590804 - CVE-2010-1200 Mozilla Crashes with evidence of memory corruption
590828 - CVE-2010-1198 Mozilla Freed object reuse across plugin instances
590833 - CVE-2010-1199 Mozilla Integer Overflow in XSLT Node Sorting
590850 - CVE-2010-1197 Mozilla Content-Disposition: attachment ignored if Content-Type: multipart also present
615455 - CVE-2010-1211 Mozilla miscellaneous memory safety hazards
615462 - CVE-2010-1214 Mozilla Plugin parameter EnsureCachedAttrParamArrays remote code execution vulnerability
615466 - CVE-2010-2753 Mozilla nsTreeSelection dangling pointer remote code execution vulnerability
615488 - CVE-2010-2754 Mozilla Cross-origin data leakage from script filename in error messages

6. Package List:

Red Hat Enterprise Linux AS version 4:

Source:
ftp://updates.redhat.com/enterprise/4AS/en/os/SRPMS/thunderbird-1.5.0.12-28.el4.src.rpm

i386:
thunderbird-1.5.0.12-28.el4.i386.rpm
thunderbird-debuginfo-1.5.0.12-28.el4.i386.rpm

ia64:
thunderbird-1.5.0.12-28.el4.ia64.rpm
thunderbird-debuginfo-1.5.0.12-28.el4.ia64.rpm

ppc:
thunderbird-1.5.0.12-28.el4.ppc.rpm
thunderbird-debuginfo-1.5.0.12-28.el4.ppc.rpm

s390:
thunderbird-1.5.0.12-28.el4.s390.rpm
thunderbird-debuginfo-1.5.0.12-28.el4.s390.rpm

s390x:
thunderbird-1.5.0.12-28.el4.s390x.rpm
thunderbird-debuginfo-1.5.0.12-28.el4.s390x.rpm

x86_64:
thunderbird-1.5.0.12-28.el4.x86_64.rpm
thunderbird-debuginfo-1.5.0.12-28.el4.x86_64.rpm

Red Hat Enterprise Linux Desktop version 4:

Source:
ftp://updates.redhat.com/enterprise/4Desktop/en/os/SRPMS/thunderbird-1.5.0.12-28.el4.src.rpm

i386:
thunderbird-1.5.0.12-28.el4.i386.rpm
thunderbird-debuginfo-1.5.0.12-28.el4.i386.rpm

x86_64:
thunderbird-1.5.0.12-28.el4.x86_64.rpm
thunderbird-debuginfo-1.5.0.12-28.el4.x86_64.rpm

Red Hat Enterprise Linux ES version 4:

Source:
ftp://updates.redhat.com/enterprise/4ES/en/os/SRPMS/thunderbird-1.5.0.12-28.el4.src.rpm

i386:
thunderbird-1.5.0.12-28.el4.i386.rpm
thunderbird-debuginfo-1.5.0.12-28.el4.i386.rpm

ia64:
thunderbird-1.5.0.12-28.el4.ia64.rpm
thunderbird-debuginfo-1.5.0.12-28.el4.ia64.rpm

x86_64:
thunderbird-1.5.0.12-28.el4.x86_64.rpm
thunderbird-debuginfo-1.5.0.12-28.el4.x86_64.rpm

Red Hat Enterprise Linux WS version 4:

Source:
ftp://updates.redhat.com/enterprise/4WS/en/os/SRPMS/thunderbird-1.5.0.12-28.el4.src.rpm

i386:
thunderbird-1.5.0.12-28.el4.i386.rpm
thunderbird-debuginfo-1.5.0.12-28.el4.i386.rpm

ia64:
thunderbird-1.5.0.12-28.el4.ia64.rpm
thunderbird-debuginfo-1.5.0.12-28.el4.ia64.rpm

x86_64:
thunderbird-1.5.0.12-28.el4.x86_64.rpm
thunderbird-debuginfo-1.5.0.12-28.el4.x86_64.rpm

These packages are GPG signed by Red Hat for security. Our key and
details on how to verify the signature are available from
https://www.redhat.com/security/team/key/#package

7. References:

https://www.redhat.com/security/data/cve/CVE-2010-0174.html
https://www.redhat.com/security/data/cve/CVE-2010-0175.html
https://www.redhat.com/security/data/cve/CVE-2010-0176.html
https://www.redhat.com/security/data/cve/CVE-2010-0177.html
https://www.redhat.com/security/data/cve/CVE-2010-1197.html
https://www.redhat.com/security/data/cve/CVE-2010-1198.html
https://www.redhat.com/security/data/cve/CVE-2010-1199.html
https://www.redhat.com/security/data/cve/CVE-2010-1200.html
https://www.redhat.com/security/data/cve/CVE-2010-1211.html
https://www.redhat.com/security/data/cve/CVE-2010-1214.html
https://www.redhat.com/security/data/cve/CVE-2010-2753.html
https://www.redhat.com/security/data/cve/CVE-2010-2754.html
http://www.redhat.com/security/updates/classification/#moderate

8. Contact:

The Red Hat security contact is . More contact
details at https://www.redhat.com/security/team/contact/

Copyright 2010 Red Hat, Inc.


[RHSA-2010:0545-01] Critical: thunderbird security update
=====================================================================
Red Hat Security Advisory

Synopsis: Critical: thunderbird security update
Advisory ID: RHSA-2010:0545-01
Product: Red Hat Enterprise Linux
Advisory URL: https://rhn.redhat.com/errata/RHSA-2010-0545.html
Issue date: 2010-07-20
CVE Names: CVE-2010-0174 CVE-2010-0175 CVE-2010-0176
CVE-2010-0177 CVE-2010-1197 CVE-2010-1198
CVE-2010-1199 CVE-2010-1200 CVE-2010-1205
CVE-2010-1211 CVE-2010-1214 CVE-2010-2753
CVE-2010-2754
=====================================================================

1. Summary:

An updated thunderbird package that fixes several security issues is now
available for Red Hat Enterprise Linux 5.

The Red Hat Security Response Team has rated this update as having critical
security impact. Common Vulnerability Scoring System (CVSS) base scores,
which give detailed severity ratings, are available for each vulnerability
from the CVE links in the References section.

2. Relevant releases/architectures:

RHEL Optional Productivity Applications (v. 5 server) - i386, x86_64
Red Hat Enterprise Linux Desktop (v. 5 client) - i386, x86_64

3. Description:

Mozilla Thunderbird is a standalone mail and newsgroup client.

A memory corruption flaw was found in the way Thunderbird decoded certain
PNG images. An attacker could create a mail message containing a
specially-crafted PNG image that, when opened, could cause Thunderbird to
crash or, potentially, execute arbitrary code with the privileges of the
user running Thunderbird. (CVE-2010-1205)

Several flaws were found in the processing of malformed HTML mail content.
An HTML mail message containing malicious content could cause Thunderbird
to crash or, potentially, execute arbitrary code with the privileges of the
user running Thunderbird. (CVE-2010-0174, CVE-2010-1200, CVE-2010-1211,
CVE-2010-1214, CVE-2010-2753)

An integer overflow flaw was found in the processing of malformed HTML mail
content. An HTML mail message containing malicious content could cause
Thunderbird to crash or, potentially, execute arbitrary code with the
privileges of the user running Thunderbird. (CVE-2010-1199)

Several use-after-free flaws were found in Thunderbird. Viewing an HTML
mail message containing malicious content could result in Thunderbird
executing arbitrary code with the privileges of the user running
Thunderbird. (CVE-2010-0175, CVE-2010-0176, CVE-2010-0177)

A flaw was found in the way Thunderbird plug-ins interact. It was possible
for a plug-in to reference the freed memory from a different plug-in,
resulting in the execution of arbitrary code with the privileges of the
user running Thunderbird. (CVE-2010-1198)

A flaw was found in the way Thunderbird handled the "Content-Disposition:
attachment" HTTP header when the "Content-Type: multipart" HTTP header was
also present. Loading remote HTTP content that allows arbitrary uploads and
relies on the "Content-Disposition: attachment" HTTP header to prevent
content from being displayed inline, could be used by an attacker to serve
malicious content to users. (CVE-2010-1197)

A same-origin policy bypass flaw was found in Thunderbird. Remote HTML
content could steal private data from different remote HTML content
Thunderbird has loaded. (CVE-2010-2754)

All Thunderbird users should upgrade to this updated package, which
resolves these issues. All running instances of Thunderbird must be
restarted for the update to take effect.

4. Solution:

Before applying this update, make sure all previously-released errata
relevant to your system have been applied.

This update is available via the Red Hat Network. Details on how to
use the Red Hat Network to apply this update are available at
http://kbase.redhat.com/faq/docs/DOC-11259

5. Bugs fixed (http://bugzilla.redhat.com/):

578147 - CVE-2010-0174 Mozilla crashes with evidence of memory corruption
578149 - CVE-2010-0175 Mozilla remote code execution with use-after-free in nsTreeSelection
578150 - CVE-2010-0176 Mozilla Dangling pointer vulnerability in nsTreeContentView
578152 - CVE-2010-0177 Mozilla Dangling pointer vulnerability in nsPluginArray
590804 - CVE-2010-1200 Mozilla Crashes with evidence of memory corruption
590828 - CVE-2010-1198 Mozilla Freed object reuse across plugin instances
590833 - CVE-2010-1199 Mozilla Integer Overflow in XSLT Node Sorting
590850 - CVE-2010-1197 Mozilla Content-Disposition: attachment ignored if Content-Type: multipart also present
608238 - CVE-2010-1205 libpng: out-of-bounds memory write
615455 - CVE-2010-1211 Mozilla miscellaneous memory safety hazards
615462 - CVE-2010-1214 Mozilla Plugin parameter EnsureCachedAttrParamArrays remote code execution vulnerability
615466 - CVE-2010-2753 Mozilla nsTreeSelection dangling pointer remote code execution vulnerability
615488 - CVE-2010-2754 Mozilla Cross-origin data leakage from script filename in error messages

6. Package List:

Red Hat Enterprise Linux Desktop (v. 5 client):

Source:
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Client/en/os/SRPMS/thunderbird-2.0.0.24-6.el5.src.rpm

i386:
thunderbird-2.0.0.24-6.el5.i386.rpm
thunderbird-debuginfo-2.0.0.24-6.el5.i386.rpm

x86_64:
thunderbird-2.0.0.24-6.el5.x86_64.rpm
thunderbird-debuginfo-2.0.0.24-6.el5.x86_64.rpm

RHEL Optional Productivity Applications (v. 5 server):

Source:
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Server/en/os/SRPMS/thunderbird-2.0.0.24-6.el5.src.rpm

i386:
thunderbird-2.0.0.24-6.el5.i386.rpm
thunderbird-debuginfo-2.0.0.24-6.el5.i386.rpm

x86_64:
thunderbird-2.0.0.24-6.el5.x86_64.rpm
thunderbird-debuginfo-2.0.0.24-6.el5.x86_64.rpm

These packages are GPG signed by Red Hat for security. Our key and
details on how to verify the signature are available from
https://www.redhat.com/security/team/key/#package

7. References:

https://www.redhat.com/security/data/cve/CVE-2010-0174.html
https://www.redhat.com/security/data/cve/CVE-2010-0175.html
https://www.redhat.com/security/data/cve/CVE-2010-0176.html
https://www.redhat.com/security/data/cve/CVE-2010-0177.html
https://www.redhat.com/security/data/cve/CVE-2010-1197.html
https://www.redhat.com/security/data/cve/CVE-2010-1198.html
https://www.redhat.com/security/data/cve/CVE-2010-1199.html
https://www.redhat.com/security/data/cve/CVE-2010-1200.html
https://www.redhat.com/security/data/cve/CVE-2010-1205.html
https://www.redhat.com/security/data/cve/CVE-2010-1211.html
https://www.redhat.com/security/data/cve/CVE-2010-1214.html
https://www.redhat.com/security/data/cve/CVE-2010-2753.html
https://www.redhat.com/security/data/cve/CVE-2010-2754.html
http://www.redhat.com/security/updates/classification/#critical

8. Contact:

The Red Hat security contact is . More contact
details at https://www.redhat.com/security/team/contact/

Copyright 2010 Red Hat, Inc.



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/firefoxseamonkeythunderbird_update_for_rhel.html)