Fedora Core 2 Update: exim-4.43-1.FC2.1
Posted on: 01/06/2005 07:55 PM

A exim security update is available for Fedora Core 2

---------------------------------------------------------------------
Fedora Update Notification
FEDORA-2005-001
2005-01-06
---------------------------------------------------------------------

Product : Fedora Core 2
Name : exim
Version : 4.43

Release : 1.FC2.1

Summary : The exim mail transfer agent
Description :
Exim is a mail transport agent (MTA) developed at the University of Cambridge for use on Unix systems connected to the Internet. In style it is similar to Smail 3, but its facilities are more extensive, and in particular it has options for verifying incoming sender and recipient addresses, for refusing mail from specified hosts, networks, or senders, and for controlling mail relaying. Exim is in production use at quite a few sites, some of which move hundreds of thousands of messages per day.

Exiscan is compiled in to allow inbuilt scanning capability. See http://duncanthrax.net/exiscan-acl/

---------------------------------------------------------------------
Update Information:

This erratum fixes two relatively minor security issues which were discovered in Exim in the last few weeks. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the names CAN-2005-0021 and CAN-2005-0022 to these, respectively.

1. The function host_aton() can overflow a buffer if it is presented with an illegal IPv6 address that has more than 8 components.

2. The second report described a buffer overflow in the function spa_base64_to_bits(), which is part of the code for SPA authentication. This code originated in the Samba project. The overflow can be exploited only if you are using SPA authentication.

---------------------------------------------------------------------
* Tue Jan 04 2005 David Woodhouse dwmw2@redhat.com 4.43-1.FC2.1

- Fix buffer overflows (CAN-2005-0021, CAN-2005-0022)
- Demonstrate SASL auth configuration in default config file
- Enable TLS and provide certificate if necessary
- Don't reject all GB2312 charset mail by default

---------------------------------------------------------------------
This update can be downloaded from:
http://download.fedora.redhat.com/pub/fedora/linux/core/updates/2/

c962c75145017206cde8c67fd7a56eb7 SRPMS/exim-4.43-1.FC2.1.src.rpm
a533e222f4ff2beb0536daf177def1b8 x86_64/exim-4.43-1.FC2.1.x86_64.rpm
c0639fcca5b8bbca2e753155a2c34532 x86_64/exim-mon-4.43-1.FC2.1.x86_64.rpm
7fe11efcfb57bf044d0bf2f09c53f6f2 x86_64/exim-doc-4.43-1.FC2.1.x86_64.rpm
b28149b3e7e2fed0dee72e30ad39a52b x86_64/exim-sa-4.43-1.FC2.1.x86_64.rpm
283a93d612b65e2a514ba6fc8131677d x86_64/debug/exim-debuginfo-4.43-1.FC2.1.
x86_64.rpm
f2d1181933fa6f6b34cd1ae71bee16a4 i386/exim-4.43-1.FC2.1.i386.rpm
628be45b2a947f7579c4dd068ac45bf1 i386/exim-mon-4.43-1.FC2.1.i386.rpm
16f125efa84916c076586c01ba6d4e8c i386/exim-doc-4.43-1.FC2.1.i386.rpm
c94d60d7d71b6dffe3a06967c45ce79f i386/exim-sa-4.43-1.FC2.1.i386.rpm
e7233593925bf8a0003a9ca7c74c2bdd i386/debug/exim-debuginfo-4.43-1.FC2.1.i3
86.rpm

This update can also be installed with the Update Agent; you can launch the Update Agent with the 'up2date' command.


Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/fedora_core_2_update_exim_443_1fc21.html)