DSA 901-1: New gnump3d packages fix several vulnerabilities
Posted on: 11/19/2005 09:22 AM

The Debian Security Team published a new security update for Debian GNU/Linux. Here the announcement:

Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 901-1 security@debian.org
http://www.debian.org/security/ Martin Schulze
November 19th, 2005 http://www.debian.org/security/faq
- --------------------------------------------------------------------------

Package : gnump3d
Vulnerability : programming error
Problem type : remote
Debian-specific: no
CVE IDs : CVE-2005-3349 CVE-2005-3355

Several vulnerabilities have been discovered in gnump3d, a streaming
server for MP3 and OGG files. The Common Vulnerabilities and
Exposures Project identifies the following problems:


Ludwig Nussel discovered several temporary files that are created
with predictable filenames in an insecure fashion and allows local
attackers to craft symlink attacks.


Ludwig Nussel discovered that the theme parameter to HTTP
requests may be used for path traversal.

The old stable distribution (woody) does not contain a gnump3d package.

For the stable distribution (sarge) these problems have been fixed in
version 2.9.3-1sarge3.

For the unstable distribution (sid) these problems have been fixed in
version 2.9.8-1.

We recommend that you upgrade your gnump3 package.

Upgrade Instructions
- --------------------

wget url
will fetch the file for you
dpkg -i file.deb
will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
will update the internal database
apt-get upgrade
will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.

Debian GNU/Linux 3.1 alias sarge
- --------------------------------

Source archives:

Size/MD5 checksum: 575 49b982ffa8bc0981063c22e43e37d8e0
Size/MD5 checksum: 16233 c719d2a258db442db1523c8f5c06560c
Size/MD5 checksum: 616250 1a0d6a10f6ac2354e1f8c6000665f299

Architecture independent components:

Size/MD5 checksum: 603396 87d0c50400f7cd2d96e4c42982102f7e

These files will probably be moved into the stable distribution on
its next update.

- ---------------------------------------------------------------------------------
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-security dists/stable/updates/main
Mailing list: debian-security-announce@lists.debian.org
Package info: `apt-cache show lt;pkggt;' and http://packages.debian.org/lt;pkggt;

Version: GnuPG v1.4.2 (GNU/Linux)


Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/dsa_901_1_new_gnump3d_packages_fix_several_vulnerabilities.html)