DSA 811-1: New common-lisp-controller packages fix arbitrary code injection
Posted on: 09/14/2005 02:32 AM

The Debian Security Team published a new security update for Debian GNU/Linux. Here the announcement:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 811-1 security@debian.org
http://www.debian.org/security/ Martin Schulze
September 14th, 2005 http://www.debian.org/security/faq
- --------------------------------------------------------------------------

Package : common-lisp-controller
Vulnerability : design error
Problem type : local
Debian-specific: no
CVE ID : CAN-2005-2657

François-René Rideau discovered a bug in common-lisp-controller, a
Common Lisp source and compiler manager, that allows a local user to
compile malicious code into a cache directory which is executed by
another user if that user has not used Common Lisp before.

The old stable distribution (woody) is not affected by this problem.

For the stable distribution (sarge) this problem has been fixed in
version 4.15sarge2.

For the unstable distribution (sid) this problem has been fixed in
version 4.18.

We recommend that you upgrade your common-lisp-controller package.


Upgrade Instructions
- --------------------

wget url
will fetch the file for you
dpkg -i file.deb
will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
will update the internal database
apt-get upgrade
will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.


Debian GNU/Linux 3.1 alias sarge
- --------------------------------

Source archives:

http://security.debian.org/pool/updates/main/c/common-lisp-controller/common-lisp-controller_4.15sarge2.dsc
Size/MD5 checksum: 599 bcb4fb7eb8c11f08446b6e4105f2a822
http://security.debian.org/pool/updates/main/c/common-lisp-controller/common-lisp-controller_4.15sarge2.tar.gz
Size/MD5 checksum: 25058 cdcdf88a0ff8e5bf836769d623e25638

Architecture independent components:

http://security.debian.org/pool/updates/main/c/common-lisp-controller/common-lisp-controller_4.15sarge2_all.deb
Size/MD5 checksum: 24090 156cd8800e862992ff0feed5d8f59a47


These files will probably be moved into the stable distribution on
its next update.

- ---------------------------------------------------------------------------------
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-security dists/stable/updates/main
Mailing list: debian-security-announce@lists.debian.org
Package info: `apt-cache show lt;pkggt;' and http://packages.debian.org/lt;pkggt;

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)

iD8DBQFDJ8F8W5ql+IAeqTIRAmFxAKCkKRgq6/c/ukvMj3ucbDQoc079lwCeLmHP
+7PHLtkoBhYp3qBg3D+kBUY=
=pwqq
-----END PGP SIGNATURE-----



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/dsa_811_1_new_common_lisp_controller_packages_fix_arbitrary_code_injection.html)