DSA 718-1: New ethereal packages fix buffer overflow
Posted on: 04/28/2005 02:08 PM

New ethereal packages are available for Debian GNU/Linux

---------------------------------------------------------------------------
Debian Security Advisory DSA 718-1 security@debian.org
http://www.debian.org/security/ Martin Schulze
April 28th, 2005 http://www.debian.org/security/faq
---------------------------------------------------------------------------

Package : ethereal
Vulnerability : buffer overflow
Problem-Type : remote
Debian-specific: no
CVE ID : CAN-2005-0739

A buffer overflow has been detected in the IAPP dissector of Ethereal, a commonly used network traffic analyser. A remote attacker may be able to overflow a buffer using a specially crafted packet. More problems have been discovered which don't apply to the version in woody but are fixed in sid as well.

For the stable distribution (woody) this problem has been fixed in version 0.9.4-1woody12.

For the unstable distribution (sid) these problems have been fixed in version 0.10.10-1.

We recommend that you upgrade your ethereal packages.

Upgrade Instructions
---------------------

wget url
will fetch the file for you
dpkg -i file.deb
will install the referenced file.

If you are using the apt-get package manager, use the line for sources.list as given below:

apt-get update
will update the internal database
apt-get upgrade
will install corrected packages

You may use an automated update by adding the resources from the footer to the proper configuration.


Debian GNU/Linux 3.0 alias woody
---------------------------------

Source archives:

http://security.debian.org/pool/updates/main/p/prozilla/prozilla_1.3.6-3woody2.dsc
Size/MD5 checksum: 612 b928187dd8f03148a2539d4b3c80b438
http://security.debian.org/pool/updates/main/p/prozilla/prozilla_1.3.6-3woody2.diff.gz
Size/MD5 checksum: 9649 fe452d3b07b843d9bdb0a62eea08b32e
http://security.debian.org/pool/updates/main/p/prozilla/prozilla_1.3.6.orig.tar.gz
Size/MD5 checksum: 152755 65864dfe72f5cb7d7e595ca6f34fc7d7

Alpha architecture:

http://security.debian.org/pool/updates/main/p/prozilla/prozilla_1.3.6-3woody2_alpha.deb
Size/MD5 checksum: 78456 67eb74ad4ef6f7b11fb6d0c84e97e885

ARM architecture:

http://security.debian.org/pool/updates/main/p/prozilla/prozilla_1.3.6-3woody2_arm.deb
Size/MD5 checksum: 65416 ee4e2b27282f5d797388cf9db6bb1ae6

Intel IA-32 architecture:

http://security.debian.org/pool/updates/main/p/prozilla/prozilla_1.3.6-3woody2_i386.deb
Size/MD5 checksum: 64420 ca9cf2d80468eb3c6f262efd2865f32f

Intel IA-64 architecture:

http://security.debian.org/pool/updates/main/p/prozilla/prozilla_1.3.6-3woody2_ia64.deb
Size/MD5 checksum: 93510 41775fe0d297ef48a07decba2df534d0

HP Precision architecture:

http://security.debian.org/pool/updates/main/p/prozilla/prozilla_1.3.6-3woody2_hppa.deb
Size/MD5 checksum: 74488 8d7ccf055d158ddd57f29ff6a67a54ba

Motorola 680x0 architecture:

http://security.debian.org/pool/updates/main/p/prozilla/prozilla_1.3.6-3woody2_m68k.deb
Size/MD5 checksum: 61402 087350199da0c600391b0975956d097a

Big endian MIPS architecture:

http://security.debian.org/pool/updates/main/p/prozilla/prozilla_1.3.6-3woody2_mips.deb
Size/MD5 checksum: 73084 5a5e06a2436b08c7133ce1a21b97a167

Little endian MIPS architecture:

http://security.debian.org/pool/updates/main/p/prozilla/prozilla_1.3.6-3woody2_mipsel.deb
Size/MD5 checksum: 73182 8479c67ce0ccb680821aeddba9fdb2e5

PowerPC architecture:

http://security.debian.org/pool/updates/main/p/prozilla/prozilla_1.3.6-3woody2_powerpc.deb
Size/MD5 checksum: 68490 7c83bdce09185e681b20c3903fcc18fd

IBM S/390 architecture:

http://security.debian.org/pool/updates/main/p/prozilla/prozilla_1.3.6-3woody2_s390.deb
Size/MD5 checksum: 65476 e25037beaff259f42db818fb8e8a403b

Sun Sparc architecture:

http://security.debian.org/pool/updates/main/p/prozilla/prozilla_1.3.6-3woody2_sparc.deb
Size/MD5 checksum: 68120 a1c98ba0fad335c84930c8894bf57435


These files will probably be moved into the stable distribution on its next update.


Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/dsa_718_1_new_ethereal_packages_fix_buffer_overflow.html)