DSA 641-1: New playmidi packages fix local root exploit
Posted on: 01/17/2005 09:15 AM

New playmidi packages are available for Debian GNU/Linux

---------------------------------------------------------------------------
Debian Security Advisory DSA 641-1 security@debian.org
http://www.debian.org/security/ Martin Schulze
January 17th, 2005 http://www.debian.org/security/faq
---------------------------------------------------------------------------

Package : playmidi
Vulnerability : buffer overflow
Problem-Type : local
Debian-specific: no
CVE ID : CAN-2005-0020

Erik Sjölund discovered that playmidi, a MIDI player, contains a setuid root program with a buffer overflow that can be exploited by a local attacker.

For the stable distribution (woody) this problem has been fixed in version 2.4-4woody1.

For the unstable distribution (sid) this problem has been fixed in version 2.4debian-3.

We recommend that you upgrade your playmidi package.

Upgrade Instructions
---------------------

wget url
will fetch the file for you
dpkg -i file.deb
will install the referenced file.

If you are using the apt-get package manager, use the line for sources.list as given below:

apt-get update
will update the internal database
apt-get upgrade
will install corrected packages

You may use an automated update by adding the resources from the footer to the proper configuration.


Debian GNU/Linux 3.0 alias woody
---------------------------------

Source archives:

http://security.debian.org/pool/updates/main/p/playmidi/playmidi_2.4-4woody1.dsc
Size/MD5 checksum: 660 27266405df049e3ad78449aa26359180
http://security.debian.org/pool/updates/main/p/playmidi/playmidi_2.4-4woody1.diff.gz
Size/MD5 checksum: 11116 5593e29fbf22ee00c6ea1d2cc4fccd9d
http://security.debian.org/pool/updates/main/p/playmidi/playmidi_2.4.orig.tar.gz
Size/MD5 checksum: 146742 04efb0826324bce1d93228c77d52f911

Alpha architecture:

http://security.debian.org/pool/updates/main/p/playmidi/playmidi_2.4-4woody1_alpha.deb
Size/MD5 checksum: 151852 60b96643f5810f39bf0f7c8344bad727

ARM architecture:

http://security.debian.org/pool/updates/main/p/playmidi/playmidi_2.4-4woody1_arm.deb
Size/MD5 checksum: 142944 6df41fcb7eadb971547306b81c3d04e0

Intel IA-32 architecture:

http://security.debian.org/pool/updates/main/p/playmidi/playmidi_2.4-4woody1_i386.deb
Size/MD5 checksum: 152556 07ed83461c1895ee6e473f72aef321c7

Intel IA-64 architecture:

http://security.debian.org/pool/updates/main/p/playmidi/playmidi_2.4-4woody1_ia64.deb
Size/MD5 checksum: 168568 91ca1e75e685edba1cd280e2b7b57aae

HP Precision architecture:

http://security.debian.org/pool/updates/main/p/playmidi/playmidi_2.4-4woody1_hppa.deb
Size/MD5 checksum: 147882 96433cebca7781212b33419726fd271e

Motorola 680x0 architecture:

http://security.debian.org/pool/updates/main/p/playmidi/playmidi_2.4-4woody1_m68k.deb
Size/MD5 checksum: 132748 ec499ea1a198151560d5e1050738465c

Big endian MIPS architecture:

http://security.debian.org/pool/updates/main/p/playmidi/playmidi_2.4-4woody1_mips.deb
Size/MD5 checksum: 144526 b8577f77664f10bc433140eccfa024d9

Little endian MIPS architecture:

http://security.debian.org/pool/updates/main/p/playmidi/playmidi_2.4-4woody1_mipsel.deb
Size/MD5 checksum: 143648 b2eac216eb51a3e75114662e0c3c3d05

PowerPC architecture:

http://security.debian.org/pool/updates/main/p/playmidi/playmidi_2.4-4woody1_powerpc.deb
Size/MD5 checksum: 143318 4e42843f540adea484c9b6513f7cc1ac

IBM S/390 architecture:

http://security.debian.org/pool/updates/main/p/playmidi/playmidi_2.4-4woody1_s390.deb
Size/MD5 checksum: 141042 11ec7a55306c470ff9bb9c248e73d1e6

Sun Sparc architecture:

http://security.debian.org/pool/updates/main/p/playmidi/playmidi_2.4-4woody1_sparc.deb
Size/MD5 checksum: 147806 698b5ab0d50fc0a77c0bb4921c5b77d5


These files will probably be moved into the stable distribution on its next update.


Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/dsa_641_1_new_playmidi_packages_fix_local_root_exploit.html)