DSA 512-1: New gallery packages fix unauthenticated access
Posted on: 06/03/2004 03:26 AM

New gallery packages has been released for Debian GNU/Linux

---------------------------------------------------------------------------
Debian Security Advisory DSA 512-1 security@debian.org
http://www.debian.org/security/ Matt Zimmerman
June 2nd, 2004 http://www.debian.org/security/faq
---------------------------------------------------------------------------

Package : gallery
Vulnerability : unauthenticated access
Problem-Type : remote
Debian-specific: no

A vulnerability was discovered in gallery, a web-based photo album written in php, whereby a remote attacker could gain access to the gallery "admin" user without proper authentication. No CVE candidate was available for this vulnerability at the time of release.

For the current stable distribution (woody), these problems have been fixed in version 1.2.5-8woody2.

For the unstable distribution (sid), these problems have been fixed in version 1.4.3-pl2-1.

We recommend that you update your gallery package.

Upgrade Instructions
---------------------

wget url
will fetch the file for you
dpkg -i file.deb
will install the referenced file.

If you are using the apt-get package manager, use the line for sources.list as given below:

apt-get update
will update the internal database
apt-get upgrade
will install corrected packages

You may use an automated update by adding the resources from the footer to the proper configuration.

Debian GNU/Linux 3.0 alias woody
---------------------------------

Source archives:

http://security.debian.org/pool/updates/main/g/gallery/gallery_1.2.5-8woody2.dsc
Size/MD5 checksum: 573 1369280ce34db40a941ef4fae6f107a5
http://security.debian.org/pool/updates/main/g/gallery/gallery_1.2.5-8woody2.diff.gz
Size/MD5 checksum: 7575 109d81ad481a7b6a197b5dd5b2a3eeaf
http://security.debian.org/pool/updates/main/g/gallery/gallery_1.2.5.orig.tar.gz
Size/MD5 checksum: 132099 1a32e57b36ca06d22475938e1e1b19f9

Architecture independent components:

http://security.debian.org/pool/updates/main/g/gallery/gallery_1.2.5-8woody2_all.deb
Size/MD5 checksum: 137412 ebae6be30fe04acb993da74c9f54dcf0

These files will probably be moved into the stable distribution on its next revision.


Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/dsa_512_1_new_gallery_packages_fix_unauthenticated_access.html)