DSA 2636-1: xen security update
Posted on: 03/02/2013 11:50 AM

A xen security update has been released for Debian GNU/Linux

DSA 2636-1: xen security update


- -------------------------------------------------------------------------
Debian Security Advisory DSA-2636-1 security@debian.org
http://www.debian.org/security/ Moritz Muehlenhoff
March 01, 2013 http://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : xen
Vulnerability : several
Problem type : remote
Debian-specific: no
CVE ID : CVE-2012-4544 CVE-2012-5511 CVE-2012-5634 CVE-2013-0153
Debian Bug :

Multiple vulnerabilities have been discovered in the Xen hypervisor. The
Common Vulnerabilities and Exposures project identifies the following
problems:

CVE-2012-4544

Insufficient validation of kernel or ramdisk sizes in the Xen PV
domain builder could result in denial of service.

CVE-2012-5511

Several HVM control operations performed insufficient validation of
input, which could result in denial of service through resource
exhaustion.

CVE-2012-5634

Incorrect interrupt handling when using VT-d hardware could result
in denial of service.

CVE-2013-0153

Insufficient restriction of interrupt access could result in denial
of service.


For the stable distribution (squeeze), these problems have been fixed in
version 4.0.1-5.7.

For the testing distribution (wheezy), these problems have been fixed in
version 4.1.4-2.

For the unstable distribution (sid), these problems have been fixed in
version 4.1.4-2.

We recommend that you upgrade your xen packages.

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: http://www.debian.org/security/



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/dsa_2636_1_xen_security_update.html)