DSA 2631-1: squid3 security update
Posted on: 02/25/2013 09:07 AM

A squid3 security update has been released for Debian GNU/Linux

DSA 2631-1: squid3 security update


- -------------------------------------------------------------------------
Debian Security Advisory DSA-2630-1 security@debian.org
http://www.debian.org/security/ Salvatore Bonaccorso
February 24, 2013 http://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : squid3
Vulnerability : denial of service
Problem type : remote
Debian-specific: no
CVE ID : CVE-2012-5643 CVE-2013-0189
Debian Bug : 696187

Squid3, a fully featured Web proxy cache, is prone to a denial of
service attack due to memory consumption caused by memory leaks in
cachemgr.cgi:

CVE-2012-5643

squid's cachemgr.cgi was vulnerable to excessive resource use. A
remote attacker could exploit this flaw to perform a denial of
service attack on the server and other hosted services.

CVE-2013-0189

The original patch for CVE-2012-5643 was incomplete. A remote
attacker still could exploit this flaw to perform a denial of
service attack.

For the stable distribution (squeeze), these problems have been fixed in
version 3.1.6-1.2+squeeze3.

For the testing distribution (wheezy), these problems have been fixed in
version 3.1.20-2.1.

For the unstable distribution (sid), these problems have been fixed in
version 3.1.20-2.1.

We recommend that you upgrade your squid3 packages.

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: http://www.debian.org/security/



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/dsa_2631_1_squid3_security_update.html)