DSA 2520-1: openoffice.org security update
Posted on: 08/03/2012 08:49 AM

An openoffice.org security update has been released for Debian GNU/Linux

- -------------------------------------------------------------------------
Debian Security Advisory DSA-2520-1 security@debian.org
http://www.debian.org/security/ Yves-Alexis Perez
August 01, 2012 http://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : openoffice.org
Vulnerability : Multiple heap-based buffer overflows
Problem type : local
Debian-specific: no
CVE ID : CVE-2012-2665
Debian Bug :

Timo Warns from PRE-CERT discovered multiple heap-based buffer overflows in
OpenOffice.org, an office productivity suite. The issues lies in the XML
manifest encryption tag parsing code. Using specially crafted files, an
attacker can cause application crash and could cause arbitrary code execution.

For the stable distribution (squeeze), this problem has been fixed in
version 3.2.1-11+squeeze7.

openoffice.org package has been replaced by libreoffice in testing (wheezy) and
unstable (sid) distributions.

For the testing distribution (wheezy), this problem has been fixed in
version 1:3.5.4-7.

For the unstable distribution (sid), this problem has been fixed in
version 1:3.5.4-7.

We recommend that you upgrade your openoffice.org packages.

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: http://www.debian.org/security/



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/dsa_2520_1_openoffice_org_security_update.html)