DSA 2508-1: kfreebsd-8 security update
Posted on: 07/23/2012 08:48 AM

A kfreebsd-8 security update has been released for Debian GNU/Linux

- -------------------------------------------------------------------------
Debian Security Advisory DSA-2508-1 security@debian.org
http://www.debian.org/security/ Yves-Alexis Perez
July 22, 2012 http://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : kfreebsd-8
Vulnerability : privilege escalation
Problem type : local
Debian-specific: no
CVE ID : CVE-2012-0217
Debian Bug : 677297

Rafal Wojtczuk from Bromium discovered that FreeBSD wasn't handling correctly
uncanonical return addresses on Intel amd64 CPUs, allowing privilege escalation
to kernel for local users.

For the stable distribution (squeeze), this problem has been fixed in
version 8.1+dfsg-8+squeeze3.

For the testing distribution (wheezy), this problem has been fixed in
version 8.3-4.

For the unstable distribution (sid), this problem has been fixed in
version 8.3-4.

We recommend that you upgrade your kfreebsd-8 packages.



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/dsa_2508_1_kfreebsd_8_security_update.html)