DSA 2492-1: php5 security update
Posted on: 06/11/2012 10:00 AM

A php5 security update has been released for Debian GNU/Linux

- -------------------------------------------------------------------------
Debian Security Advisory DSA-2492-1 security@debian.org
http://www.debian.org/security/ Florian Weimer
June 10, 2012 http://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : php5
Vulnerability : buffer overflow
Problem type : remote
Debian-specific: no
CVE ID : CVE-2012-2386

The Phar extension for PHP does not properly handle crafted tar files,
leading to a heap-based buffer overflow. PHP applications processing
tar files could crash or, potentially, execute arbitrary code.

In addition, this update addresses a regression which caused a crash
when accessing a global object that is returned as $this from __get.

For the stable distribution (squeeze), this problem has been fixed in
version 5.3.3-7+squeeze13.

For the testing distribution (wheezy) and the unstable distribution
(sid), this problem has been fixed in version 5.4.4~rc1-1.

We recommend that you upgrade your php5 packages.

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: http://www.debian.org/security/



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/dsa_2492_1_php5_security_update.html)