DSA 2491-1: postgresql-8.4 security update
Posted on: 06/10/2012 10:45 AM

A postgresql-8.4 security update has been released for Debian GNU/Linux

- -------------------------------------------------------------------------
Debian Security Advisory DSA-2491-1 security@debian.org
http://www.debian.org/security/ Florian Weimer
June 09, 2012 http://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : postgresql-8.4
Vulnerability : several
Problem type : remote
Debian-specific: no
CVE ID : CVE-2012-2143 CVE-2012-2655

Two vulnerabilities were discovered in PostgreSQL, an SQL database
server:

CVE-2012-2143
The crypt(text, text) function in the pgcrypto contrib module
did not handle certain passwords correctly, ignoring
characters after the first character which does not fall into
the ASCII range.

CVE-2012-2655
SECURITY DEFINER and SET attributes for a call handler of a
procedural language could crash the database server.

In addition, this update contains reliability and stability fixes from
the 8.4.12 upstream release.

For the stable distribution (squeeze), this problem has been fixed in
version 8.4.12-0squeeze1.

For the unstable distribution (sid), this problem has been fixed in
version 8.4.12-1.

We recommend that you upgrade your postgresql-8.4 packages.

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: http://www.debian.org/security/



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/dsa_2491_1_postgresql_8_4_security_update.html)