DSA 2448-1: inspircd security update
Posted on: 04/10/2012 12:26 PM

An inspircd security update has been released for Debian GNU/Linux

- -------------------------------------------------------------------------
Debian Security Advisory DSA-2448-1 security@debian.org
http://www.debian.org/security/ Jonathan Wiltshire
April 10, 2012 http://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : inspircd
Vulnerability : buffer overflow
Problem type : remote
Debian-specific: no
CVE ID : CVE-2012-1836
Debian Bug : 667914

It was discovered that a heap-based buffer overflow in InspIRCd could allow
remote attackers to execute arbitrary code via a crafted DNS query.

For the stable distribution (squeeze), this problem has been fixed in
version 1.1.22+dfsg-4+squeeze1.

For the testing distribution (wheezy), this problem has been fixed in
version 1.1.22+dfsg-4+wheezy1.

For the unstable distribution (sid), this problem has been fixed in
version 2.0.5-0.1.

We recommend that you upgrade your inspircd packages.

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: http://www.debian.org/security/



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/dsa_2448_1_inspircd_security_update.html)