DSA 2431-1: libdbd-pg-perl security update
Posted on: 03/12/2012 08:09 AM

A libdbd-pg-perl security update has been released for Debian GNU/Linux

- -------------------------------------------------------------------------
Debian Security Advisory DSA-2431-1 security@debian.org
http://www.debian.org/security/ Moritz Muehlenhoff
March 11, 2012 http://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : libdbd-pg-perl
Vulnerability : format string vulnerabilities
Problem type : remote
Debian-specific: no
CVE ID : CVE-2012-1151
Debian Bug : 661536

Niko Tyni discovered two format string vulnerabilities in DBD::Pg, a Perl
DBI driver for the PostgreSQL database server, which can be exploited
by a rogue database server.

For the stable distribution (squeeze), this problem has been fixed in
version 2.17.1-2+squeeze1.

For the unstable distribution (sid), this problem has been fixed in
version 2.19.0-1.

We recommend that you upgrade your libdbd-pg-perl packages.

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: http://www.debian.org/security/



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/dsa_2431_1_libdbd_pg_perl_security_update.html)