DSA 2385-1: pdns security update
Posted on: 01/11/2012 12:02 AM

A pdns security update has been released for Debian GNU/Linux

- -------------------------------------------------------------------------
Debian Security Advisory DSA-2385-1 security@debian.org
http://www.debian.org/security/ Florian Weimer
January 10, 2012 http://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : pdns
Vulnerability : packet loop
Problem type : remote
Debian-specific: no
CVE ID : CVE-2012-0206

Ray Morris discovered that the PowerDNS authoritative sever responds
to response packets. An attacker who can spoof the source address of
IP packets can cause an endless packet loop between a PowerDNS
authoritative server and another DNS server, leading to a denial of
service.

For the oldstable distribution (lenny), this problem has been fixed in
version 2.9.21.2-1+lenny1.

For the stable distribution (squeeze), this problem has been fixed in
version 2.9.22-8+squeeze1.

For the testing distribution (wheezy) and the unstable distribution
(sid), this problem will be fixed soon.

We recommend that you upgrade your pdns packages.

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: http://www.debian.org/security/



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/dsa_2385_1_pdns_security_update.html)