DSA 2159-1: vlc security update
Posted on: 02/11/2011 10:21 AM

A vlc security update is available for Debian 6.0

- -------------------------------------------------------------------------
Debian Security Advisory DSA-2159-1 security@debian.org
http://www.debian.org/security/ Moritz Muehlenhoff
February 10, 2011 http://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : vlc
Vulnerability : missing input sanitising
Problem type : (local)remote
Debian-specific: no
CVE ID : CVE-2011-0531

Dan Rosenberg discovered that insufficient input validation in VLC's
processing of Matroska/WebM containers could lead to the execution of
arbitrary code.

For the stable distribution (squeeze), this problem has been fixed in
version 1.1.3-1squeeze3.

The version of vlc in the oldstable distribution (lenny) is affected
by further issues and will be addressed in a followup DSA.

For the unstable distribution (sid), this problem has been fixed in
version 1.1.7-1.

We recommend that you upgrade your vlc packages.

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: http://www.debian.org/security/



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/dsa_2159_1_vlc_security_update.html)