DSA 2032-1: New libpng packages fix several vulnerabilities
Posted on: 04/11/2010 06:00 PM

The Debian Security Team published a new security update for Debian GNU/Linux. Here the announcement:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- ------------------------------------------------------------------------
Debian Security Advisory DSA-2032-1 security@debian.org
http://www.debian.org/security/ Giuseppe Iuculano
April 11, 2010 http://www.debian.org/security/faq
- ------------------------------------------------------------------------

Package : libpng
Vulnerability : several
Problem type : local (remote)
Debian-specific: no
CVE Id(s) : CVE-2009-2042 CVE-2010-0205
Debian Bugs : 533676 572308


Several vulnerabilities have been discovered in libpng, a library for
reading and writing PNG files. The Common Vulnerabilities and
Exposures project identifies the following problems:

CVE-2009-2042

libpng does not properly parse 1-bit interlaced images with width values
that are not divisible by 8, which causes libpng to include
uninitialized bits in certain rows of a PNG file and might allow remote
attackers to read portions of sensitive memory via "out-of-bounds
pixels" in the file.


CVE-2010-0205

libpng does not properly handle compressed ancillary-chunk data that has
a disproportionately large uncompressed representation, which allows
remote attackers to cause a denial of service (memory and CPU
consumption, and application hang) via a crafted PNG file


For the stable distribution (lenny), these problems have been fixed in
version 1.2.27-2+lenny3.

For the testing (squeeze) and unstable (sid) distribution, these
problems have been fixed in version 1.2.43-1

We recommend that you upgrade your libpng package.

Upgrade instructions
- --------------------

wget url
will fetch the file for you
dpkg -i file.deb
will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
will update the internal database
apt-get upgrade
will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.


Debian GNU/Linux 5.0 alias lenny
- --------------------------------

Debian (stable)
- ---------------

Stable updates are available for alpha, amd64, arm, armel, hppa, i386, ia64, mips, mipsel, powerpc, s390 and sparc.

Source archives:

http://security.debian.org/pool/updates/main/libp/libpng/libpng_1.2.27-2+lenny3.dsc
Size/MD5 checksum: 1201 abe81b0d3c4aa7a1fa418e29f2c5b297
http://security.debian.org/pool/updates/main/libp/libpng/libpng_1.2.27.orig.tar.gz
Size/MD5 checksum: 783204 13a0de401db1972a8e68f47d5bdadd13
http://security.debian.org/pool/updates/main/libp/libpng/libpng_1.2.27-2+lenny3.diff.gz
Size/MD5 checksum: 19687 60ede1843ceb8a1f127c54b847a74dfa

Architecture independent packages:

http://security.debian.org/pool/updates/main/libp/libpng/libpng3_1.2.27-2+lenny3_all.deb
Size/MD5 checksum: 880 028b00e28aad8282714776c5dcca64a8

alpha architecture (DEC Alpha)

http://security.debian.org/pool/updates/main/libp/libpng/libpng12-0-udeb_1.2.27-2+lenny3_alpha.udeb
Size/MD5 checksum: 86562 d9c50af59951e972557d393409b75bf2
http://security.debian.org/pool/updates/main/libp/libpng/libpng12-dev_1.2.27-2+lenny3_alpha.deb
Size/MD5 checksum: 287752 1d7d84aee223c0933d1a616722607096
http://security.debian.org/pool/updates/main/libp/libpng/libpng12-0_1.2.27-2+lenny3_alpha.deb
Size/MD5 checksum: 182436 001ecbf421f70ca521a3968f1d14c874

amd64 architecture (AMD x86_64 (AMD64))

http://security.debian.org/pool/updates/main/libp/libpng/libpng12-0-udeb_1.2.27-2+lenny3_amd64.udeb
Size/MD5 checksum: 71912 78fbe1a6568671e4c557ec12e29481b0
http://security.debian.org/pool/updates/main/libp/libpng/libpng12-dev_1.2.27-2+lenny3_amd64.deb
Size/MD5 checksum: 254500 481312a64867f31c363b7fbba9cfe171
http://security.debian.org/pool/updates/main/libp/libpng/libpng12-0_1.2.27-2+lenny3_amd64.deb
Size/MD5 checksum: 167864 3d285c20d2f080313f82eb09dcb7261b

arm architecture (ARM)

http://security.debian.org/pool/updates/main/libp/libpng/libpng12-0-udeb_1.2.27-2+lenny3_arm.udeb
Size/MD5 checksum: 64566 a4a9742190557d14beae40133fb46cf1
http://security.debian.org/pool/updates/main/libp/libpng/libpng12-dev_1.2.27-2+lenny3_arm.deb
Size/MD5 checksum: 245438 a16f62e771622e05812172f7c7066504
http://security.debian.org/pool/updates/main/libp/libpng/libpng12-0_1.2.27-2+lenny3_arm.deb
Size/MD5 checksum: 159612 81facf06de458dd6b1e84a78bb1acfc8

armel architecture (ARM EABI)

http://security.debian.org/pool/updates/main/libp/libpng/libpng12-0-udeb_1.2.27-2+lenny3_armel.udeb
Size/MD5 checksum: 67028 56fc4199656d239231c7b8d8e035fead
http://security.debian.org/pool/updates/main/libp/libpng/libpng12-dev_1.2.27-2+lenny3_armel.deb
Size/MD5 checksum: 245930 9f64181bc16af0ad0de4ba2e86b25706
http://security.debian.org/pool/updates/main/libp/libpng/libpng12-0_1.2.27-2+lenny3_armel.deb
Size/MD5 checksum: 162504 3129e1c2360fcba0309257e2b1dff8ca

hppa architecture (HP PA RISC)

http://security.debian.org/pool/updates/main/libp/libpng/libpng12-0-udeb_1.2.27-2+lenny3_hppa.udeb
Size/MD5 checksum: 73858 9d5a53e3258b5149bee68a4d20067bf9
http://security.debian.org/pool/updates/main/libp/libpng/libpng12-0_1.2.27-2+lenny3_hppa.deb
Size/MD5 checksum: 169602 12ddce05c84ef675c348a1e64f1a277c
http://security.debian.org/pool/updates/main/libp/libpng/libpng12-dev_1.2.27-2+lenny3_hppa.deb
Size/MD5 checksum: 261788 9297cb916e57e2f912de3f16bcbae475

i386 architecture (Intel ia32)

http://security.debian.org/pool/updates/main/libp/libpng/libpng12-dev_1.2.27-2+lenny3_i386.deb
Size/MD5 checksum: 246968 083d472fd65f884c91dff5926e538342
http://security.debian.org/pool/updates/main/libp/libpng/libpng12-0_1.2.27-2+lenny3_i386.deb
Size/MD5 checksum: 165560 233945ee4b1e442357276431ce495a4c
http://security.debian.org/pool/updates/main/libp/libpng/libpng12-0-udeb_1.2.27-2+lenny3_i386.udeb
Size/MD5 checksum: 70094 769336f4574678e56931e1a1eaf6be6a

ia64 architecture (Intel ia64)

http://security.debian.org/pool/updates/main/libp/libpng/libpng12-dev_1.2.27-2+lenny3_ia64.deb
Size/MD5 checksum: 305324 42d7265034b84662467bb75456653787
http://security.debian.org/pool/updates/main/libp/libpng/libpng12-0-udeb_1.2.27-2+lenny3_ia64.udeb
Size/MD5 checksum: 111776 ad716022a6a22371bb83f3966ebe17d4
http://security.debian.org/pool/updates/main/libp/libpng/libpng12-0_1.2.27-2+lenny3_ia64.deb
Size/MD5 checksum: 206866 572b9d18c5adba74a4e5b99714968a60

mipsel architecture (MIPS (Little Endian))

http://security.debian.org/pool/updates/main/libp/libpng/libpng12-dev_1.2.27-2+lenny3_mipsel.deb
Size/MD5 checksum: 262242 e905771ac3fa905cc03a3ddc8f9872dd
http://security.debian.org/pool/updates/main/libp/libpng/libpng12-0-udeb_1.2.27-2+lenny3_mipsel.udeb
Size/MD5 checksum: 68370 4d44877866357a0fd8474fd8fe183616
http://security.debian.org/pool/updates/main/libp/libpng/libpng12-0_1.2.27-2+lenny3_mipsel.deb
Size/MD5 checksum: 164154 93c02dbae7dfe59b77ce4b683b82eaef

powerpc architecture (PowerPC)

http://security.debian.org/pool/updates/main/libp/libpng/libpng12-0_1.2.27-2+lenny3_powerpc.deb
Size/MD5 checksum: 166402 1d470464fe2b493aef8d95dde5fd95d8
http://security.debian.org/pool/updates/main/libp/libpng/libpng12-0-udeb_1.2.27-2+lenny3_powerpc.udeb
Size/MD5 checksum: 70682 1dd9713672dbac4a7434f1f96a1184b5
http://security.debian.org/pool/updates/main/libp/libpng/libpng12-dev_1.2.27-2+lenny3_powerpc.deb
Size/MD5 checksum: 253478 7a87577e07ed0bb9e759b973b2d7cf18

s390 architecture (IBM S/390)

http://security.debian.org/pool/updates/main/libp/libpng/libpng12-0-udeb_1.2.27-2+lenny3_s390.udeb
Size/MD5 checksum: 73470 52b1a911a81f133a83a387663aa3ffb2
http://security.debian.org/pool/updates/main/libp/libpng/libpng12-dev_1.2.27-2+lenny3_s390.deb
Size/MD5 checksum: 252988 18b4c8b17b3e30ab6cce89c21c99fbfc
http://security.debian.org/pool/updates/main/libp/libpng/libpng12-0_1.2.27-2+lenny3_s390.deb
Size/MD5 checksum: 169264 601982b9a97707ab05e1f4469cd8e20e

sparc architecture (Sun SPARC/UltraSPARC)

http://security.debian.org/pool/updates/main/libp/libpng/libpng12-0_1.2.27-2+lenny3_sparc.deb
Size/MD5 checksum: 161562 facd643206903acfa3a503c1d69e9248
http://security.debian.org/pool/updates/main/libp/libpng/libpng12-0-udeb_1.2.27-2+lenny3_sparc.udeb
Size/MD5 checksum: 66032 cbbe521a9a5629987603a57b8c9f35be
http://security.debian.org/pool/updates/main/libp/libpng/libpng12-dev_1.2.27-2+lenny3_sparc.deb
Size/MD5 checksum: 247212 76b8fe782fd0e5f7546bd535f8d442bc


These files will probably be moved into the stable distribution on
its next update.

- ---------------------------------------------------------------------------------
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-security dists/stable/updates/main
Mailing list: debian-security-announce@lists.debian.org
Package info: `apt-cache show lt;pkggt;' and http://packages.debian.org/lt;pkggt;
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iEYEARECAAYFAkvB/yQACgkQNxpp46476arJFwCdG3xzEL0SYqHS8rJg3pzYehZt
AcoAn2GBzbmldTUCEuhVm/AeGmvzrom3
=MjfY
-----END PGP SIGNATURE-----



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/dsa_2032_1_new_libpng_packages_fix_several_vulnerabilities.html)