DSA 1994-1: New ajaxterm packages fix session hijacking
Posted on: 02/11/2010 07:55 PM

The Debian Security Team published a new security update for Debian GNU/Linux. Here the announcement:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- ------------------------------------------------------------------------
Debian Security Advisory DSA-1994-1 security@debian.org
http://www.debian.org/security/ Raphael Geissert
February 11, 2010 http://www.debian.org/security/faq
- ------------------------------------------------------------------------

Package : ajaxterm
Vulnerability : weak session IDs
Problem type : remote
Debian-specific: no
CVE Id(s) : CVE-2009-1629

It was discovered that ajaxterm, a web-based terminal, generates weak
and predictable session IDs, which might be used to hijack a session or
cause a denial of service attack on a system that uses ajaxterm.

For the oldstable distribution (etch), the problem has been fixed in
version 0.9-2+etch1.

For the stable distribution (lenny), the problem has been fixed in
version 0.10-2+lenny1.

For the unstable distribution (sid), the problem has been fixed in
version 0.10-5.

We recommend that you upgrade your ajaxterm package.

Upgrade instructions
- --------------------

wget url
will fetch the file for you
dpkg -i file.deb
will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
will update the internal database
apt-get upgrade
will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.


Debian GNU/Linux 4.0 alias etch
- -------------------------------

Oldstable updates are available for alpha, amd64, arm, hppa, i386, ia64, mips, mipsel, powerpc, s390 and sparc.

Source archives:

http://security.debian.org/pool/updates/main/a/ajaxterm/ajaxterm_0.9-2+etch1.dsc
Size/MD5 checksum: 690 4e0e8803297516dd65e13e10836b7700
http://security.debian.org/pool/updates/main/a/ajaxterm/ajaxterm_0.9-2+etch1.diff.gz
Size/MD5 checksum: 6479 30e20eb2a1a452f9e2711619d3386155
http://security.debian.org/pool/updates/main/a/ajaxterm/ajaxterm_0.9.orig.tar.gz
Size/MD5 checksum: 33751 9e48eae37beb62df3f91460b7fe352e0

Architecture independent packages:

http://security.debian.org/pool/updates/main/a/ajaxterm/ajaxterm_0.9-2+etch1_all.deb
Size/MD5 checksum: 40490 4c63417d3dfe2aa14c115042c10cdb97

Debian GNU/Linux 5.0 alias lenny
- --------------------------------

Stable updates are available for alpha, amd64, arm, armel, hppa, i386, ia64, mips, mipsel, powerpc, s390 and sparc.

Source archives:

http://security.debian.org/pool/updates/main/a/ajaxterm/ajaxterm_0.10-2+lenny1.diff.gz
Size/MD5 checksum: 8309 63860e0b5b279d0fe92012abef36628e
http://security.debian.org/pool/updates/main/a/ajaxterm/ajaxterm_0.10.orig.tar.gz
Size/MD5 checksum: 34372 b10830a7a81d2a4c9f8815510dafb87a
http://security.debian.org/pool/updates/main/a/ajaxterm/ajaxterm_0.10-2+lenny1.dsc
Size/MD5 checksum: 1275 dac2c51d75700af66248358265c77897

Architecture independent packages:

http://security.debian.org/pool/updates/main/a/ajaxterm/ajaxterm_0.10-2+lenny1_all.deb
Size/MD5 checksum: 41606 287e8220fce3fc0b673ed6f392094b71


These files will probably be moved into the stable distribution on
its next update.

- ---------------------------------------------------------------------------------
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-security dists/stable/updates/main
Mailing list: debian-security-announce@lists.debian.org
Package info: `apt-cache show lt;pkggt;' and http://packages.debian.org/lt;pkggt;
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iEYEARECAAYFAkt0UH8ACgkQXm3vHE4uylrRBgCfcEPSmw9saWEqJfuz42ttGD/3
8vsAoJ4nUzl5W1kCo8pfRUqH3FV3WaZm
=9cAd
-----END PGP SIGNATURE-----



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/dsa_1994_1_new_ajaxterm_packages_fix_session_hijacking.html)