DSA 1818-1: New gforge packages fix insufficient input sanitising
Posted on: 06/18/2009 04:40 AM

The Debian Security Team published a new security update for Debian GNU/Linux. Here the announcement:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- ------------------------------------------------------------------------
Debian Security Advisory DSA-1818-1 security@debian.org
http://www.debian.org/security/ Steffen Joeris
June 18, 2009 http://www.debian.org/security/faq
- ------------------------------------------------------------------------

Package : gforge
Vulnerability : insufficient input sanitising
Problem type : remote
Debian-specific: no
CVE IDs : CVE ids pending


Laurent Almeras and Guillaume Smet have discovered a possible SQL
injection vulnerability and cross-site scripting vulnerabilities in
gforge, a collaborative development tool. Due to insufficient input
sanitising, it was possible to inject arbitrary SQL statements and use
several parameters to conduct cross-site scripting attacks.

For the stable distribution (lenny), these problem have been fixed in
version 4.7~rc2-7lenny1.

The oldstable distribution (etch), these problems have been fixed in
version 4.5.14-22etch11.

For the testing distribution (squeeze), these problems will be fixed
soon.

For the unstable distribution (sid), these problems have been fixed in
version 4.7.3-2.


We recommend that you upgrade your gforge packages.


Upgrade instructions
- --------------------

wget url
will fetch the file for you
dpkg -i file.deb
will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
will update the internal database
apt-get upgrade
will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.


Debian GNU/Linux 4.0 alias etch
- -------------------------------

Debian (oldstable)
- ------------------

Oldstable updates are available for alpha, amd64, arm, hppa, i386, ia64, mips, mipsel, powerpc, s390 and sparc.

Source archives:

http://security.debian.org/pool/updates/main/g/gforge/gforge_4.5.14.orig.tar.gz
Size/MD5 checksum: 2161141 e85f82eff84ee073f80a2a52dd32c8a5
http://security.debian.org/pool/updates/main/g/gforge/gforge_4.5.14-22etch11.diff.gz
Size/MD5 checksum: 201451 94977f0fcf9809c2c56b7b4f030c749d
http://security.debian.org/pool/updates/main/g/gforge/gforge_4.5.14-22etch11.dsc
Size/MD5 checksum: 952 73cb38a7bb8fb7371886d1af0632f0f6

Architecture independent packages:

http://security.debian.org/pool/updates/main/g/gforge/gforge-common_4.5.14-22etch11_all.deb
Size/MD5 checksum: 1011474 0a38ec79e8b10ee730169e6abe70d7a2
http://security.debian.org/pool/updates/main/g/gforge/gforge-db-postgresql_4.5.14-22etch11_all.deb
Size/MD5 checksum: 212716 db347a6691d2ee6155ee4eb404e3503c
http://security.debian.org/pool/updates/main/g/gforge/gforge-shell-ldap_4.5.14-22etch11_all.deb
Size/MD5 checksum: 86560 3a76aa7d0e44e188b0e4a92685127162
http://security.debian.org/pool/updates/main/g/gforge/gforge-ftp-proftpd_4.5.14-22etch11_all.deb
Size/MD5 checksum: 86266 de7a343ca8786dc611820b1fda735135
http://security.debian.org/pool/updates/main/g/gforge/gforge_4.5.14-22etch11_all.deb
Size/MD5 checksum: 80488 cbb1fb7d47b3ac865e3baa446d0af066
http://security.debian.org/pool/updates/main/g/gforge/gforge-mta-exim4_4.5.14-22etch11_all.deb
Size/MD5 checksum: 89334 42feee7a50b0b106919a78fdcff4167e
http://security.debian.org/pool/updates/main/g/gforge/gforge-mta-postfix_4.5.14-22etch11_all.deb
Size/MD5 checksum: 88730 a06c1f5db2a6a7c703d07e165a6ece53
http://security.debian.org/pool/updates/main/g/gforge/gforge-ldap-openldap_4.5.14-22etch11_all.deb
Size/MD5 checksum: 95708 8338b93e5bd4cda3befe20c02a67a321
http://security.debian.org/pool/updates/main/g/gforge/gforge-mta-courier_4.5.14-22etch11_all.deb
Size/MD5 checksum: 76296 bf558ca5cc8332056033710f98b1c015
http://security.debian.org/pool/updates/main/g/gforge/gforge-mta-exim_4.5.14-22etch11_all.deb
Size/MD5 checksum: 88824 f4839730b37f387e4d5e50944b1164c5
http://security.debian.org/pool/updates/main/g/gforge/gforge-shell-postgresql_4.5.14-22etch11_all.deb
Size/MD5 checksum: 87368 2d0393bf75d68ec115fd2ca74ebacb5d
http://security.debian.org/pool/updates/main/g/gforge/gforge-web-apache_4.5.14-22etch11_all.deb
Size/MD5 checksum: 705186 cde383e7fb26af98e925ae64c8a36b01
http://security.debian.org/pool/updates/main/g/gforge/gforge-lists-mailman_4.5.14-22etch11_all.deb
Size/MD5 checksum: 82304 5434b187e218fc807ad900c3dd4b9a86
http://security.debian.org/pool/updates/main/g/gforge/gforge-dns-bind9_4.5.14-22etch11_all.deb
Size/MD5 checksum: 103986 dd0c348499935f9e02f04ecdb9ef150d


Debian GNU/Linux 5.0 alias lenny
- --------------------------------

Debian (stable)
- ---------------

Stable updates are available for alpha, amd64, arm, armel, hppa, i386, ia64, mips, mipsel, powerpc, s390 and sparc.

Source archives:

http://security.debian.org/pool/updates/main/g/gforge/gforge_4.7~rc2-7lenny1.dsc
Size/MD5 checksum: 1486 e7a7c74f21808c7f33dc901be6933103
http://security.debian.org/pool/updates/main/g/gforge/gforge_4.7~rc2-7lenny1.diff.gz
Size/MD5 checksum: 102240 f5441aa166901192aaca66beba497011
http://security.debian.org/pool/updates/main/g/gforge/gforge_4.7~rc2.orig.tar.gz
Size/MD5 checksum: 10225404 bd24808ce79363d4c7c529778f6f5324

Architecture independent packages:

http://security.debian.org/pool/updates/main/g/gforge/gforge-dns-bind9_4.7~rc2-7lenny1_all.deb
Size/MD5 checksum: 106876 c11cc5d541653a764bc282efbd11c689
http://security.debian.org/pool/updates/main/g/gforge/gforge-plugin-mediawiki_4.7~rc2-7lenny1_all.deb
Size/MD5 checksum: 213540 47273c7ff0d9826dc912e57c43a5652e
http://security.debian.org/pool/updates/main/g/gforge/gforge-ftp-proftpd_4.7~rc2-7lenny1_all.deb
Size/MD5 checksum: 97302 138c96c98f96751ea2ca6055864a502b
http://security.debian.org/pool/updates/main/g/gforge/gforge-plugin-scmcvs_4.7~rc2-7lenny1_all.deb
Size/MD5 checksum: 129362 2456cca2f7712d4bca217a223e5cb541
http://security.debian.org/pool/updates/main/g/gforge/gforge-db-postgresql_4.7~rc2-7lenny1_all.deb
Size/MD5 checksum: 230964 c0a9f22a5bf6da679ac034c5d3d2b08a
http://security.debian.org/pool/updates/main/g/gforge/gforge-mta-exim4_4.7~rc2-7lenny1_all.deb
Size/MD5 checksum: 100746 49a89ed3083e1d7b7e195e901828e6fc
http://security.debian.org/pool/updates/main/g/gforge/gforge-mta-postfix_4.7~rc2-7lenny1_all.deb
Size/MD5 checksum: 101510 f7af3a1c28c7f18dc5a4b4b59b713ef1
http://security.debian.org/pool/updates/main/g/gforge/gforge-shell-postgresql_4.7~rc2-7lenny1_all.deb
Size/MD5 checksum: 95058 68975f63793f7633436ebeec2f89bdc3
http://security.debian.org/pool/updates/main/g/gforge/gforge-web-apache_4.7~rc2-7lenny1_all.deb
Size/MD5 checksum: 88468 0dc63613df9a6f1c993e57f8635d5e41
http://security.debian.org/pool/updates/main/g/gforge/gforge-mta-courier_4.7~rc2-7lenny1_all.deb
Size/MD5 checksum: 88736 afe2ccbd51b758a9ea26e3a999144158
http://security.debian.org/pool/updates/main/g/gforge/gforge-lists-mailman_4.7~rc2-7lenny1_all.deb
Size/MD5 checksum: 94572 19d5655343fea53c3efaf00ca2178972
http://security.debian.org/pool/updates/main/g/gforge/gforge-common_4.7~rc2-7lenny1_all.deb
Size/MD5 checksum: 1112514 154682e81a30d27d9cf1023f8274e0e5
http://security.debian.org/pool/updates/main/g/gforge/gforge_4.7~rc2-7lenny1_all.deb
Size/MD5 checksum: 92798 70cf1ce13e39be31c3db12c83844481a
http://security.debian.org/pool/updates/main/g/gforge/gforge-plugin-scmsvn_4.7~rc2-7lenny1_all.deb
Size/MD5 checksum: 121988 4d916fe368ac5c9e2e87e3d2b6462b3c
http://security.debian.org/pool/updates/main/g/gforge/gforge-web-apache2_4.7~rc2-7lenny1_all.deb
Size/MD5 checksum: 1397172 a12b8e472a88c2b1f8c5af035e8223dd


These files will probably be moved into the stable distribution on
its next update.

- ---------------------------------------------------------------------------------
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-security dists/stable/updates/main
Mailing list: debian-security-announce@lists.debian.org
Package info: `apt-cache show lt;pkggt;' and http://packages.debian.org/lt;pkggt;
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iEYEARECAAYFAko5mSwACgkQ62zWxYk/rQeyaACeJjFptWex2HrryzUIi+RI/cJR
5xAAn2j6l7ruNCzdpnskOUixMaakxcBQ
=IFYq
-----END PGP SIGNATURE-----



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/dsa_1818_1_new_gforge_packages_fix_insufficient_input_sanitising.html)