DSA 1384-1: New xen-utils packages fix several vulnerabilities
Posted on: 10/05/2007 10:40 PM

The Debian Security Team published a new security update for Debian GNU/Linux. Here the announcement:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- ------------------------------------------------------------------------
Debian Security Advisory DSA 1384-1 security@debian.org
http://www.debian.org/security/ Steve Kemp
October 5th, 2007 http://www.debian.org/security/faq
- ------------------------------------------------------------------------

Package : xen-utils
Vulnerability : various
Problem type : local
Debian-specific: no
CVE Id(s) : CVE-2007-4993, CVE-2007-1320
Debian Bug : 444430, 444007


Several local vulnerabilities have been discovered in the Xen hypervisor
packages which may lead to the execution of arbitrary code. The Common
Vulnerabilities and Exposures project identifies the following problems:

CVE-2007-4993

By use of a specially crafted grub configuration file a domU user
may be able to execute arbitary code upon the dom0 when pygrub is
being used.

CVE-2007-1320

Multiple heap-based buffer overflows in the Cirrus VGA extension,
provided by QEMU, may allow local users to execute arbitrary code
via "bitblt" heap overflow.


For the stable distribution (etch), these problems have been fixed in version
3.0.3-0-3.

For the unstable distribution (sid), these problems will be fixed soon.

We recommend that you upgrade your xen-utils package.


Upgrade instructions
- --------------------

wget url
will fetch the file for you
dpkg -i file.deb
will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
will update the internal database
apt-get upgrade
will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.


Debian GNU/Linux 4.0 alias etch
- --------------------------------

Source archives:

http://security.debian.org/pool/updates/main/x/xen-3.0/xen-3.0_3.0.3-0.orig.tar.gz
Size/MD5 checksum: 6127238 71257a2d977a601594c70c9eac0a121b
http://security.debian.org/pool/updates/main/x/xen-3.0/xen-3.0_3.0.3-0-3.diff.gz
Size/MD5 checksum: 28697 64f2dd856726a95d88fe48531e987ff4
http://security.debian.org/pool/updates/main/x/xen-3.0/xen-3.0_3.0.3-0-3.dsc
Size/MD5 checksum: 1115 d42726f5a374bfb8eb1a6618174ff893

Architecture independent packages:

http://security.debian.org/pool/updates/main/x/xen-3.0/xen-docs-3.0_3.0.3-0-3_all.deb
Size/MD5 checksum: 533396 b91af7395e7a1169be06ced33ef56daa

amd64 architecture (AMD x86_64 (AMD64))

http://security.debian.org/pool/updates/main/x/xen-3.0/xen-utils-3.0.3-1_3.0.3-0-3_amd64.deb
Size/MD5 checksum: 368012 b4ceb2935cf07339c98b7aa67709a508
http://security.debian.org/pool/updates/main/x/xen-3.0/xen-ioemu-3.0.3-1_3.0.3-0-3_amd64.deb
Size/MD5 checksum: 331438 f7f8a51f48c87072fe2c0ffd03e066aa
http://security.debian.org/pool/updates/main/x/xen-3.0/xen-hypervisor-3.0.3-1-amd64_3.0.3-0-3_amd64.deb
Size/MD5 checksum: 269956 7957630a8fcd612e7492b7d14a36512d

i386 architecture (Intel ia32)

http://security.debian.org/pool/updates/main/x/xen-3.0/xen-hypervisor-3.0.3-1-i386-pae_3.0.3-0-3_i386.deb
Size/MD5 checksum: 273756 f36f6d51efa2c545d98275e63965569c
http://security.debian.org/pool/updates/main/x/xen-3.0/xen-ioemu-3.0.3-1_3.0.3-0-3_i386.deb
Size/MD5 checksum: 326526 b198abda8622589fb4dd0141744dddf0
http://security.debian.org/pool/updates/main/x/xen-3.0/xen-utils-3.0.3-1_3.0.3-0-3_i386.deb
Size/MD5 checksum: 347860 954ccb3ddf9aea5fa5a09e08abd6c95c
http://security.debian.org/pool/updates/main/x/xen-3.0/xen-hypervisor-3.0.3-1-i386_3.0.3-0-3_i386.deb
Size/MD5 checksum: 253984 b92b82d449805ff4a8d8f90b655be600


These files will probably be moved into the stable distribution on
its next update.

- ---------------------------------------------------------------------------------
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-security dists/stable/updates/main
Mailing list: debian-security-announce@lists.debian.org
Package info: `apt-cache show lt;pkggt;' and http://packages.debian.org/lt;pkggt;
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFHBpFKwM/Gs81MDZ0RAvZsAKCnXLupWqXyaSLVVtQwHmloeFo7lwCfXJGw
tM93ku81ukvZcGVP2yG86C4=
=NXa2
-----END PGP SIGNATURE-----



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/dsa_1384_1_new_xen_utils_packages_fix_several_vulnerabilities.html)