DSA 1280-1: New aircrack-ng packages fix arbitrary code execution
Posted on: 04/24/2007 09:40 PM

The Debian Security Team published a new security update for Debian GNU/Linux. Here the announcement:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 1280-1 security@debian.org
http://www.debian.org/security/ Moritz Muehlenhoff
April 24th, 2007 http://www.debian.org/security/faq
- --------------------------------------------------------------------------

Package : aircrack-ng
Vulnerability : buffer overflow
Problem-Type : remote
Debian-specific: no
CVE ID : CVE-2007-2057

It was discovered that aircrack-ng, a WEP/WPA security analysis tool,
performs insufficient validation of 802.11 authentication packets, which
allows the execution of arbitrary code.

The oldstable distribution (sarge) doesn't contain aircrack-ng packages.

For the stable distribution (etch) this problem has been fixed in
version 0.6.2-7etch1.

For the unstable distribution (sid) this problem has been fixed in
version 0.7-3.

We recommend that you upgrade your aircrack-ng packages. Packages for
the arm, sparc and mipsen architectures are not yet available. They
will be provided later.


Upgrade Instructions
- --------------------

wget url
will fetch the file for you
dpkg -i file.deb
will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
will update the internal database
apt-get upgrade
will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.


Debian GNU/Linux 4.0 alias etch
- -------------------------------

Source archives:

http://security.debian.org/pool/updates/main/a/aircrack-ng/aircrack-ng_0.6.2-7etch1.dsc
Size/MD5 checksum: 661 872aff5e32ad5c89a779578e3830b32d
http://security.debian.org/pool/updates/main/a/aircrack-ng/aircrack-ng_0.6.2-7etch1.diff.gz
Size/MD5 checksum: 47734 58cbd2a08adce2136967789ddf21fcac
http://security.debian.org/pool/updates/main/a/aircrack-ng/aircrack-ng_0.6.2.orig.tar.gz
Size/MD5 checksum: 150501 0b1a9fb6818822f933336efc9fff316b

Architecture independent components:

http://security.debian.org/pool/updates/main/a/aircrack-ng/aircrack_0.6.2-7etch1_all.deb
Size/MD5 checksum: 9132 6830331627fb76889703644c6d93d607

Alpha architecture:

http://security.debian.org/pool/updates/main/a/aircrack-ng/aircrack-ng_0.6.2-7etch1_alpha.deb
Size/MD5 checksum: 238954 9240aecb7ee517da7d32e5f122313844

AMD64 architecture:

http://security.debian.org/pool/updates/main/a/aircrack-ng/aircrack-ng_0.6.2-7etch1_amd64.deb
Size/MD5 checksum: 190972 12cb6f920db553bb1a76d1f4dc36bad2

HP Precision architecture:

http://security.debian.org/pool/updates/main/a/aircrack-ng/aircrack-ng_0.6.2-7etch1_hppa.deb
Size/MD5 checksum: 205880 34a2bc35ae45b53376906eb5485f4685

Intel IA-32 architecture:

http://security.debian.org/pool/updates/main/a/aircrack-ng/aircrack-ng_0.6.2-7etch1_i386.deb
Size/MD5 checksum: 192166 2be2b95c98f9de66886765c18335f9b9

Intel IA-64 architecture:

http://security.debian.org/pool/updates/main/a/aircrack-ng/aircrack-ng_0.6.2-7etch1_ia64.deb
Size/MD5 checksum: 268668 bc4ac4de85d212913cfb267c6472ed65

PowerPC architecture:

http://security.debian.org/pool/updates/main/a/aircrack-ng/aircrack-ng_0.6.2-7etch1_powerpc.deb
Size/MD5 checksum: 199288 bdf1467b714b6b9e3c7f6d2b4b874dcf

IBM S/390 architecture:

http://security.debian.org/pool/updates/main/a/aircrack-ng/aircrack-ng_0.6.2-7etch1_s390.deb
Size/MD5 checksum: 204934 88c3a532d8933130626f3a02b8b7cd35


These files will probably be moved into the stable distribution on
its next update.

- ---------------------------------------------------------------------------------
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-security dists/stable/updates/main
Mailing list: debian-security-announce@lists.debian.org
Package info: `apt-cache show lt;pkggt;' and http://packages.debian.org/lt;pkggt;
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFGLmpoXm3vHE4uyloRAmuYAKCM84PBOJKJe+E5HNtEOHcAW9998QCghFUf
m4pE0ctTSB6uyNHVVrA48p8=
=1LfB
-----END PGP SIGNATURE-----



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/dsa_1280_1_new_aircrack_ng_packages_fix_arbitrary_code_execution.html)