DSA 1155-2: New sendmail packages fix denial of service
Posted on: 08/24/2006 12:25 PM

The Debian Security Team published a new security update for Debian GNU/Linux. Here the announcement:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 1155-2 security@debian.org
http://www.debian.org/security/ Martin Schulze
August 24th, 2006 http://www.debian.org/security/faq
- --------------------------------------------------------------------------

Package : sendmail
Vulnerability : programming error
Problem type : remote
Debian-specific: no
CVE ID : CVE-2006-1173
CERT advisory : VU#146718
BugTraq ID : 18433
Debian Bug : 373801 380258

It turned out that the sendmail binary depends on libsasl2 (gt;= 2.1.19.dfsg1)
which is neither available in the stable nor in the the security archive.
This version is scheduled for the inclusion in the next update of the
stable release, though.

You'll have to download the referenced file for your architecture from
below and install it with dpkg -i.

As an alternative, temporarily adding the following line to
/etc/apt/sources.list will mitigate the problem as well:

deb http://ftp.debian.de/debian stable-proposed-updates main

Here is the original security advisory for completeness:

Frank Sheiness discovered that a MIME conversion routine in sendmail,
a powerful, efficient, and scalable mail transport agent, could be
tricked by a specially crafted mail to perform an endless recursion.

For the stable distribution (sarge) this problem has been fixed in
version 8.13.4-3sarge2.

For the unstable distribution (sid) this problem has been fixed in
version 8.13.7-1.

We recommend that you upgrade your sendmail package.


Upgrade Instructions
- --------------------

wget url
will fetch the file for you
dpkg -i file.deb
will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given at the end of this advisory:

apt-get update
will update the internal database
apt-get upgrade
will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.


Debian GNU/Linux 3.1 alias sarge
- --------------------------------

Source archives:

http://ftp.debian.org/debian/pool/main/c/cyrus-sasl2/cyrus-sasl2_2.1.19.dfsg1-0sarge2.diff.gz
Size/MD5 checksum: 31919 f7042b666907ca4294018bc764edce96
http://ftp.debian.org/debian/pool/main/c/cyrus-sasl2/cyrus-sasl2_2.1.19.dfsg1-0sarge2.dsc
Size/MD5 checksum: 1131 aca52362519bd66cda473678eaf2130f
http://ftp.debian.org/debian/pool/main/c/cyrus-sasl2/cyrus-sasl2_2.1.19.dfsg1.orig.tar.gz
Size/MD5 checksum: 1576960 f2fa0ce4d8b3dc37ca71fb5b5d57cd8b

Alpha architecture:

http://ftp.debian.org/debian/pool/main/c/cyrus-sasl2/libsasl2_2.1.19.dfsg1-0sarge2_alpha.deb
Size/MD5 checksum: 277878 30d488b82d54f006662f52609da94f0a

HP Precision architecture:

http://ftp.debian.org/debian/pool/main/c/cyrus-sasl2/libsasl2_2.1.19.dfsg1-0sarge2_hppa.deb
Size/MD5 checksum: 273306 46dec2833097a7006953004c712208f6

ARM architecture:

http://ftp.debian.org/debian/pool/main/c/cyrus-sasl2/libsasl2_2.1.19.dfsg1-0sarge2_arm.deb
Size/MD5 checksum: 260076 17cbbf95b9ba82428fce3721d8904fab

Intel IA-32 architecture:

http://ftp.debian.org/debian/pool/main/c/cyrus-sasl2/libsasl2_2.1.19.dfsg1-0sarge2_i386.deb
Size/MD5 checksum: 258784 2f307e6af80a02a3e559020a31f00c94

Motorola 680x0 architecture:

http://ftp.debian.org/debian/pool/main/c/cyrus-sasl2/libsasl2_2.1.19.dfsg1-0sarge2_m68k.deb
Size/MD5 checksum: 253302 27e9e53ad9f430d5d731236f0fb7c5ca

Big endian MIPS architecture:

http://ftp.debian.org/debian/pool/main/c/cyrus-sasl2/libsasl2_2.1.19.dfsg1-0sarge2_mips.deb
Size/MD5 checksum: 260866 8109e94b29d2f6a5cb1bedd0ce729ae9

Little endian MIPS architecture:

http://ftp.debian.org/debian/pool/main/c/cyrus-sasl2/libsasl2_2.1.19.dfsg1-0sarge2_mipsel.deb
Size/MD5 checksum: 261078 2e6cd2f4f8e8fa7cb6863e6378cf77e9

PowerPC architecture:

http://ftp.debian.org/debian/pool/main/c/cyrus-sasl2/libsasl2_2.1.19.dfsg1-0sarge2_powerpc.deb
Size/MD5 checksum: 268388 d3f233ab1a90934e6578b5ccebd5543b

Sun Sparc architecture:

http://ftp.debian.org/debian/pool/main/c/cyrus-sasl2/libsasl2_2.1.19.dfsg1-0sarge2_sparc.deb
Size/MD5 checksum: 257648 06552692dcf73bd6db29ca5e12ea90bf

IBM S/390 architecture:

http://ftp.debian.org/debian/pool/main/c/cyrus-sasl2/libsasl2_2.1.19.dfsg1-0sarge2_s390.deb
Size/MD5 checksum: 265332 586764113955d451c9ae16e404c7ea37

Intel IA-64 architecture:

http://ftp.debian.org/debian/pool/main/c/cyrus-sasl2/libsasl2_2.1.19.dfsg1-0sarge2_ia64.deb
Size/MD5 checksum: 297874 1b2e9357178ead1e33616513c8402080


These files will probably be moved into the stable distribution on
its next update.

- ---------------------------------------------------------------------------------
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-security dists/stable/updates/main
Mailing list: debian-security-announce@lists.debian.org
Package info: `apt-cache show lt;pkggt;' and http://packages.debian.org/lt;pkggt;

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.5 (GNU/Linux)

iD8DBQFE7W6AW5ql+IAeqTIRAv6sAJsHGI0CRXiBbMq+o7g7SEWfHl7xmQCeO/49
whGMz8lpCWo1gKxVM3VkJlY=
=cxqr
-----END PGP SIGNATURE-----



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/dsa_1155_2_new_sendmail_packages_fix_denial_of_service.html)