cvs Update for Gentoo
Posted on: 01/21/2003 09:50 PM

A cvs package secuity update for Gentoo Linux has been released:

By sending a malformed directory name it is possible to trigger an error condition that will make the function return at a point where a global pointer variable is already freed and has not got a new value assigned yet. This will result in a classical double-free() when the next Directory request is handled. With the help of other CVS requests it is possible to either leak some information that could be used to determine the heap position or to execute arbitrary code on systems that are known to be vulnerable to this kind of bugs.

SOLUTION

It is recommended that all Gentoo Linux users who are running dev-util/cvs upgrade to cvs-1.11.5 as follows:

emerge sync
emerge -u cvs
emerge clean




Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/cvs_update_for_gentoo.html)