Cups/Clearsilver Security Updates for Debian
Posted on: 12/01/2011 11:03 AM

The following two security updates are available for Debian GNU/Linux: [SECURITY] [DSA 2355-1] clearsilver security update, and [SECURITY] [DSA 2354-1] cups security update

[SECURITY] [DSA 2355-1] clearsilver security update
- -------------------------------------------------------------------------
Debian Security Advisory DSA-2355-1 security@debian.org
http://www.debian.org/security/ Moritz Muehlenhoff
November 30, 2011 http://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : clearsilver
Vulnerability : format string vulnerability
Problem type : remote
Debian-specific: no
CVE ID : CVE-2011-4357

Leo Iannacone and Colin Watson discovered a format string vulnerability
in the Python bindings for the Clearsilver HTML template system, which
may lead to denial of service or the execution of arbitrary code.

For the oldstable distribution (lenny), this problem has been fixed in
version 0.10.4-1.3+lenny1.

For the stable distribution (squeeze), this problem has been fixed in
version 0.10.5-1+squeeze1.

For the unstable distribution (sid), this problem will be fixed soon.

We recommend that you upgrade your clearsilver packages.

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: http://www.debian.org/security/

[SECURITY] [DSA 2354-1] cups security update
- -------------------------------------------------------------------------
Debian Security Advisory DSA-2354-1 security@debian.org
http://www.debian.org/security/ Yves-Alexis Perez
November 28, 2011 http://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : cups
Vulnerability : several
Problem type : remote
Debian-specific: no
CVE ID : CVE-2011-2896 CVE-2011-3170

Petr Sklenar and Tomas Hoger discovered that missing input sanitising in
the GIF decoder inside the Cups printing system could lead to denial
of service or potentially arbitrary code execution through crafted GIF
files.

For the oldstable distribution (lenny), this problem has been fixed in
version 1.3.8-1+lenny10.

For the stable distribution (squeeze), this problem has been fixed in
version 1.4.4-7+squeeze1.

For the testing and unstable distribution (sid), this problem has been
fixed in version 1.5.0-8.

We recommend that you upgrade your cups packages.

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: http://www.debian.org/security/




Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/cupsclearsilver_security_updates_for_debian.html)