Chromium/Hostapd/MariaDB/XOrg Updates for Gentoo Linux
Posted on: 11/11/2017 07:09 AM

The following updates has been released for Gentoo Linux:

GLSA 201711-02 : Chromium, Google Chrome: Multiple vulnerabilities
GLSA 201711-03 : hostapd and wpa_supplicant: Key Reinstallation (KRACK) attacks
GLSA 201711-04 : MariaDB, MySQL: Root privilege escalation
GLSA 201711-05 : X.Org Server: Multiple vulnerabilities

GLSA 201711-02 : Chromium, Google Chrome: Multiple vulnerabilities
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201711-02
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: Chromium, Google Chrome: Multiple vulnerabilities
Date: November 10, 2017
Bugs: #635556, #636800
ID: 201711-02

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in Chromium and Google Chrome,
the worst of which could result in the execution of arbitrary code.

Background
==========

Chromium is an open-source browser project that aims to build a safer,
faster, and more stable way for all users to experience the web.

Google Chrome is one fast, simple, and secure browser for all your
devices

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 www-client/chromium < 62.0.3202.89 >= 62.0.3202.89
2 www-client/google-chrome
< 62.0.3202.89 >= 62.0.3202.89
-------------------------------------------------------------------
2 affected packages

Description
===========

Multiple vulnerabilities have been discovered in Chromium and Google
Chrome. Please review the referenced CVE identifier and Google Chrome
Releases for details.

Impact
======

A remote attack may be able to execute arbitrary code, cause a Denial
of Service condition, or have other unspecified impacts.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Chromium users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot -v ">=www-client/chromium-62.0.3202.89"

All Google Chrome users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot -v ">=www-client/google-chrome-62.0.3202.89"

References
==========

[ 1 ] CVE-2017-15396
https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-15396
[ 2 ] Google Chrome Releases
https://chromereleases.googleblog.com/2017/11/stable-channel-update-for-desktop.html

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/201711-02

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2017 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5



GLSA 201711-03 : hostapd and wpa_supplicant: Key Reinstallation (KRACK) attacks

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201711-03
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: hostapd and wpa_supplicant: Key Reinstallation (KRACK)
attacks
Date: November 10, 2017
Bugs: #634436, #634438
ID: 201711-03

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=======
A flaw was discovered in the 4-way handshake in hostapd and
wpa_supplicant that allows attackers to conduct a Man in the Middle
attack.

Background
=========
wpa_supplicant is a WPA Supplicant with support for WPA and WPA2 (IEEE
802.11i / RSN). hostapd is a user space daemon for access point and
authentication servers.

Affected packages
================
-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 net-wireless/hostapd < 2.6-r1 >= 2.6-r1
2 net-wireless/wpa_supplicant
< 2.6-r3 >= 2.6-r3
-------------------------------------------------------------------
2 affected packages

Description
==========
WiFi Protected Access (WPA and WPA2) and it's associated technologies
are all vulnerable to the KRACK attacks. Please review the referenced
CVE identifiers for details.

Impact
=====
An attacker can carry out the KRACK attacks on a wireless network in
order to gain access to network clients. Once achieved, the attacker
can potentially harvest confidential information (e.g. HTTP/HTTPS),
inject malware, or perform a myriad of other attacks.

Workaround
=========
There is no known workaround at this time.

Resolution
=========
All hostapd users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-wireless/hostapd-2.6-r1"

All wpa_supplicant users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot -v ">=net-wireless/wpa_supplicant-2.6-r3"

References
=========
[ 1 ] CVE-2017-13077
https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-13077
[ 2 ] CVE-2017-13078
https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-13078
[ 3 ] CVE-2017-13079
https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-13079
[ 4 ] CVE-2017-13080


GLSA 201711-04 : MariaDB, MySQL: Root privilege escalation


- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201711-04
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: MariaDB, MySQL: Root privilege escalation
Date: November 10, 2017
Bugs: #635704, #635706
ID: 201711-04

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=======
A vulnerability was discovered in MariaDB and MySQL which may allow
local users to gain root privileges.

Background
=========
MySQL is a popular multi-threaded, multi-user SQL server. MariaDB is an
enhanced, drop-in replacement for MySQL.

Affected packages
================
-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 dev-db/mariadb < 10.0.30-r1 >= 10.0.30-r1
2 dev-db/mysql < 5.6.36-r1 >= 5.6.36-r1
-------------------------------------------------------------------
2 affected packages

Description
==========
The Gentoo installation scripts before 2017-09-29 have chown calls for
user-writable directory trees, which allows local users to gain
privileges by leveraging access to the mysql account for creation of a
link.

Impact
=====
A local attacker could escalate privileges to root.

Workaround
=========
There is no known workaround at this time.

Resolution
=========
All MariaDB users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">Þv-db/mariadb-10.0.30-r1"

All MySQL users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">Þv-db/mysql-5.6.36-r1"

References
=========
[ 1 ] CVE-2017-15945
https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-15945

Availability
===========
This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/201711-04



GLSA 201711-05 : X.Org Server: Multiple vulnerabilities


- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201711-05
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: X.Org Server: Multiple vulnerabilities
Date: November 10, 2017
Bugs: #635974
ID: 201711-05

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=======
Multiple vulnerabilities have been found in X.Org Server, the worst of
which could allow an attacker to execute arbitrary code.

Background
=========
The X.Org project provides an open source implementation of the X
Window System.

Affected packages
================
-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 x11-base/xorg-server < 1.19.5 >= 1.19.5

Description
==========
Multiple vulnerabilities have been discovered in X.Org Server. Please
review the referenced CVE identifiers for details.

Impact
=====
Attackers could execute arbitrary code or cause a Denial of Service
condition.

Workaround
=========
There is now know workaround at this time.

Resolution
=========
All X.Org Server users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=x11-base/xorg-server-1.19.5"

References
=========
[ 1 ] CVE-2017-12176
https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-12176
[ 2 ] CVE-2017-12177
https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-12177
[ 3 ] CVE-2017-12178
https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-12178
[ 4 ] CVE-2017-12179
https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-12179
[ 5 ] CVE-2017-12180
https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-12180
[ 6 ] CVE-2017-12181
https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-12181
[ 7 ] CVE-2017-12182
https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-12182
[ 8 ] CVE-2017-12183
https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-12183





Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/chromiumhostapdmariadbxorg_updates_for_gentoo_linux.html)