Bugzilla Security Update for Debian
Posted on: 12/31/2002 10:11 AM

A security for bugzilla under Debian GNU/Linux has been released

A cross site scripting vulnerability has been reported for Bugzilla, a web-based bug tracking system. Bugzilla does not properly sanitize any input submitted by users for use in quips. As a result, it is possible for a remote attacker to create a malicious link containing script code which will be executed in the browser of a legitimate user, in the context of the website running Bugzilla. This issue may be exploited to steal cookie-based authentication credentials from legitimate users of the website running the vulnerable software.

This vulnerability only affects users who have the 'quips' feature enabled and who upgraded from version 2.10 which did not exist inside of Debian. The Debian package history of Bugzilla starts with 1.13 and jumped to 2.13. However, users could have installed version 2.10 prior to the Debian package.

For the current stable distribution (woody) this problem has been fixed in version 2.14.2-0woody3.

The old stable distribution (potato) does not contain a Bugzilla package.

For the unstable distribution (sid) this problem will be fixed soon.


Read more


Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/bugzilla_security_update_for_debian.html)