AutoTrace/Jbig2dec Updates for Gentoo Linux
Posted on: 08/27/2017 08:22 AM

The following updates has been released for Gentoo Linux:

GLSA 201708-09 : AutoTrace: Multiple vulnerabilities
GLSA 201708-10 : jbig2dec: User-assisted execution of arbitrary code

GLSA 201708-09 : AutoTrace: Multiple vulnerabilities
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201708-09
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: AutoTrace: Multiple vulnerabilities
Date: August 26, 2017
Bugs: #613992, #619040
ID: 201708-09

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in AutoTrace, the worst of
which could cause a Denial of Service condition.

Background
==========

AutoTrace converts bitmap to vector graphics.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 media-gfx/autotrace <= 0.31.1-r8 Vulnerable!
-------------------------------------------------------------------
NOTE: Certain packages are still vulnerable. Users should migrate
to another package if one is available or wait for the
existing packages to be marked stable by their
architecture maintainers.

Description
===========

Heap-based buffer overflows have been discovered in the
pstoedit_suffix_table_init and pnm_load_rawpbm functions of AutoTrace.

Impact
======

Remote attackers, by enticing a user to process a crafted bmp image
file, could cause a Denial of Service condition.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

Gentoo has discontinued support for AutoTrace. We recommend that users
unmerge AutoTrace:

# emerge --unmerge "media-gfx/autotrace"

References
==========

[ 1 ] CVE-2016-7392
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2016-7392
[ 2 ] CVE-2017-9153
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-9153

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/201708-09

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2017 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5



GLSA 201708-10 : jbig2dec: User-assisted execution of arbitrary code
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201708-10
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: jbig2dec: User-assisted execution of arbitrary code
Date: August 26, 2017
Bugs: #616464
ID: 201708-10

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple integer overflow flaws have been discovered in jbig2dec,
possibly resulting in execution of arbitrary code or Denial of Service.

Background
==========

jbig2dec is a decoder implementation of the JBIG2 image compression
format.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 media-libs/jbig2dec < 0.13-r4 >= 0.13-r4

Description
===========

Integer overflow errors have been discovered in the
jbig2_decode_symbol_dict, jbig2_build_huffman_table, and
jbig2_image_compose functions of jbig2dec.

Impact
======

A remote attacker, by enticing a user to open a specially crafted JBIG2
file using an application linked against jbig2dec, could possibly
execute arbitrary code with the privileges of the process or cause a
Denial of Service condition.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All jbig2dec users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=media-libs/jbig2dec-0.13-r4"

References
==========

[ 1 ] CVE-2017-7885
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-7885
[ 2 ] CVE-2017-7975
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-7975
[ 3 ] CVE-2017-7976
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-7976

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/201708-10

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2017 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5






Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/autotracejbig2dec_updates_for_gentoo_linux.html)