Asterisk Security Update for Debian 7 LTS
Posted on: 12/31/2017 09:18 AM

Updated asterisk packages has been released for Debian GNU/Linux 7 LTS

Asterisk Security Update for Debian 7 LTS


Package : asterisk
Version : 1:1.8.13.1~dfsg1-3+deb7u8
CVE ID : CVE-2017-17090
Debian Bug : 883342

A vulnerability has been discovered in Asterisk, an open source PBX and
telephony toolkit, which may result in resource exhaustion and denial of
service.

CVE-2017-17090: memory leak from chan_skinny.
If the chan_skinny (AKA SCCP protocol) channel driver is flooded with
certain requests it can cause the asterisk process to use excessive
amounts of virtual memory eventually causing asterisk to stop processing
requests of any kind. The chan_skinny driver has been updated to release
memory allocations in a correct manner thereby preventing any possiblity
of exhaustion.

For Debian 7 "Wheezy", these problems have been fixed in version
1:1.8.13.1~dfsg1-3+deb7u8.

We recommend that you upgrade your asterisk packages.

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS




Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/asterisk_security_update_for_debian_7_lts_i965.html)