ArgyllCMS/Chrony Updates for Gentoo
Posted on: 03/01/2014 07:02 AM

The following two updates are available for Gentoo Linux:

[ GLSA 201402-28 ] Chrony: Multiple vulnerabilities
[ GLSA 201402-29 ] ArgyllCMS: User-assisted execution of arbitrary code

[ GLSA 201402-28 ] Chrony: Multiple vulnerabilities
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201402-28
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: Chrony: Multiple vulnerabilities
Date: February 28, 2014
Bugs: #480364
ID: 201402-28

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in Chrony, possibly allowing
remote attackers to cause a Denial of Service condition.

Background
==========

Chrony is a pair of programs which are used to maintain the accuracy of
the system clock on a computer.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 net-misc/chrony <= 1.29 >= 1.29

Description
===========

Multiple vulnerabilities have been discovered in Chrony. Please review
the CVE identifiers referenced below for details.

Impact
======

A remote attacker could possibly cause a Denial of Service condition by
sending specially crafted packets.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Chrony users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-misc/chrony-1.29"

References
==========

[ 1 ] CVE-2012-4502
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-4502
[ 2 ] CVE-2012-4503
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-4503

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201402-28.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2014 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5




[ GLSA 201402-29 ] ArgyllCMS: User-assisted execution of arbitrary code
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201402-29
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: ArgyllCMS: User-assisted execution of arbitrary code
Date: February 28, 2014
Bugs: #437652
ID: 201402-29

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple integer overflow vulnerabilities have been found in ArgyllCMS
which could allow attackers to execute arbitrary code.

Background
==========

ArgyllCMS is an ICC compatible color management system that supports
accurate ICC profile creation for scanners, cameras and film recorders.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 media-gfx/argyllcms < 1.4.0-r1 >= 1.4.0-r1

Description
===========

Multiple integer overflow vulnerabilities have been discovered in the
ICC Format Library in ArgyllCMS.

Impact
======

A remote attacker could entice a user to open a specially crafted image
file using ArgyllCMS, possibly resulting in execution of arbitrary code
with the privileges of the process or a Denial of Service condition.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All ArgyllCMS users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=media-gfx/argyllcms-1.4.0-r1"

References
==========

[ 1 ] CVE-2012-4405
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-4405

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201402-29.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2014 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5







Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/argyllcmschrony_updates_for_gentoo.html)