MDKSA-2005:237 - Updated cpio packages fix buffer overflow on x86_64
Posted on: 12/24/2005 05:32 AM

The Mandriva Security Team published a new security update: MDKSA-2005:237 - Updated cpio packages fix buffer overflow on x86_64 for Mandriva Linux. Here the announcement:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

_______________________________________________________________________

Mandriva Linux Security Advisory MDKSA-2005:237
http://www.mandriva.com/security/
_______________________________________________________________________

Package : cpio
Date : December 23, 2005
Affected: 10.2, 2006.0
_______________________________________________________________________

Problem Description:

A buffer overflow in cpio 2.6 on 64-bit platforms could allow a local
user to create a DoS (crash) and possibly execute arbitrary code when
creating a cpio archive with a file whose size is represented by more
than 8 digits.

The updated packages have been patched to correct these problems.
_______________________________________________________________________

References:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-4268
_______________________________________________________________________

Updated Packages:

Mandriva Linux 10.2:
b0400cb8878a93cc4e4d4326a0a46641 10.2/RPMS/cpio-2.6-3.3.102mdk.i586.rpm
ad70b46181e5a9ae2ca7ed97bb2c3853 10.2/SRPMS/cpio-2.6-3.3.102mdk.src.rpm

Mandriva Linux 10.2/X86_64:
0a7ca9d0d1de932219a76dcee4195ff8 x86_64/10.2/RPMS/cpio-2.6-3.3.102mdk.x86_64.rpm
ad70b46181e5a9ae2ca7ed97bb2c3853 x86_64/10.2/SRPMS/cpio-2.6-3.3.102mdk.src.rpm

Mandriva Linux 2006.0:
571d79d56efac2687713e63180f10049 2006.0/RPMS/cpio-2.6-5.1.20060mdk.i586.rpm
998e92b468e495d779efd10daacae3ad 2006.0/SRPMS/cpio-2.6-5.1.20060mdk.src.rpm

Mandriva Linux 2006.0/X86_64:
0bd4e5c9d85826c706232e21d3393317 x86_64/2006.0/RPMS/cpio-2.6-5.1.20060mdk.x86_64.rpm
998e92b468e495d779efd10daacae3ad x86_64/2006.0/SRPMS/cpio-2.6-5.1.20060mdk.src.rpm
_______________________________________________________________________

To upgrade automatically use MandrivaUpdate or urpmi. The verification
of md5 checksums and GPG signatures is performed automatically for you.

All packages are signed by Mandriva for security. You can obtain the
GPG public key of the Mandriva Security Team by executing:

gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

You can view other update advisories for Mandriva Linux at:

http://www.mandriva.com/security/advisories

If you want to report vulnerabilities, please contact

security_(at)_mandriva.com
_______________________________________________________________________

Type Bits/KeyID Date User ID
pub 1024D/22458A98 2000-07-10 Mandriva Security Team
lt;security*mandriva.comgt;
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (GNU/Linux)

iD8DBQFDrHPemqjQ0CJFipgRApCrAJ40iYNwqiNcgLiIrd5zh3tbuAkFSACgpiZ3
tD9IdCprIvkMOdpAqBAkdzU=
=UtT3
-----END PGP SIGNATURE-----



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/_mdksa_2005237__updated_cpio_packages_fix_buffer_overflow_on_x86_64.html)