7 Updates for Gentoo
Posted on: 11/21/2011 10:52 AM

7 new security updates has been released for Gentoo Linux

[gentoo-announce] [ GLSA 201111-11 ] GNU Tar: User-assisted execution of arbitrary code
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201111-11
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: GNU Tar: User-assisted execution of arbitrary code
Date: November 20, 2011
Bugs: #313333
ID: 201111-11

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A buffer overflow flaw in GNU Tar could result in execution of
arbitrary code or a Denial of Service.

Background
==========

GNU Tar is a utility to create archives as well as add and extract
files from archives.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 app-arch/tar < 1.23 >= 1.23

Description
===========

GNU Tar is vulnerable to a boundary error in the rmt_read__ function in
lib/rtapelib.c, which could cause a heap-based buffer overflow.

Impact
======

A remote attacker could entice the user to load a specially crafted
archive, possibly resulting in the execution of arbitrary code or a
Denial of Service.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All GNU Tar users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=app-arch/tar-1.23"

NOTE: This is a legacy GLSA. Updates for all affected architectures are
available since July 18, 2010. It is likely that your system is already
no longer affected by this issue.

References
==========

[ 1 ] CVE-2010-0624
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2010-0624

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201111-11.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2011 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5



[gentoo-announce] [ GLSA 201111-09 ] Perl Safe module: Arbitrary Perl code injection
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201111-09
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: Perl Safe module: Arbitrary Perl code injection
Date: November 20, 2011
Bugs: #325563
ID: 201111-09

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

The Safe module for Perl does not properly restrict code, allowing a
remote attacker to execute arbitrary Perl code outside of a restricted
compartment.

Background
==========

Safe is a Perl module to compile and execute code in restricted
compartments.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 perl-core/Safe < 2.27 >= 2.27
2 virtual/perl-Safe < 2.27 >= 2.27
-------------------------------------------------------------------
2 affected packages
-------------------------------------------------------------------

Description
===========

Unsafe code evaluation prevents the Safe module from properly
restricting the code of implicitly called methods on implicitly blessed
objects.

Impact
======

A remote attacker could entice a user to load a specially crafted Perl
script, resulting in execution arbitrary Perl code outside of a
restricted compartment.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All users of the standalone Perl Safe module should upgrade to the
latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=perl-core/Safe-2.27"

All users of the Safe module bundled with Perl should upgrade to the
latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=virtual/perl-Safe-2.27"

NOTE: This is a legacy GLSA. Updates for all affected architectures are
available since July 18, 2010. It is likely that your system is already
no longer affected by this issue.

References
==========

[ 1 ] CVE-2010-1168
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2010-1168

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201111-09.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2011 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5



[gentoo-announce] [ GLSA 201111-08 ] radvd: Multiple vulnerabilities
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201111-08
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: High
Title: radvd: Multiple vulnerabilities
Date: November 20, 2011
Bugs: #385967
ID: 201111-08

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in radvd which could
potentially lead to privilege escalation, data loss, or a Denial of
Service.

Background
==========

radvd is an IPv6 router advertisement daemon for Linux and BSD.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 net-misc/radvd < 1.8.2 >= 1.8.2

Description
===========

Multiple vulnerabilities have been discovered in radvd. Please review
the CVE identifiers referenced below for details.

Impact
======

A remote unauthenticated attacker may be able to gain escalated
privileges, escalate the privileges of the radvd process, overwrite
files with specific names, or cause a Denial of Service. Local
attackers may be able to overwrite the contents of arbitrary files
using symlinks.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All radvd users should upgrade to the latest stable version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-misc/radvd-1.8.2"

References
==========

[ 1 ] CVE-2011-3601
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-3601
[ 2 ] CVE-2011-3602
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-3602
[ 3 ] CVE-2011-3603
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-3603
[ 4 ] CVE-2011-3604
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-3604
[ 5 ] CVE-2011-3605
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-3605

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201111-08.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2011 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5



[gentoo-announce] [ GLSA 201111-10 ] Evince: Multiple vulnerabilities
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201111-10
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: Evince: Multiple vulnerabilities
Date: November 20, 2011
Bugs: #350681, #363447
ID: 201111-10

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in Evince, allowing remote
attackers to execute arbitrary code or cause a Denial of Service.

Background
==========

Evince is a document viewer for multiple document formats, including
PostScript.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 app-text/evince < 2.32.0-r2 >= 2.32.0-r2

Description
===========

Multiple vulnerabilities have been discovered in Evince. Please review
the CVE identifiers referenced below for details.

Impact
======

A remote attacker could entice a user to load a DVI file with a
specially crafted font, resulting in the execution of arbitrary code
with the privileges of the user running the application or a Denial of
Service.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Evince users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=app-text/evince-2.32.0-r2"

NOTE: This is a legacy GLSA. Updates for all affected architectures are
available since April 26, 2011. It is likely that your system is
already no longer affected by this issue.

References
==========

[ 1 ] CVE-2010-2640
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2010-2640
[ 2 ] CVE-2010-2641
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2010-2641
[ 3 ] CVE-2010-2642
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2010-2642
[ 4 ] CVE-2010-2643
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2010-2643

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201111-10.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2011 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5



[gentoo-announce] [ GLSA 201111-12 ] abcm2ps: Multiple vulnerabilities
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201111-12
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: abcm2ps: Multiple vulnerabilities
Date: November 20, 2011
Bugs: #322859
ID: 201111-12

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities, including buffer overflows, have been found
in abcm2ps.

Background
==========

abcm2ps is a program to convert abc files to Postscript files.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 media-sound/abcm2ps < 5.9.13 >= 5.9.13

Description
===========

Multiple vulnerabilities have been discovered in abcm2ps:

* Boundary errors in the PUT0 and PUT1 macros, the trim_title()
function, or a long "-O" command line option can lead to a buffer
overflow (CVE-2010-3441).
* A vulnerability in the getarena() function in abc2ps.c can cause a
heap-based buffer overflow in abcm2ps (CVE-2010-4743).
* Multiple unspecified vulnerabilities (CVE-2010-4744).

Impact
======

A remote attacker could entice a user to load a specially crafted ABC
file or use a long -O option on the command line, resulting in the
execution of arbitrary code.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All abcm2ps users should upgrade to the latest stable version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=media-sound/abcm2ps-5.9.13"

NOTE: This is a legacy GLSA. Updates for all affected architectures are
available since August 27, 2010. It is likely that your system is
already no longer affected by this issue.

References
==========

[ 1 ] CVE-2010-3441
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2010-3441
[ 2 ] CVE-2010-4743
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2010-4743
[ 3 ] CVE-2010-4744
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2010-4744

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201111-12.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2011 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5



[gentoo-announce] [ GLSA 201111-06 ] MaraDNS: Arbitrary code execution
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201111-06
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: High
Title: MaraDNS: Arbitrary code execution
Date: November 20, 2011
Bugs: #352569
ID: 201111-06

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A buffer overflow vulnerability in MaraDNS allows remote attackers to
execute arbitrary code or cause a Denial of Service.

Background
==========

MaraDNS is a proxy DNS server with permanent caching.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 net-dns/maradns < 1.4.06 >= 1.4.06

Description
===========

A long DNS hostname with a large number of labels could trigger a
buffer overflow in the compress_add_dlabel_points() function of
dns/Compress.c.

Impact
======

A remote unauthenticated attacker could execute arbitrary code or cause
a Denial of Service.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All MaraDNS users should upgrade to the latest stable version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-dns/maradns-1.4.06"

NOTE: This is a legacy GLSA. Updates for all affected architectures are
available since February 12, 2011. It is likely that your system is
already no longer affected by this issue.

References
==========

[ 1 ] CVE-2011-0520
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-0520

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201111-06.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2011 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5



[gentoo-announce] [ GLSA 201111-07 ] TinTin++: Multiple vulnerabilities
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201111-07
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: High
Title: TinTin++: Multiple vulnerabilities
Date: November 20, 2011
Bugs: #209903
ID: 201111-07

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been reported in TinTin++ which could
allow a remote attacker to conduct several attacks, including the
execution of arbitrary code and Denial of Service.

Background
==========

TinTin++ is a free MUD gaming client.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 games-mud/tintin < 1.98.0 >= 1.98.0

Description
===========

Multiple vulnerabilities have been discovered in TinTin++. Please
review the CVE identifiers referenced below for details.

Impact
======

Remote unauthenticated attackers may be able to execute arbitrary code
with the privileges of the TinTin++ process, cause a Denial of Service,
or truncate arbitrary files in the top level of the home directory
belonging to the user running the TinTin++ process.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All TinTin++ users should upgrade to the latest stable version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=games-mud/tintin-1.98.0"

NOTE: This is a legacy GLSA. Updates for all affected architectures are
available since March 25, 2008. It is likely that your system is
already no longer affected by this issue.

References
==========

[ 1 ] CVE-2008-0671
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2008-0671
[ 2 ] CVE-2008-0672
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2008-0672
[ 3 ] CVE-2008-0673
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2008-0673

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201111-07.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2011 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5






Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/7_updates_for_gentoo.html)