6 Security Updates for Gentoo Linux
Posted on: 08/15/2012 11:01 AM

6 security updates has been released for Gentoo Linux: [ GLSA 201208-06 ] libgdata: Man-in-the-Middle attack, [ GLSA 201208-05 ] Perl Config-IniFiles Module: Insecure temporary file usage, [ GLSA 201208-04 ] Gajim: Multiple vulnerabilities, [ GLSA 201208-03 ] Chromium: Multiple vulnerabilities, [ GLSA 201208-01 ] socat: Arbitrary code execution, and [ GLSA 201208-02 ] Puppet: Multiple vulnerabilities

[ GLSA 201208-06 ] libgdata: Man-in-the-Middle attack
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201208-06
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: libgdata: Man-in-the-Middle attack
Date: August 14, 2012
Bugs: #408245
ID: 201208-06

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A vulnerability in libgdata could allow remote attackers to perform
man-in-the-middle attacks.

Background
==========

libgdata is a GLib-based library for accessing online service APIs
using the GData protocol.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 dev-libs/libgdata < 0.8.1-r2 >= 0.8.1-r2

Description
===========

An error in the "_gdata_service_build_session()" function of
gdata-service.c prevents libgdata from properly validating
certificates.

Impact
======

A remote attacker could perform man-in-the-middle attacks to spoof
arbitrary SSL servers via a crafted certificate.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All libgdata users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-libs/libgdata-0.8.1-r2"

References
==========

[ 1 ] CVE-2012-1177
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-1177

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201208-06.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2012 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5




[ GLSA 201208-05 ] Perl Config-IniFiles Module: Insecure temporary file usage
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201208-05
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: Perl Config-IniFiles Module: Insecure temporary file usage
Date: August 14, 2012
Bugs: #414485
ID: 201208-05

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

An insecure temporary file usage has been reported in the Perl
Config-IniFiles module, possibly allowing symlink attacks.

Background
==========

Config-IniFiles is a Perl module for reading .ini-style configuration
files.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 dev-perl/Config-IniFiles
< 2.710.0 >= 2.710.0

Description
===========

The Perl Config-IniFiles module uses predicatable temporary file names.

Impact
======

A local attacker could perform symlink attacks to overwrite arbitrary
files with the privileges of the user running the application.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All users of the Perl Config-IniFiles module should upgrade to the
latest version:

# emerge --sync
# emerge --ask --oneshot -v ">=dev-perl/Config-IniFiles-2.710.0"

References
==========

[ 1 ] CVE-2012-2451
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-2451

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201208-05.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2012 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5




[ GLSA 201208-04 ] Gajim: Multiple vulnerabilities
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201208-04
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: Gajim: Multiple vulnerabilities
Date: August 14, 2012
Bugs: #411269, #412215
ID: 201208-04

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in Gajim, the worst of which
may allow execution of arbitrary code.

Background
==========

Gajim is a Jabber and XMPP client written in PyGTK.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 net-im/gajim < 0.15-r1 >= 0.15-r1

Description
===========

Multiple vulnerabilities have been discovered in Gajim. Please review
the CVE identifiers referenced below for details.

Impact
======

A remote attacker could entice a user to open a specially crafted link
using Gajim, possibly resulting in execution of arbitrary code with the
privileges of the process or a Denial of Service condition.
Furthermore, a remote attacker could use a specially crafted Jabber ID,
possibly resulting in execution of arbitrary SQL statements.

A local attacker could perform symlink attacks to overwrite arbitrary
files with the privileges of the user running the application.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Gajim users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-im/gajim-0.15-r1"

References
==========

[ 1 ] CVE-2012-2085
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-2085
[ 2 ] CVE-2012-2086
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-2086
[ 3 ] CVE-2012-2093
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-2093

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201208-04.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2012 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5




[ GLSA 201208-03 ] Chromium: Multiple vulnerabilities
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201208-03
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: Chromium: Multiple vulnerabilities
Date: August 14, 2012
Bugs: #423719, #426204, #429174
ID: 201208-03

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been reported in Chromium, some of which
may allow execution of arbitrary code.

Background
==========

Chromium is an open source web browser project.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 www-client/chromium < 21.0.1180.57 >= 21.0.1180.57

Description
===========

Multiple vulnerabilities have been discovered in Chromium. Please
review the CVE identifiers and release notes referenced below for
details.

Impact
======

A remote attacker could entice a user to open a specially crafted web
site using Chromium, possibly resulting in the execution of arbitrary
code with the privileges of the process, a Denial of Service condition,
disclosure of sensitive information, or other unspecified impact.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Chromium users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot -v ">=www-client/chromium-21.0.1180.57"

References
==========

[ 1 ] CVE-2012-2815
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-2815
[ 2 ] CVE-2012-2817
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-2817
[ 3 ] CVE-2012-2818
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-2818
[ 4 ] CVE-2012-2819
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-2819
[ 5 ] CVE-2012-2820
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-2820
[ 6 ] CVE-2012-2821
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-2821
[ 7 ] CVE-2012-2823
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-2823
[ 8 ] CVE-2012-2824
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-2824
[ 9 ] CVE-2012-2825
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-2825
[ 10 ] CVE-2012-2826
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-2826
[ 11 ] CVE-2012-2829
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-2829
[ 12 ] CVE-2012-2830
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-2830
[ 13 ] CVE-2012-2831
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-2831
[ 14 ] CVE-2012-2834
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-2834
[ 15 ] CVE-2012-2842
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-2842
[ 16 ] CVE-2012-2843
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-2843
[ 17 ] CVE-2012-2846
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-2846
[ 18 ] CVE-2012-2847
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-2847
[ 19 ] CVE-2012-2848
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-2848
[ 20 ] CVE-2012-2849
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-2849
[ 21 ] CVE-2012-2853
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-2853
[ 22 ] CVE-2012-2854
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-2854
[ 23 ] CVE-2012-2857
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-2857
[ 24 ] CVE-2012-2858
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-2858
[ 25 ] CVE-2012-2859
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-2859
[ 26 ] CVE-2012-2860
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-2860
[ 27 ] Release Notes 20.0.1132.43

http://googlechromereleases.blogspot.com/2012/06/stable-channel-update_26.html
[ 28 ] Release Notes 20.0.1132.57

http://googlechromereleases.blogspot.com/2012/07/stable-channel-update.html
[ 29 ] Release Notes 21.0.1180.57

http://googlechromereleases.blogspot.com/2012/07/stable-channel-release.html

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201208-03.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2012 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5




[ GLSA 201208-01 ] socat: Arbitrary code execution
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201208-01
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: High
Title: socat: Arbitrary code execution
Date: August 14, 2012
Bugs: #415977
ID: 201208-01

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A buffer overflow in socat might allow remote attackers to execute
arbitrary code.

Background
==========

socat is a multipurpose bidirectional relay, similar to netcat.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 net-misc/socat < 1.7.2.1 >= 1.7.2.1

Description
===========

A vulnerability in the "xioscan_readline()" function in xio-readline.c
could cause a heap-based buffer overflow.

Impact
======

A remote attacker could possibly execute arbitrary code with the
privileges of the socat process.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All socat users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-misc/socat-1.7.2.1"

References
==========

[ 1 ] CVE-2012-0219
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-0219
[ 2 ] Socat security advisory 3
http://www.dest-unreach.org/socat/contrib/socat-secadv3.html

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201208-01.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2012 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5




[ GLSA 201208-02 ] Puppet: Multiple vulnerabilities
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201208-02
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: High
Title: Puppet: Multiple vulnerabilities
Date: August 14, 2012
Bugs: #410857
ID: 201208-02

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in Puppet, the worst of which
could lead to execution of arbitrary code.

Background
==========

Puppet is a system configuration management tool written in Ruby.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 app-admin/puppet < 2.7.13 >= 2.7.13

Description
===========

Multiple vulnerabilities have been found in Puppet:

* Puppet uses predictable file names for temporary files
(CVE-2012-1906).
* REST requests for a file in a remote filebucket are not handled
properly by overriding filebucket storage locations (CVE-2012-1986).
* REST requests for a file in a remote filebucket are not handled
properly by reading streams or writing files on the Puppet master's
file system (CVE-2012-1987).
* File name paths are not properly sanitized from bucket requests
(CVE-2012-1988).
* The Telnet utility in Puppet does not handle temporary files securely
(CVE-2012-1989).

Impact
======

A local attacker with access to agent SSL keys could possibly execute
arbitrary code with the privileges of the process, cause a Denial of
Service condition, or perform symlink attacks to overwrite or read
arbitrary files on the Puppet master.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Puppet users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=app-admin/puppet-2.7.13"

References
==========

[ 1 ] CVE-2012-1906
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-1906
[ 2 ] CVE-2012-1986
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-1986
[ 3 ] CVE-2012-1987
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-1987
[ 4 ] CVE-2012-1988
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-1988
[ 5 ] CVE-2012-1989
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-1989

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201208-02.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2012 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5







Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/6_security_updates_for_gentoo_linux.html)