6 Gentoo Security Updates
Posted on: 06/04/2010 12:56 PM

The following 6 security updates for Gentoo Linux are available: lighttpd, GD, XEmacs, Asterisk, Bugzilla, and Oracle JRE/JDK

[gentoo-announce] [ GLSA 201006-17 ] lighttpd: Denial of Service
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201006-17
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: lighttpd: Denial of Service
Date: June 03, 2010
Bugs: #303213
ID: 201006-17

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A processing error in lighttpd might result in a Denial of Service
condition.

Background
==========

lighttpd is a lightweight high-performance web server.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 www-servers/lighttpd < 1.4.25-r1 >= 1.4.25-r1

Description
===========

Li Ming reported that lighttpd does not properly process packets that
are sent overly slow.

Impact
======

A remote attacker might send specially crafted packets to a server
running lighttpd, possibly resulting in a Denial of Service condition
via host memory exhaustion.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All lighttpd users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose
">=www-servers/lighttpd-1.4.25-r1"

References
==========

[ 1 ] CVE-2010-0295
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-0295

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201006-17.xml


[gentoo-announce] [ GLSA 201006-16 ] GD: User-assisted execution of arbitrary code
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201006-16
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: GD: User-assisted execution of arbitrary code
Date: June 03, 2010
Bugs: #292130
ID: 201006-16

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

The GD library is prone to a buffer overflow vulnerability.

Background
==========

GD is a graphic library for fast image creation.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 media-libs/gd < 2.0.35-r1 >= 2.0.35-r1

Description
===========

Tomas Hoger reported that the _gdGetColors() function in gd_gd.c does
not properly verify the colorsTotal struct member, possibly leading to
a buffer overflow.

Impact
======

A remote attacker could entice a user to open a specially crafted image
file with a program using the GD library, possibly resulting in the
remote execution of arbitrary code with the privileges of the user
running the application, or a Denial of Service condition.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All GD users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=media-libs/gd-2.0.35-r1"

NOTE: This is a legacy GLSA. Updates for all affected architectures are
available since November 21, 2009. It is likely that your system is
already no longer affected by this issue.

References
==========

[ 1 ] CVE-2009-3546
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-3546

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201006-16.xml


[gentoo-announce] [ GLSA 201006-15 ] XEmacs: User-assisted execution of arbitrary code
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201006-15
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: XEmacs: User-assisted execution of arbitrary code
Date: June 03, 2010
Bugs: #275397
ID: 201006-15

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple integer overflow errors in XEmacs might allow remote,
user-assisted attackers to execute arbitrary code.

Background
==========

XEmacs is a highly extensible and customizable text editor.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 app-editors/xemacs < 21.4.22-r1 >= 21.4.22-r1

Description
===========

Tielei Wang reported multiple integer overflow vulnerabilities in the
tiff_instantiate(), png_instantiate() and jpeg_instantiate() functions
in glyphs-eimage.c, all possibly leading to heap-based buffer
overflows.

Impact
======

A remote attacker could entice a user to open a specially crafted TIFF,
JPEG or PNG file using XEmacs, possibly resulting in the remote
execution of arbitrary code with the privileges of the user running the
application, or a Denial of Service condition.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All XEmacs users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=app-editors/xemacs-21.4.22-r1"

NOTE: This is a legacy GLSA. Updates for all affected architectures are
available since July 26, 2009. It is likely that your system is already
no longer affected by this issue.

References
==========

[ 1 ] CVE-2009-2688
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-2688

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201006-15.xml


[gentoo-announce] [ GLSA 201006-20 ] Asterisk: Multiple vulnerabilities
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201006-20
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: Asterisk: Multiple vulnerabilities
Date: June 04, 2010
Bugs: #281107, #283624, #284892, #295270
ID: 201006-20

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities in Asterisk might allow remote attackers to
cause a Denial of Service condition, or conduct other attacks.

Background
==========

Asterisk is an open source telephony engine and toolkit.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 net-misc/asterisk < 1.2.37 >= 1.2.37

Description
===========

Multiple vulnerabilities have been reported in Asterisk:

* Nick Baggott reported that Asterisk does not properly process
overly long ASCII strings in various packets (CVE-2009-2726).

* Noam Rathaus and Blake Cornell reported a flaw in the IAX2 protocol
implementation (CVE-2009-2346).

* amorsen reported an input processing error in the RTP protocol
implementation (CVE-2009-4055).

* Patrik Karlsson reported an information disclosure flaw related to
the REGISTER message (CVE-2009-3727).

* A vulnerability was found in the bundled Prototype JavaScript
library, related to AJAX calls (CVE-2008-7220).

Impact
======

A remote attacker could exploit these vulnerabilities by sending a
specially crafted package, possibly causing a Denial of Service
condition, or resulting in information disclosure.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Asterisk users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-misc/asterisk-1.2.37"

NOTE: This is a legacy GLSA. Updates for all affected architectures are
available since January 5, 2010. It is likely that your system is
already no longer affected by this issue.

References
==========

[ 1 ] CVE-2009-2726
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-2726
[ 2 ] CVE-2009-2346
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-2346
[ 3 ] CVE-2009-4055
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-4055
[ 4 ] CVE-2009-3727
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-3727
[ 5 ] CVE-2008-7220
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-7220

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201006-20.xml


[gentoo-announce] [ GLSA 201006-19 ] Bugzilla: Multiple vulnerabilities
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201006-19:02
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: Bugzilla: Multiple vulnerabilities
Date: June 04, 2010
Updated: June 04, 2010
Bugs: #239564, #258592, #264572, #284824, #303437, #303725
ID: 201006-19:02

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Bugzilla is prone to multiple medium severity vulnerabilities.

Background
==========

Bugzilla is a bug tracking system from the Mozilla project.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 www-apps/bugzilla < 3.2.6 >= 3.2.6

Description
===========

Multiple vulnerabilities have been reported in Bugzilla. Please review
the CVE identifiers referenced below for details.

Impact
======

A remote attacker might be able to disclose local files, bug
information, passwords, and other data under certain circumstances.
Furthermore, a remote attacker could conduct SQL injection, Cross-Site
Scripting (XSS) or Cross-Site Request Forgery (CSRF) attacks via
various vectors.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Bugzilla users should upgrade to an unaffected version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=www-apps/bugzilla-3.2.6"

Bugzilla 2.x and 3.0 have reached their end of life. There will be no
more security updates. All Bugzilla 2.x and 3.0 users should update to
a supported Bugzilla 3.x version.

References
==========

[ 1 ] CVE-2008-4437
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-4437
[ 2 ] CVE-2008-6098
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-6098
[ 3 ] CVE-2009-0481
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-0481
[ 4 ] CVE-2009-0482
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-0482
[ 5 ] CVE-2009-0483
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-0483
[ 6 ] CVE-2009-0484
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-0484
[ 7 ] CVE-2009-0485
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-0485
[ 8 ] CVE-2009-0486
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-0486
[ 9 ] CVE-2009-1213
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-1213
[ 10 ] CVE-2009-3125
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-3125
[ 11 ] CVE-2009-3165
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-3165
[ 12 ] CVE-2009-3166
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-3166
[ 13 ] CVE-2009-3387
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-3387
[ 14 ] CVE-2009-3989
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-3989

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201006-19.xml


[gentoo-announce] [ GLSA 201006-18 ] Oracle JRE/JDK: Multiple vulnerabilities
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201006-18
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: Oracle JRE/JDK: Multiple vulnerabilities
Date: June 04, 2010
Bugs: #306579, #314531
ID: 201006-18

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

The Oracle JDK and JRE are vulnerable to multiple unspecified
vulnerabilities.

Background
==========

The Oracle Java Development Kit (JDK) (formerly known as Sun JDK) and
the Oracle Java Runtime Environment (JRE) (formerly known as Sun JRE)
provide the Oracle Java platform (formerly known as Sun Java Platform).

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 dev-java/sun-jre-bin < 1.6.0.20 >= 1.6.0.20
2 dev-java/sun-jdk < 1.6.0.20 >= 1.6.0.20
3 app-emulation/emul-linux-x86-java < 1.6.0.20 >= 1.6.0.20
-------------------------------------------------------------------
3 affected packages on all of their supported architectures.
-------------------------------------------------------------------

Description
===========

Multiple vulnerabilities have been reported in the Oracle Java
implementation. Please review the CVE identifiers referenced below and
the associated Oracle Critical Patch Update Advisory for details.

Impact
======

A remote attacker could exploit these vulnerabilities to cause
unspecified impact, possibly including remote execution of arbitrary
code.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Oracle JRE 1.6.x users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-java/sun-jre-bin-1.6.0.20"

All Oracle JDK 1.6.x users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-java/sun-jdk-1.6.0.20"

All users of the precompiled 32bit Oracle JRE 1.6.x should upgrade to
the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose
">=app-emulation/emul-linux-x86-java-1.6.0.20"

All Oracle JRE 1.5.x, Oracle JDK 1.5.x, and precompiled 32bit Oracle
JRE 1.5.x users are strongly advised to unmerge Java 1.5:

# emerge --unmerge =app-emulation/emul-linux-x86-java-1.5*
# emerge --unmerge =dev-java/sun-jre-bin-1.5*
# emerge --unmerge =dev-java/sun-jdk-1.5*

Gentoo is ceasing support for the 1.5 generation of the Oracle Java
Platform in accordance with upstream. All 1.5 JRE versions are masked
and will be removed shortly. All 1.5 JDK versions are marked as
"build-only" and will be masked for removal shortly. Users are advised
to change their default user and system Java implementation to an
unaffected version. For example:

# java-config --set-system-vm sun-jdk-1.6

For more information, please consult the Gentoo Linux Java
documentation.

References
==========

[ 1 ] CVE-2009-3555
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-3555
[ 2 ] CVE-2010-0082
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-0082
[ 3 ] CVE-2010-0084
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-0084
[ 4 ] CVE-2010-0085
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-0085
[ 5 ] CVE-2010-0087
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-0087
[ 6 ] CVE-2010-0088
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-0088
[ 7 ] CVE-2010-0089
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-0089
[ 8 ] CVE-2010-0090
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-0090
[ 9 ] CVE-2010-0091
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-0091
[ 10 ] CVE-2010-0092
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-0092
[ 11 ] CVE-2010-0093
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-0093
[ 12 ] CVE-2010-0094
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-0094
[ 13 ] CVE-2010-0095
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-0095
[ 14 ] CVE-2010-0837
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-0837
[ 15 ] CVE-2010-0838
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-0838
[ 16 ] CVE-2010-0839
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-0839
[ 17 ] CVE-2010-0840
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-0840
[ 18 ] CVE-2010-0841
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-0841
[ 19 ] CVE-2010-0842
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-0842
[ 20 ] CVE-2010-0843
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-0843
[ 21 ] CVE-2010-0844
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-0844
[ 22 ] CVE-2010-0845
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-0845
[ 23 ] CVE-2010-0846
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-0846
[ 24 ] CVE-2010-0847
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-0847
[ 25 ] CVE-2010-0848
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-0848
[ 26 ] CVE-2010-0849
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-0849
[ 27 ] CVE-2010-0850
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-0850
[ 28 ] CVE-2010-0886
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-0886
[ 29 ] CVE-2010-0887
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-0887
[ 30 ] Gentoo Linux Java documentation
http://www.gentoo.org/doc/en/java.xml#doc_chap4
[ 31 ] Oracle Java SE and Java for Business Critical Patch Update
Advisory - March 2010
Oracle Java SE and Java for Business Critical Patch Update - March 2010

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201006-18.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
Gentoo Bugzilla Main Page

License
=======

Copyright 2010 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

302 Found



Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/6_gentoo_security_updates.html)