5 Security Updates for Debian
Posted on: 06/08/2012 07:45 AM

5 security updates for Debian has been released: [SECURITY] [DSA 2488-1] iceweasel security update, [SECURITY] [DSA 2490-1] nss security update, [SECURITY] [DSA 2489-1] iceape security update, [SECURITY] [DSA 2487-1] openoffice.org security update, and [SECURITY] [DSA 2480-3] request-tracker3.8 regression update

[SECURITY] [DSA 2488-1] iceweasel security update
- -------------------------------------------------------------------------
Debian Security Advisory DSA-2488-1 security@debian.org
http://www.debian.org/security/ Thijs Kinkhorst
June 7, 2012 http://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : iceweasel
Vulnerability : several vulnerabilities
Problem type : local (remote)
Debian-specific: no
CVE ID : CVE-2012-1937 CVE-2012-1940 CVE-2012-1947

Several vulnerabilities have been discovered in Iceweasel, a web
browser based on Firefox. The included XULRunner library provides
rendering services for several other applications included in Debian.

CVE-2012-1937

Mozilla developers discovered several memory corruption bugs,
which may lead to the execution of arbitrary code.

CVE-2012-1940

Abhishek Arya discovered a use-after-free problem when working
with column layout with absolute positioning in a container that
changes size, which may lead to the execution of arbitrary code.

CVE-2012-1947

Abhishek Arya discovered a heap buffer overflow in utf16 to latin1
character set conersion, allowing to execute arbitray code.


Note: We'd like to advise users of Iceweasel's 3.5 branch in Debian
stable to consider to upgrade to the Iceweasel 10.0 ESR (Extended
Support Release) which is now availble in Debian Backports.
Although Debian will continue to support Iceweasel 3.5 in stable with
security updates, this can only be done on a best effort base as
upstream provides no such support anymore. On top of that, the 10.0
branch adds proactive security features to the browser.

For the stable distribution (squeeze), this problem has been fixed in
version 3.5.16-16.

For the unstable distribution (sid), this problem has been fixed in
version 10.0.5esr-1.

We recommend that you upgrade your iceweasel packages.

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: http://www.debian.org/security/

[SECURITY] [DSA 2490-1] nss security update
- -------------------------------------------------------------------------
Debian Security Advisory DSA-2490-1 security@debian.org
http://www.debian.org/security/ Thijs Kinkhorst
June 7, 2012 http://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : nss
Vulnerability : denial of service
Problem type : remote
Debian-specific: no
CVE ID : CVE-2012-0441

Kaspar Brand discovered that Mozilla's Network Security Services (NSS)
library did insufficient length checking in the QuickDER decoder,
allowing to crash a program using the library.

For the stable distribution (squeeze), this problem has been fixed in
version 3.12.8-1+squeeze5.

For the testing distribution (wheezy) and unstable distribution (sid),
this problem has been fixed in version 2:3.13.4-3.

We recommend that you upgrade your nss packages.

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: http://www.debian.org/security/

[SECURITY] [DSA 2489-1] iceape security update
- -------------------------------------------------------------------------
Debian Security Advisory DSA-2489-1 security@debian.org
http://www.debian.org/security/ Thijs Kinkhorst
June 7, 2012 http://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : iceape
Vulnerability : several vulnerabilities
Problem type : local (remote)
Debian-specific: no
CVE ID : CVE-2012-1937 CVE-2012-1940 CVE-2012-1947

Several vulnerabilities have been found in the Iceape internet suite,
an unbranded version of Seamonkey.

CVE-2012-1937

Mozilla developers discovered several memory corruption bugs,
which may lead to the execution of arbitrary code.

CVE-2012-1940

Abhishek Arya discovered a use-after-free problem when working
with column layout with absolute positioning in a container that
changes size, which may lead to the execution of arbitrary code.

CVE-2012-1947

Abhishek Arya discovered a heap buffer overflow in utf16 to latin1
character set conersion, allowing to execute arbitray code.

For the stable distribution (squeeze), this problem has been fixed in
version 2.0.11-13.

For the testing distribution (wheezy) and unstable distribution (sid),
this problem will be fixed soon.

We recommend that you upgrade your iceape packages.

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: http://www.debian.org/security/

[SECURITY] [DSA 2487-1] openoffice.org security update
- -------------------------------------------------------------------------
Debian Security Advisory DSA-2487-1 security@debian.org
http://www.debian.org/security/ Florian Weimer
June 07, 2012 http://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : openoffice.org
Vulnerability : buffer overflow
Problem type : local (remote)
Debian-specific: no
CVE ID : CVE-2012-1149 CVE-2012-2334

It was discovered that OpenOffice.org would not properly process
crafted document files, possibly leading to arbitrary code execution.

CVE-2012-1149
Integer overflows in PNG image handling

CVE-2012-2334
Integer overflow in operator new[] invocation and heap-based
buffer overflow inside the MS-ODRAW parser

For the stable distribution (squeeze), this problem has been fixed in
version 1:3.2.1-11+squeeze6.

For the unstable distribution (sid), these problems have been fixed in
version 1:3.5.2~rc2-1 of the libreoffice package.

We recommend that you upgrade your openoffice.org packages.

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: http://www.debian.org/security/

[SECURITY] [DSA 2480-3] request-tracker3.8 regression update
- -------------------------------------------------------------------------
Debian Security Advisory DSA-2480-3 security@debian.org
http://www.debian.org/security/ Florian Weimer
June 07, 2012 http://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : request-tracker3.8
Vulnerability : regression
Debian Bug : 674924 675369

The recent security updates for request-tracker3.8, DSA-2480-1 and
DSA-2480-2, contained another regression when running under mod_perl.

Please note that if you run request-tracker3.8 under the Apache web
server, you must stop and start Apache manually. The "restart"
mechanism is not recommended, especially when using mod_perl.

For the stable distribution (squeeze), this problem has been fixed in
version 3.8.8-7+squeeze4.

We recommend that you upgrade your request-tracker3.8 packages.

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: http://www.debian.org/security/




Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/5_security_updates_for_debian.html)