5 RHEL Updates
Posted on: 02/17/2012 09:45 AM

Red Hat has released the following updates for RHEL: [RHSA-2012:0143-01] Critical: xulrunner security update, [RHSA-2012:0141-01] Critical: seamonkey security update, [RHSA-2012:0142-01] Critical: firefox security update, [RHSA-2012:0140-01] Critical: thunderbird security update, and [RHSA-2012:0139-01] Critical: java-1.6.0-sun security update

[RHSA-2012:0143-01] Critical: xulrunner security update
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

=====================================================================
Red Hat Security Advisory

Synopsis: Critical: xulrunner security update
Advisory ID: RHSA-2012:0143-01
Product: Red Hat Enterprise Linux
Advisory URL: https://rhn.redhat.com/errata/RHSA-2012-0143.html
Issue date: 2012-02-16
CVE Names: CVE-2011-3026
=====================================================================

1. Summary:

Updated xulrunner packages that fix one security issue are now available
for Red Hat Enterprise Linux 5 and 6.

The Red Hat Security Response Team has rated this update as having critical
security impact. A Common Vulnerability Scoring System (CVSS) base score,
which gives a detailed severity rating, is available from the CVE link in
the References section.

2. Relevant releases/architectures:

RHEL Desktop Workstation (v. 5 client) - i386, x86_64
Red Hat Enterprise Linux (v. 5 server) - i386, ia64, ppc, s390x, x86_64
Red Hat Enterprise Linux Desktop (v. 5 client) - i386, x86_64
Red Hat Enterprise Linux Desktop (v. 6) - i386, x86_64
Red Hat Enterprise Linux Desktop Optional (v. 6) - i386, x86_64
Red Hat Enterprise Linux HPC Node Optional (v. 6) - x86_64
Red Hat Enterprise Linux Server (v. 6) - i386, ppc64, s390x, x86_64
Red Hat Enterprise Linux Server Optional (v. 6) - i386, ppc64, s390x, x86_64
Red Hat Enterprise Linux Workstation (v. 6) - i386, x86_64
Red Hat Enterprise Linux Workstation Optional (v. 6) - i386, x86_64

3. Description:

XULRunner provides the XUL Runtime environment for applications using the
Gecko layout engine.

A heap-based buffer overflow flaw was found in the way XULRunner handled
PNG (Portable Network Graphics) images. A web page containing a malicious
PNG image could cause an application linked against XULRunner (such as
Firefox) to crash or, potentially, execute arbitrary code with the
privileges of the user running the application. (CVE-2011-3026)

All XULRunner users should upgrade to these updated packages, which correct
this issue. After installing the update, applications using XULRunner must
be restarted for the changes to take effect.

4. Solution:

Before applying this update, make sure all previously-released errata
relevant to your system have been applied.

This update is available via the Red Hat Network. Details on how to
use the Red Hat Network to apply this update are available at
https://access.redhat.com/kb/docs/DOC-11259

5. Bugs fixed (http://bugzilla.redhat.com/):

790737 - CVE-2011-3026 libpng: Heap-buffer-overflow in png_decompress_chunk

6. Package List:

Red Hat Enterprise Linux Desktop (v. 5 client):

Source:
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Client/en/os/SRPMS/xulrunner-1.9.2.26-2.el5_7.src.rpm

i386:
xulrunner-1.9.2.26-2.el5_7.i386.rpm
xulrunner-debuginfo-1.9.2.26-2.el5_7.i386.rpm

x86_64:
xulrunner-1.9.2.26-2.el5_7.i386.rpm
xulrunner-1.9.2.26-2.el5_7.x86_64.rpm
xulrunner-debuginfo-1.9.2.26-2.el5_7.i386.rpm
xulrunner-debuginfo-1.9.2.26-2.el5_7.x86_64.rpm

RHEL Desktop Workstation (v. 5 client):

Source:
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Client/en/os/SRPMS/xulrunner-1.9.2.26-2.el5_7.src.rpm

i386:
xulrunner-debuginfo-1.9.2.26-2.el5_7.i386.rpm
xulrunner-devel-1.9.2.26-2.el5_7.i386.rpm

x86_64:
xulrunner-debuginfo-1.9.2.26-2.el5_7.i386.rpm
xulrunner-debuginfo-1.9.2.26-2.el5_7.x86_64.rpm
xulrunner-devel-1.9.2.26-2.el5_7.i386.rpm
xulrunner-devel-1.9.2.26-2.el5_7.x86_64.rpm

Red Hat Enterprise Linux (v. 5 server):

Source:
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Server/en/os/SRPMS/xulrunner-1.9.2.26-2.el5_7.src.rpm

i386:
xulrunner-1.9.2.26-2.el5_7.i386.rpm
xulrunner-debuginfo-1.9.2.26-2.el5_7.i386.rpm
xulrunner-devel-1.9.2.26-2.el5_7.i386.rpm

ia64:
xulrunner-1.9.2.26-2.el5_7.ia64.rpm
xulrunner-debuginfo-1.9.2.26-2.el5_7.ia64.rpm
xulrunner-devel-1.9.2.26-2.el5_7.ia64.rpm

ppc:
xulrunner-1.9.2.26-2.el5_7.ppc.rpm
xulrunner-1.9.2.26-2.el5_7.ppc64.rpm
xulrunner-debuginfo-1.9.2.26-2.el5_7.ppc.rpm
xulrunner-debuginfo-1.9.2.26-2.el5_7.ppc64.rpm
xulrunner-devel-1.9.2.26-2.el5_7.ppc.rpm
xulrunner-devel-1.9.2.26-2.el5_7.ppc64.rpm

s390x:
xulrunner-1.9.2.26-2.el5_7.s390.rpm
xulrunner-1.9.2.26-2.el5_7.s390x.rpm
xulrunner-debuginfo-1.9.2.26-2.el5_7.s390.rpm
xulrunner-debuginfo-1.9.2.26-2.el5_7.s390x.rpm
xulrunner-devel-1.9.2.26-2.el5_7.s390.rpm
xulrunner-devel-1.9.2.26-2.el5_7.s390x.rpm

x86_64:
xulrunner-1.9.2.26-2.el5_7.i386.rpm
xulrunner-1.9.2.26-2.el5_7.x86_64.rpm
xulrunner-debuginfo-1.9.2.26-2.el5_7.i386.rpm
xulrunner-debuginfo-1.9.2.26-2.el5_7.x86_64.rpm
xulrunner-devel-1.9.2.26-2.el5_7.i386.rpm
xulrunner-devel-1.9.2.26-2.el5_7.x86_64.rpm

Red Hat Enterprise Linux Desktop (v. 6):

Source:
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/6Client/en/os/SRPMS/xulrunner-1.9.2.26-2.el6_2.src.rpm

i386:
xulrunner-1.9.2.26-2.el6_2.i686.rpm
xulrunner-debuginfo-1.9.2.26-2.el6_2.i686.rpm

x86_64:
xulrunner-1.9.2.26-2.el6_2.i686.rpm
xulrunner-1.9.2.26-2.el6_2.x86_64.rpm
xulrunner-debuginfo-1.9.2.26-2.el6_2.i686.rpm
xulrunner-debuginfo-1.9.2.26-2.el6_2.x86_64.rpm

Red Hat Enterprise Linux Desktop Optional (v. 6):

Source:
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/6Client/en/os/SRPMS/xulrunner-1.9.2.26-2.el6_2.src.rpm

i386:
xulrunner-debuginfo-1.9.2.26-2.el6_2.i686.rpm
xulrunner-devel-1.9.2.26-2.el6_2.i686.rpm

x86_64:
xulrunner-debuginfo-1.9.2.26-2.el6_2.i686.rpm
xulrunner-debuginfo-1.9.2.26-2.el6_2.x86_64.rpm
xulrunner-devel-1.9.2.26-2.el6_2.i686.rpm
xulrunner-devel-1.9.2.26-2.el6_2.x86_64.rpm

Red Hat Enterprise Linux HPC Node Optional (v. 6):

Source:
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/6ComputeNode/en/os/SRPMS/xulrunner-1.9.2.26-2.el6_2.src.rpm

x86_64:
xulrunner-1.9.2.26-2.el6_2.i686.rpm
xulrunner-1.9.2.26-2.el6_2.x86_64.rpm
xulrunner-debuginfo-1.9.2.26-2.el6_2.i686.rpm
xulrunner-debuginfo-1.9.2.26-2.el6_2.x86_64.rpm
xulrunner-devel-1.9.2.26-2.el6_2.i686.rpm
xulrunner-devel-1.9.2.26-2.el6_2.x86_64.rpm

Red Hat Enterprise Linux Server (v. 6):

Source:
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/6Server/en/os/SRPMS/xulrunner-1.9.2.26-2.el6_2.src.rpm

i386:
xulrunner-1.9.2.26-2.el6_2.i686.rpm
xulrunner-debuginfo-1.9.2.26-2.el6_2.i686.rpm

ppc64:
xulrunner-1.9.2.26-2.el6_2.ppc.rpm
xulrunner-1.9.2.26-2.el6_2.ppc64.rpm
xulrunner-debuginfo-1.9.2.26-2.el6_2.ppc.rpm
xulrunner-debuginfo-1.9.2.26-2.el6_2.ppc64.rpm

s390x:
xulrunner-1.9.2.26-2.el6_2.s390.rpm
xulrunner-1.9.2.26-2.el6_2.s390x.rpm
xulrunner-debuginfo-1.9.2.26-2.el6_2.s390.rpm
xulrunner-debuginfo-1.9.2.26-2.el6_2.s390x.rpm

x86_64:
xulrunner-1.9.2.26-2.el6_2.i686.rpm
xulrunner-1.9.2.26-2.el6_2.x86_64.rpm
xulrunner-debuginfo-1.9.2.26-2.el6_2.i686.rpm
xulrunner-debuginfo-1.9.2.26-2.el6_2.x86_64.rpm

Red Hat Enterprise Linux Server Optional (v. 6):

Source:
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/6Server/en/os/SRPMS/xulrunner-1.9.2.26-2.el6_2.src.rpm

i386:
xulrunner-debuginfo-1.9.2.26-2.el6_2.i686.rpm
xulrunner-devel-1.9.2.26-2.el6_2.i686.rpm

ppc64:
xulrunner-debuginfo-1.9.2.26-2.el6_2.ppc.rpm
xulrunner-debuginfo-1.9.2.26-2.el6_2.ppc64.rpm
xulrunner-devel-1.9.2.26-2.el6_2.ppc.rpm
xulrunner-devel-1.9.2.26-2.el6_2.ppc64.rpm

s390x:
xulrunner-debuginfo-1.9.2.26-2.el6_2.s390.rpm
xulrunner-debuginfo-1.9.2.26-2.el6_2.s390x.rpm
xulrunner-devel-1.9.2.26-2.el6_2.s390.rpm
xulrunner-devel-1.9.2.26-2.el6_2.s390x.rpm

x86_64:
xulrunner-debuginfo-1.9.2.26-2.el6_2.i686.rpm
xulrunner-debuginfo-1.9.2.26-2.el6_2.x86_64.rpm
xulrunner-devel-1.9.2.26-2.el6_2.i686.rpm
xulrunner-devel-1.9.2.26-2.el6_2.x86_64.rpm

Red Hat Enterprise Linux Workstation (v. 6):

Source:
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/6Workstation/en/os/SRPMS/xulrunner-1.9.2.26-2.el6_2.src.rpm

i386:
xulrunner-1.9.2.26-2.el6_2.i686.rpm
xulrunner-debuginfo-1.9.2.26-2.el6_2.i686.rpm

x86_64:
xulrunner-1.9.2.26-2.el6_2.i686.rpm
xulrunner-1.9.2.26-2.el6_2.x86_64.rpm
xulrunner-debuginfo-1.9.2.26-2.el6_2.i686.rpm
xulrunner-debuginfo-1.9.2.26-2.el6_2.x86_64.rpm

Red Hat Enterprise Linux Workstation Optional (v. 6):

Source:
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/6Workstation/en/os/SRPMS/xulrunner-1.9.2.26-2.el6_2.src.rpm

i386:
xulrunner-debuginfo-1.9.2.26-2.el6_2.i686.rpm
xulrunner-devel-1.9.2.26-2.el6_2.i686.rpm

x86_64:
xulrunner-debuginfo-1.9.2.26-2.el6_2.i686.rpm
xulrunner-debuginfo-1.9.2.26-2.el6_2.x86_64.rpm
xulrunner-devel-1.9.2.26-2.el6_2.i686.rpm
xulrunner-devel-1.9.2.26-2.el6_2.x86_64.rpm

These packages are GPG signed by Red Hat for security. Our key and
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/#package

7. References:

https://www.redhat.com/security/data/cve/CVE-2011-3026.html
https://access.redhat.com/security/updates/classification/#critical

8. Contact:

The Red Hat security contact is . More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2012 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.4 (GNU/Linux)

iD8DBQFPPVetXlSAg2UNWIIRAoQnAKCy1d8UY+opJVVWj7kV7tfKAetPHwCdGeGk
7+kDhRqRY3JmrAHuYNi4pU0=
=Skue
-----END PGP SIGNATURE-----


[RHSA-2012:0141-01] Critical: seamonkey security update
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

=====================================================================
Red Hat Security Advisory

Synopsis: Critical: seamonkey security update
Advisory ID: RHSA-2012:0141-01
Product: Red Hat Enterprise Linux
Advisory URL: https://rhn.redhat.com/errata/RHSA-2012-0141.html
Issue date: 2012-02-16
CVE Names: CVE-2011-3026
=====================================================================

1. Summary:

Updated seamonkey packages that fix one security issue are now available
for Red Hat Enterprise Linux 4.

The Red Hat Security Response Team has rated this update as having critical
security impact. A Common Vulnerability Scoring System (CVSS) base score,
which gives a detailed severity rating, is available from the CVE link in
the References section.

2. Relevant releases/architectures:

Red Hat Enterprise Linux AS version 4 - i386, ia64, ppc, s390, s390x, x86_64
Red Hat Enterprise Linux Desktop version 4 - i386, x86_64
Red Hat Enterprise Linux ES version 4 - i386, ia64, x86_64
Red Hat Enterprise Linux WS version 4 - i386, ia64, x86_64

3. Description:

SeaMonkey is an open source web browser, e-mail and newsgroup client, IRC
chat client, and HTML editor.

A heap-based buffer overflow flaw was found in the way SeaMonkey handled
PNG (Portable Network Graphics) images. A web page containing a malicious
PNG image could cause SeaMonkey to crash or, possibly, execute arbitrary
code with the privileges of the user running SeaMonkey. (CVE-2011-3026)

All SeaMonkey users should upgrade to these updated packages, which correct
this issue. After installing the update, SeaMonkey must be restarted for
the changes to take effect.

4. Solution:

Before applying this update, make sure all previously-released errata
relevant to your system have been applied.

This update is available via the Red Hat Network. Details on how to
use the Red Hat Network to apply this update are available at
https://access.redhat.com/kb/docs/DOC-11259

5. Bugs fixed (http://bugzilla.redhat.com/):

790737 - CVE-2011-3026 libpng: Heap-buffer-overflow in png_decompress_chunk

6. Package List:

Red Hat Enterprise Linux AS version 4:

Source:
ftp://updates.redhat.com/enterprise/4AS/en/os/SRPMS/seamonkey-1.0.9-79.el4.src.rpm

i386:
seamonkey-1.0.9-79.el4.i386.rpm
seamonkey-chat-1.0.9-79.el4.i386.rpm
seamonkey-debuginfo-1.0.9-79.el4.i386.rpm
seamonkey-devel-1.0.9-79.el4.i386.rpm
seamonkey-dom-inspector-1.0.9-79.el4.i386.rpm
seamonkey-js-debugger-1.0.9-79.el4.i386.rpm
seamonkey-mail-1.0.9-79.el4.i386.rpm

ia64:
seamonkey-1.0.9-79.el4.ia64.rpm
seamonkey-chat-1.0.9-79.el4.ia64.rpm
seamonkey-debuginfo-1.0.9-79.el4.ia64.rpm
seamonkey-devel-1.0.9-79.el4.ia64.rpm
seamonkey-dom-inspector-1.0.9-79.el4.ia64.rpm
seamonkey-js-debugger-1.0.9-79.el4.ia64.rpm
seamonkey-mail-1.0.9-79.el4.ia64.rpm

ppc:
seamonkey-1.0.9-79.el4.ppc.rpm
seamonkey-chat-1.0.9-79.el4.ppc.rpm
seamonkey-debuginfo-1.0.9-79.el4.ppc.rpm
seamonkey-devel-1.0.9-79.el4.ppc.rpm
seamonkey-dom-inspector-1.0.9-79.el4.ppc.rpm
seamonkey-js-debugger-1.0.9-79.el4.ppc.rpm
seamonkey-mail-1.0.9-79.el4.ppc.rpm

s390:
seamonkey-1.0.9-79.el4.s390.rpm
seamonkey-chat-1.0.9-79.el4.s390.rpm
seamonkey-debuginfo-1.0.9-79.el4.s390.rpm
seamonkey-devel-1.0.9-79.el4.s390.rpm
seamonkey-dom-inspector-1.0.9-79.el4.s390.rpm
seamonkey-js-debugger-1.0.9-79.el4.s390.rpm
seamonkey-mail-1.0.9-79.el4.s390.rpm

s390x:
seamonkey-1.0.9-79.el4.s390x.rpm
seamonkey-chat-1.0.9-79.el4.s390x.rpm
seamonkey-debuginfo-1.0.9-79.el4.s390x.rpm
seamonkey-devel-1.0.9-79.el4.s390x.rpm
seamonkey-dom-inspector-1.0.9-79.el4.s390x.rpm
seamonkey-js-debugger-1.0.9-79.el4.s390x.rpm
seamonkey-mail-1.0.9-79.el4.s390x.rpm

x86_64:
seamonkey-1.0.9-79.el4.x86_64.rpm
seamonkey-chat-1.0.9-79.el4.x86_64.rpm
seamonkey-debuginfo-1.0.9-79.el4.x86_64.rpm
seamonkey-devel-1.0.9-79.el4.x86_64.rpm
seamonkey-dom-inspector-1.0.9-79.el4.x86_64.rpm
seamonkey-js-debugger-1.0.9-79.el4.x86_64.rpm
seamonkey-mail-1.0.9-79.el4.x86_64.rpm

Red Hat Enterprise Linux Desktop version 4:

Source:
ftp://updates.redhat.com/enterprise/4Desktop/en/os/SRPMS/seamonkey-1.0.9-79.el4.src.rpm

i386:
seamonkey-1.0.9-79.el4.i386.rpm
seamonkey-chat-1.0.9-79.el4.i386.rpm
seamonkey-debuginfo-1.0.9-79.el4.i386.rpm
seamonkey-devel-1.0.9-79.el4.i386.rpm
seamonkey-dom-inspector-1.0.9-79.el4.i386.rpm
seamonkey-js-debugger-1.0.9-79.el4.i386.rpm
seamonkey-mail-1.0.9-79.el4.i386.rpm

x86_64:
seamonkey-1.0.9-79.el4.x86_64.rpm
seamonkey-chat-1.0.9-79.el4.x86_64.rpm
seamonkey-debuginfo-1.0.9-79.el4.x86_64.rpm
seamonkey-devel-1.0.9-79.el4.x86_64.rpm
seamonkey-dom-inspector-1.0.9-79.el4.x86_64.rpm
seamonkey-js-debugger-1.0.9-79.el4.x86_64.rpm
seamonkey-mail-1.0.9-79.el4.x86_64.rpm

Red Hat Enterprise Linux ES version 4:

Source:
ftp://updates.redhat.com/enterprise/4ES/en/os/SRPMS/seamonkey-1.0.9-79.el4.src.rpm

i386:
seamonkey-1.0.9-79.el4.i386.rpm
seamonkey-chat-1.0.9-79.el4.i386.rpm
seamonkey-debuginfo-1.0.9-79.el4.i386.rpm
seamonkey-devel-1.0.9-79.el4.i386.rpm
seamonkey-dom-inspector-1.0.9-79.el4.i386.rpm
seamonkey-js-debugger-1.0.9-79.el4.i386.rpm
seamonkey-mail-1.0.9-79.el4.i386.rpm

ia64:
seamonkey-1.0.9-79.el4.ia64.rpm
seamonkey-chat-1.0.9-79.el4.ia64.rpm
seamonkey-debuginfo-1.0.9-79.el4.ia64.rpm
seamonkey-devel-1.0.9-79.el4.ia64.rpm
seamonkey-dom-inspector-1.0.9-79.el4.ia64.rpm
seamonkey-js-debugger-1.0.9-79.el4.ia64.rpm
seamonkey-mail-1.0.9-79.el4.ia64.rpm

x86_64:
seamonkey-1.0.9-79.el4.x86_64.rpm
seamonkey-chat-1.0.9-79.el4.x86_64.rpm
seamonkey-debuginfo-1.0.9-79.el4.x86_64.rpm
seamonkey-devel-1.0.9-79.el4.x86_64.rpm
seamonkey-dom-inspector-1.0.9-79.el4.x86_64.rpm
seamonkey-js-debugger-1.0.9-79.el4.x86_64.rpm
seamonkey-mail-1.0.9-79.el4.x86_64.rpm

Red Hat Enterprise Linux WS version 4:

Source:
ftp://updates.redhat.com/enterprise/4WS/en/os/SRPMS/seamonkey-1.0.9-79.el4.src.rpm

i386:
seamonkey-1.0.9-79.el4.i386.rpm
seamonkey-chat-1.0.9-79.el4.i386.rpm
seamonkey-debuginfo-1.0.9-79.el4.i386.rpm
seamonkey-devel-1.0.9-79.el4.i386.rpm
seamonkey-dom-inspector-1.0.9-79.el4.i386.rpm
seamonkey-js-debugger-1.0.9-79.el4.i386.rpm
seamonkey-mail-1.0.9-79.el4.i386.rpm

ia64:
seamonkey-1.0.9-79.el4.ia64.rpm
seamonkey-chat-1.0.9-79.el4.ia64.rpm
seamonkey-debuginfo-1.0.9-79.el4.ia64.rpm
seamonkey-devel-1.0.9-79.el4.ia64.rpm
seamonkey-dom-inspector-1.0.9-79.el4.ia64.rpm
seamonkey-js-debugger-1.0.9-79.el4.ia64.rpm
seamonkey-mail-1.0.9-79.el4.ia64.rpm

x86_64:
seamonkey-1.0.9-79.el4.x86_64.rpm
seamonkey-chat-1.0.9-79.el4.x86_64.rpm
seamonkey-debuginfo-1.0.9-79.el4.x86_64.rpm
seamonkey-devel-1.0.9-79.el4.x86_64.rpm
seamonkey-dom-inspector-1.0.9-79.el4.x86_64.rpm
seamonkey-js-debugger-1.0.9-79.el4.x86_64.rpm
seamonkey-mail-1.0.9-79.el4.x86_64.rpm

These packages are GPG signed by Red Hat for security. Our key and
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/#package

7. References:

https://www.redhat.com/security/data/cve/CVE-2011-3026.html
https://access.redhat.com/security/updates/classification/#critical

8. Contact:

The Red Hat security contact is . More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2012 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.4 (GNU/Linux)

iD8DBQFPPVc/XlSAg2UNWIIRAm3JAJsHQLOT912YsHcirqFoT3VLkhEPGQCfcL+3
2O727JRuFQEqnyZpxZ0LpoI=
=8KCf
-----END PGP SIGNATURE-----


[RHSA-2012:0142-01] Critical: firefox security update
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

=====================================================================
Red Hat Security Advisory

Synopsis: Critical: firefox security update
Advisory ID: RHSA-2012:0142-01
Product: Red Hat Enterprise Linux
Advisory URL: https://rhn.redhat.com/errata/RHSA-2012-0142.html
Issue date: 2012-02-16
CVE Names: CVE-2011-3026
=====================================================================

1. Summary:

An updated firefox package that fixes one security issue is now available
for Red Hat Enterprise Linux 4.

The Red Hat Security Response Team has rated this update as having critical
security impact. A Common Vulnerability Scoring System (CVSS) base score,
which gives a detailed severity rating, is available from the CVE link in
the References section.

2. Relevant releases/architectures:

Red Hat Enterprise Linux AS version 4 - i386, ia64, ppc, s390, s390x, x86_64
Red Hat Enterprise Linux Desktop version 4 - i386, x86_64
Red Hat Enterprise Linux ES version 4 - i386, ia64, x86_64
Red Hat Enterprise Linux WS version 4 - i386, ia64, x86_64

3. Description:

Mozilla Firefox is an open source web browser.

A heap-based buffer overflow flaw was found in the way Firefox handled
PNG (Portable Network Graphics) images. A web page containing a malicious
PNG image could cause Firefox to crash or, possibly, execute arbitrary
code with the privileges of the user running Firefox. (CVE-2011-3026)

All Firefox users should upgrade to this updated package, which corrects
this issue. After installing the update, Firefox must be restarted for the
changes to take effect.

4. Solution:

Before applying this update, make sure all previously-released errata
relevant to your system have been applied.

This update is available via the Red Hat Network. Details on how to
use the Red Hat Network to apply this update are available at
https://access.redhat.com/kb/docs/DOC-11259

5. Bugs fixed (http://bugzilla.redhat.com/):

790737 - CVE-2011-3026 libpng: Heap-buffer-overflow in png_decompress_chunk

6. Package List:

Red Hat Enterprise Linux AS version 4:

Source:
ftp://updates.redhat.com/enterprise/4AS/en/os/SRPMS/firefox-3.6.26-3.el4.src.rpm

i386:
firefox-3.6.26-3.el4.i386.rpm
firefox-debuginfo-3.6.26-3.el4.i386.rpm

ia64:
firefox-3.6.26-3.el4.ia64.rpm
firefox-debuginfo-3.6.26-3.el4.ia64.rpm

ppc:
firefox-3.6.26-3.el4.ppc.rpm
firefox-debuginfo-3.6.26-3.el4.ppc.rpm

s390:
firefox-3.6.26-3.el4.s390.rpm
firefox-debuginfo-3.6.26-3.el4.s390.rpm

s390x:
firefox-3.6.26-3.el4.s390x.rpm
firefox-debuginfo-3.6.26-3.el4.s390x.rpm

x86_64:
firefox-3.6.26-3.el4.x86_64.rpm
firefox-debuginfo-3.6.26-3.el4.x86_64.rpm

Red Hat Enterprise Linux Desktop version 4:

Source:
ftp://updates.redhat.com/enterprise/4Desktop/en/os/SRPMS/firefox-3.6.26-3.el4.src.rpm

i386:
firefox-3.6.26-3.el4.i386.rpm
firefox-debuginfo-3.6.26-3.el4.i386.rpm

x86_64:
firefox-3.6.26-3.el4.x86_64.rpm
firefox-debuginfo-3.6.26-3.el4.x86_64.rpm

Red Hat Enterprise Linux ES version 4:

Source:
ftp://updates.redhat.com/enterprise/4ES/en/os/SRPMS/firefox-3.6.26-3.el4.src.rpm

i386:
firefox-3.6.26-3.el4.i386.rpm
firefox-debuginfo-3.6.26-3.el4.i386.rpm

ia64:
firefox-3.6.26-3.el4.ia64.rpm
firefox-debuginfo-3.6.26-3.el4.ia64.rpm

x86_64:
firefox-3.6.26-3.el4.x86_64.rpm
firefox-debuginfo-3.6.26-3.el4.x86_64.rpm

Red Hat Enterprise Linux WS version 4:

Source:
ftp://updates.redhat.com/enterprise/4WS/en/os/SRPMS/firefox-3.6.26-3.el4.src.rpm

i386:
firefox-3.6.26-3.el4.i386.rpm
firefox-debuginfo-3.6.26-3.el4.i386.rpm

ia64:
firefox-3.6.26-3.el4.ia64.rpm
firefox-debuginfo-3.6.26-3.el4.ia64.rpm

x86_64:
firefox-3.6.26-3.el4.x86_64.rpm
firefox-debuginfo-3.6.26-3.el4.x86_64.rpm

These packages are GPG signed by Red Hat for security. Our key and
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/#package

7. References:

https://www.redhat.com/security/data/cve/CVE-2011-3026.html
https://access.redhat.com/security/updates/classification/#critical

8. Contact:

The Red Hat security contact is . More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2012 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.4 (GNU/Linux)

iD8DBQFPPVd/XlSAg2UNWIIRAo3eAJ9slN5trVLVtwqJv3ci4mo0Np9JFACgrw9X
PBGGaRmPHj+nqbTT3XvCggY=
=QZ11
-----END PGP SIGNATURE-----


[RHSA-2012:0140-01] Critical: thunderbird security update
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

=====================================================================
Red Hat Security Advisory

Synopsis: Critical: thunderbird security update
Advisory ID: RHSA-2012:0140-01
Product: Red Hat Enterprise Linux
Advisory URL: https://rhn.redhat.com/errata/RHSA-2012-0140.html
Issue date: 2012-02-16
CVE Names: CVE-2011-3026
=====================================================================

1. Summary:

An updated thunderbird package that fixes one security issue is now
available for Red Hat Enterprise Linux 6.

The Red Hat Security Response Team has rated this update as having critical
security impact. A Common Vulnerability Scoring System (CVSS) base score,
which gives a detailed severity rating, is available from the CVE link in
the References section.

2. Relevant releases/architectures:

Red Hat Enterprise Linux Desktop (v. 6) - i386, x86_64
Red Hat Enterprise Linux Server Optional (v. 6) - i386, ppc64, s390x, x86_64
Red Hat Enterprise Linux Workstation (v. 6) - i386, x86_64

3. Description:

Mozilla Thunderbird is a standalone mail and newsgroup client.

A heap-based buffer overflow flaw was found in the way Thunderbird handled
PNG (Portable Network Graphics) images. An HTML mail message or remote
content containing a specially-crafted PNG image could cause Thunderbird to
crash or, possibly, execute arbitrary code with the privileges of the user
running Thunderbird. (CVE-2011-3026)

All Thunderbird users should upgrade to this updated package, which
corrects this issue. After installing the update, Thunderbird must be
restarted for the changes to take effect.

4. Solution:

Before applying this update, make sure all previously-released errata
relevant to your system have been applied.

This update is available via the Red Hat Network. Details on how to
use the Red Hat Network to apply this update are available at
https://access.redhat.com/kb/docs/DOC-11259

5. Bugs fixed (http://bugzilla.redhat.com/):

790737 - CVE-2011-3026 libpng: Heap-buffer-overflow in png_decompress_chunk

6. Package List:

Red Hat Enterprise Linux Desktop (v. 6):

Source:
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/6Client/en/os/SRPMS/thunderbird-3.1.18-2.el6_2.src.rpm

i386:
thunderbird-3.1.18-2.el6_2.i686.rpm
thunderbird-debuginfo-3.1.18-2.el6_2.i686.rpm

x86_64:
thunderbird-3.1.18-2.el6_2.x86_64.rpm
thunderbird-debuginfo-3.1.18-2.el6_2.x86_64.rpm

Red Hat Enterprise Linux Server Optional (v. 6):

Source:
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/6Server/en/os/SRPMS/thunderbird-3.1.18-2.el6_2.src.rpm

i386:
thunderbird-3.1.18-2.el6_2.i686.rpm
thunderbird-debuginfo-3.1.18-2.el6_2.i686.rpm

ppc64:
thunderbird-3.1.18-2.el6_2.ppc64.rpm
thunderbird-debuginfo-3.1.18-2.el6_2.ppc64.rpm

s390x:
thunderbird-3.1.18-2.el6_2.s390x.rpm
thunderbird-debuginfo-3.1.18-2.el6_2.s390x.rpm

x86_64:
thunderbird-3.1.18-2.el6_2.x86_64.rpm
thunderbird-debuginfo-3.1.18-2.el6_2.x86_64.rpm

Red Hat Enterprise Linux Workstation (v. 6):

Source:
ftp://ftp.redhat.com/pub/redhat/linux/enterprise/6Workstation/en/os/SRPMS/thunderbird-3.1.18-2.el6_2.src.rpm

i386:
thunderbird-3.1.18-2.el6_2.i686.rpm
thunderbird-debuginfo-3.1.18-2.el6_2.i686.rpm

x86_64:
thunderbird-3.1.18-2.el6_2.x86_64.rpm
thunderbird-debuginfo-3.1.18-2.el6_2.x86_64.rpm

These packages are GPG signed by Red Hat for security. Our key and
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/#package

7. References:

https://www.redhat.com/security/data/cve/CVE-2011-3026.html
https://access.redhat.com/security/updates/classification/#critical

8. Contact:

The Red Hat security contact is . More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2012 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.4 (GNU/Linux)

iD8DBQFPPVcKXlSAg2UNWIIRAoqMAKCzbPWoUJBFgmE9gRFZWeN/8iP7hACfaa9u
7s0BF/vOs/iyLPCfb4K/ts8=
=mBnN
-----END PGP SIGNATURE-----


[RHSA-2012:0139-01] Critical: java-1.6.0-sun security update
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

=====================================================================
Red Hat Security Advisory

Synopsis: Critical: java-1.6.0-sun security update
Advisory ID: RHSA-2012:0139-01
Product: Red Hat Enterprise Linux Extras
Advisory URL: https://rhn.redhat.com/errata/RHSA-2012-0139.html
Issue date: 2012-02-16
CVE Names: CVE-2011-3563 CVE-2011-3571 CVE-2011-5035
CVE-2012-0498 CVE-2012-0499 CVE-2012-0500
CVE-2012-0501 CVE-2012-0502 CVE-2012-0503
CVE-2012-0505 CVE-2012-0506
=====================================================================

1. Summary:

Updated java-1.6.0-sun packages that fix several security issues are now
available for Red Hat Enterprise Linux 4 Extras, and Red Hat Enterprise
Linux 5 and 6 Supplementary.

The Red Hat Security Response Team has rated this update as having critical
security impact. Common Vulnerability Scoring System (CVSS) base scores,
which give detailed severity ratings, are available for each vulnerability
from the CVE links in the References section.

2. Relevant releases/architectures:

Red Hat Desktop version 4 Extras - i386, x86_64
Red Hat Enterprise Linux AS version 4 Extras - i386, x86_64
Red Hat Enterprise Linux Desktop Supplementary (v. 5) - i386, x86_64
Red Hat Enterprise Linux Desktop Supplementary (v. 6) - i386, x86_64
Red Hat Enterprise Linux ES version 4 Extras - i386, x86_64
Red Hat Enterprise Linux HPC Node Supplementary (v. 6) - x86_64
Red Hat Enterprise Linux Server Supplementary (v. 5) - i386, x86_64
Red Hat Enterprise Linux Server Supplementary (v. 6) - i386, x86_64
Red Hat Enterprise Linux WS version 4 Extras - i386, x86_64
Red Hat Enterprise Linux Workstation Supplementary (v. 6) - i386, x86_64

3. Description:

The Sun 1.6.0 Java release includes the Sun Java 6 Runtime Environment and
the Sun Java 6 Software Development Kit.

This update fixes several vulnerabilities in the Sun Java 6 Runtime
Environment and the Sun Java 6 Software Development Kit. Further
information about these flaws can be found on the Oracle Java SE Critical
Patch page, listed in the References section. (CVE-2011-3563,
CVE-2011-3571, CVE-2011-5035, CVE-2012-0498, CVE-2012-0499, CVE-2012-0500,
CVE-2012-0501, CVE-2012-0502, CVE-2012-0503, CVE-2012-0505, CVE-2012-0506)

All users of java-1.6.0-sun are advised to upgrade to these updated
packages, which provide JDK and JRE 6 Update 31 and resolve these issues.
All running instances of Sun Java must be restarted for the update to take
effect.

4. Solution:

Before applying this update, make sure all previously-released errata
relevant to your system have been applied.

This update is available via the Red Hat Network. Details on how to
use the Red Hat Network to apply this update are available at
https://access.redhat.com/kb/docs/DOC-11259

5. Bugs fixed (http://bugzilla.redhat.com/):

788606 - CVE-2011-5035 OpenJDK: HttpServer no header count limit (Lightweight HTTP Server, 7126960)
788624 - CVE-2012-0501 OpenJDK: off-by-one bug in ZIP reading code (JRE, 7118283)
788976 - CVE-2012-0503 OpenJDK: unrestricted use of TimeZone.setDefault() (i18n, 7110687)
788994 - CVE-2011-3571 OpenJDK: AtomicReferenceArray insufficient array type check (Concurrency, 7082299)
789295 - CVE-2011-3563 OpenJDK: JavaSound incorrect bounds check (Sound, 7088367)
789297 - CVE-2012-0502 OpenJDK: KeyboardFocusManager focus stealing (AWT, 7110683)
789299 - CVE-2012-0505 OpenJDK: incomplete info in the deserialization exception (Serialization, 7110700)
789300 - CVE-2012-0506 OpenJDK: mutable repository identifiers (CORBA, 7110704)
790720 - CVE-2012-0498 Oracle JDK: unspecified vulnerability fixed in 6u31 and 7u3 (2D)
790722 - CVE-2012-0499 Oracle JDK: unspecified vulnerability fixed in 6u31 and 7u3 (2D)
790724 - CVE-2012-0500 Oracle JDK: unspecified vulnerability fixed in 6u31 and 7u3 (Deployment)

6. Package List:

Red Hat Enterprise Linux AS version 4 Extras:

i386:
java-1.6.0-sun-1.6.0.31-1jpp.1.el4.i586.rpm
java-1.6.0-sun-demo-1.6.0.31-1jpp.1.el4.i586.rpm
java-1.6.0-sun-devel-1.6.0.31-1jpp.1.el4.i586.rpm
java-1.6.0-sun-jdbc-1.6.0.31-1jpp.1.el4.i586.rpm
java-1.6.0-sun-plugin-1.6.0.31-1jpp.1.el4.i586.rpm
java-1.6.0-sun-src-1.6.0.31-1jpp.1.el4.i586.rpm

x86_64:
java-1.6.0-sun-1.6.0.31-1jpp.1.el4.x86_64.rpm
java-1.6.0-sun-demo-1.6.0.31-1jpp.1.el4.x86_64.rpm
java-1.6.0-sun-devel-1.6.0.31-1jpp.1.el4.x86_64.rpm
java-1.6.0-sun-jdbc-1.6.0.31-1jpp.1.el4.x86_64.rpm
java-1.6.0-sun-plugin-1.6.0.31-1jpp.1.el4.x86_64.rpm
java-1.6.0-sun-src-1.6.0.31-1jpp.1.el4.x86_64.rpm

Red Hat Desktop version 4 Extras:

i386:
java-1.6.0-sun-1.6.0.31-1jpp.1.el4.i586.rpm
java-1.6.0-sun-demo-1.6.0.31-1jpp.1.el4.i586.rpm
java-1.6.0-sun-devel-1.6.0.31-1jpp.1.el4.i586.rpm
java-1.6.0-sun-jdbc-1.6.0.31-1jpp.1.el4.i586.rpm
java-1.6.0-sun-plugin-1.6.0.31-1jpp.1.el4.i586.rpm
java-1.6.0-sun-src-1.6.0.31-1jpp.1.el4.i586.rpm

x86_64:
java-1.6.0-sun-1.6.0.31-1jpp.1.el4.x86_64.rpm
java-1.6.0-sun-demo-1.6.0.31-1jpp.1.el4.x86_64.rpm
java-1.6.0-sun-devel-1.6.0.31-1jpp.1.el4.x86_64.rpm
java-1.6.0-sun-jdbc-1.6.0.31-1jpp.1.el4.x86_64.rpm
java-1.6.0-sun-plugin-1.6.0.31-1jpp.1.el4.x86_64.rpm
java-1.6.0-sun-src-1.6.0.31-1jpp.1.el4.x86_64.rpm

Red Hat Enterprise Linux ES version 4 Extras:

i386:
java-1.6.0-sun-1.6.0.31-1jpp.1.el4.i586.rpm
java-1.6.0-sun-demo-1.6.0.31-1jpp.1.el4.i586.rpm
java-1.6.0-sun-devel-1.6.0.31-1jpp.1.el4.i586.rpm
java-1.6.0-sun-jdbc-1.6.0.31-1jpp.1.el4.i586.rpm
java-1.6.0-sun-plugin-1.6.0.31-1jpp.1.el4.i586.rpm
java-1.6.0-sun-src-1.6.0.31-1jpp.1.el4.i586.rpm

x86_64:
java-1.6.0-sun-1.6.0.31-1jpp.1.el4.x86_64.rpm
java-1.6.0-sun-demo-1.6.0.31-1jpp.1.el4.x86_64.rpm
java-1.6.0-sun-devel-1.6.0.31-1jpp.1.el4.x86_64.rpm
java-1.6.0-sun-jdbc-1.6.0.31-1jpp.1.el4.x86_64.rpm
java-1.6.0-sun-plugin-1.6.0.31-1jpp.1.el4.x86_64.rpm
java-1.6.0-sun-src-1.6.0.31-1jpp.1.el4.x86_64.rpm

Red Hat Enterprise Linux WS version 4 Extras:

i386:
java-1.6.0-sun-1.6.0.31-1jpp.1.el4.i586.rpm
java-1.6.0-sun-demo-1.6.0.31-1jpp.1.el4.i586.rpm
java-1.6.0-sun-devel-1.6.0.31-1jpp.1.el4.i586.rpm
java-1.6.0-sun-jdbc-1.6.0.31-1jpp.1.el4.i586.rpm
java-1.6.0-sun-plugin-1.6.0.31-1jpp.1.el4.i586.rpm
java-1.6.0-sun-src-1.6.0.31-1jpp.1.el4.i586.rpm

x86_64:
java-1.6.0-sun-1.6.0.31-1jpp.1.el4.x86_64.rpm
java-1.6.0-sun-demo-1.6.0.31-1jpp.1.el4.x86_64.rpm
java-1.6.0-sun-devel-1.6.0.31-1jpp.1.el4.x86_64.rpm
java-1.6.0-sun-jdbc-1.6.0.31-1jpp.1.el4.x86_64.rpm
java-1.6.0-sun-plugin-1.6.0.31-1jpp.1.el4.x86_64.rpm
java-1.6.0-sun-src-1.6.0.31-1jpp.1.el4.x86_64.rpm

Red Hat Enterprise Linux Desktop Supplementary (v. 5):

i386:
java-1.6.0-sun-1.6.0.31-1jpp.1.el5.i586.rpm
java-1.6.0-sun-demo-1.6.0.31-1jpp.1.el5.i586.rpm
java-1.6.0-sun-devel-1.6.0.31-1jpp.1.el5.i586.rpm
java-1.6.0-sun-jdbc-1.6.0.31-1jpp.1.el5.i586.rpm
java-1.6.0-sun-plugin-1.6.0.31-1jpp.1.el5.i586.rpm
java-1.6.0-sun-src-1.6.0.31-1jpp.1.el5.i586.rpm

x86_64:
java-1.6.0-sun-1.6.0.31-1jpp.1.el5.x86_64.rpm
java-1.6.0-sun-demo-1.6.0.31-1jpp.1.el5.x86_64.rpm
java-1.6.0-sun-devel-1.6.0.31-1jpp.1.el5.x86_64.rpm
java-1.6.0-sun-jdbc-1.6.0.31-1jpp.1.el5.x86_64.rpm
java-1.6.0-sun-plugin-1.6.0.31-1jpp.1.el5.x86_64.rpm
java-1.6.0-sun-src-1.6.0.31-1jpp.1.el5.x86_64.rpm

Red Hat Enterprise Linux Server Supplementary (v. 5):

i386:
java-1.6.0-sun-1.6.0.31-1jpp.1.el5.i586.rpm
java-1.6.0-sun-demo-1.6.0.31-1jpp.1.el5.i586.rpm
java-1.6.0-sun-devel-1.6.0.31-1jpp.1.el5.i586.rpm
java-1.6.0-sun-jdbc-1.6.0.31-1jpp.1.el5.i586.rpm
java-1.6.0-sun-plugin-1.6.0.31-1jpp.1.el5.i586.rpm
java-1.6.0-sun-src-1.6.0.31-1jpp.1.el5.i586.rpm

x86_64:
java-1.6.0-sun-1.6.0.31-1jpp.1.el5.x86_64.rpm
java-1.6.0-sun-demo-1.6.0.31-1jpp.1.el5.x86_64.rpm
java-1.6.0-sun-devel-1.6.0.31-1jpp.1.el5.x86_64.rpm
java-1.6.0-sun-jdbc-1.6.0.31-1jpp.1.el5.x86_64.rpm
java-1.6.0-sun-plugin-1.6.0.31-1jpp.1.el5.x86_64.rpm
java-1.6.0-sun-src-1.6.0.31-1jpp.1.el5.x86_64.rpm

Red Hat Enterprise Linux Desktop Supplementary (v. 6):

i386:
java-1.6.0-sun-1.6.0.31-1jpp.1.el6_2.i686.rpm
java-1.6.0-sun-demo-1.6.0.31-1jpp.1.el6_2.i686.rpm
java-1.6.0-sun-devel-1.6.0.31-1jpp.1.el6_2.i686.rpm
java-1.6.0-sun-jdbc-1.6.0.31-1jpp.1.el6_2.i686.rpm
java-1.6.0-sun-plugin-1.6.0.31-1jpp.1.el6_2.i686.rpm
java-1.6.0-sun-src-1.6.0.31-1jpp.1.el6_2.i686.rpm

x86_64:
java-1.6.0-sun-1.6.0.31-1jpp.1.el6_2.i686.rpm
java-1.6.0-sun-1.6.0.31-1jpp.1.el6_2.x86_64.rpm
java-1.6.0-sun-demo-1.6.0.31-1jpp.1.el6_2.x86_64.rpm
java-1.6.0-sun-devel-1.6.0.31-1jpp.1.el6_2.i686.rpm
java-1.6.0-sun-devel-1.6.0.31-1jpp.1.el6_2.x86_64.rpm
java-1.6.0-sun-jdbc-1.6.0.31-1jpp.1.el6_2.x86_64.rpm
java-1.6.0-sun-plugin-1.6.0.31-1jpp.1.el6_2.x86_64.rpm
java-1.6.0-sun-src-1.6.0.31-1jpp.1.el6_2.x86_64.rpm

Red Hat Enterprise Linux HPC Node Supplementary (v. 6):

x86_64:
java-1.6.0-sun-1.6.0.31-1jpp.1.el6_2.i686.rpm
java-1.6.0-sun-1.6.0.31-1jpp.1.el6_2.x86_64.rpm
java-1.6.0-sun-demo-1.6.0.31-1jpp.1.el6_2.x86_64.rpm
java-1.6.0-sun-devel-1.6.0.31-1jpp.1.el6_2.i686.rpm
java-1.6.0-sun-devel-1.6.0.31-1jpp.1.el6_2.x86_64.rpm
java-1.6.0-sun-src-1.6.0.31-1jpp.1.el6_2.x86_64.rpm

Red Hat Enterprise Linux Server Supplementary (v. 6):

i386:
java-1.6.0-sun-1.6.0.31-1jpp.1.el6_2.i686.rpm
java-1.6.0-sun-demo-1.6.0.31-1jpp.1.el6_2.i686.rpm
java-1.6.0-sun-devel-1.6.0.31-1jpp.1.el6_2.i686.rpm
java-1.6.0-sun-jdbc-1.6.0.31-1jpp.1.el6_2.i686.rpm
java-1.6.0-sun-plugin-1.6.0.31-1jpp.1.el6_2.i686.rpm
java-1.6.0-sun-src-1.6.0.31-1jpp.1.el6_2.i686.rpm

x86_64:
java-1.6.0-sun-1.6.0.31-1jpp.1.el6_2.i686.rpm
java-1.6.0-sun-1.6.0.31-1jpp.1.el6_2.x86_64.rpm
java-1.6.0-sun-demo-1.6.0.31-1jpp.1.el6_2.x86_64.rpm
java-1.6.0-sun-devel-1.6.0.31-1jpp.1.el6_2.i686.rpm
java-1.6.0-sun-devel-1.6.0.31-1jpp.1.el6_2.x86_64.rpm
java-1.6.0-sun-jdbc-1.6.0.31-1jpp.1.el6_2.x86_64.rpm
java-1.6.0-sun-plugin-1.6.0.31-1jpp.1.el6_2.x86_64.rpm
java-1.6.0-sun-src-1.6.0.31-1jpp.1.el6_2.x86_64.rpm

Red Hat Enterprise Linux Workstation Supplementary (v. 6):

i386:
java-1.6.0-sun-1.6.0.31-1jpp.1.el6_2.i686.rpm
java-1.6.0-sun-demo-1.6.0.31-1jpp.1.el6_2.i686.rpm
java-1.6.0-sun-devel-1.6.0.31-1jpp.1.el6_2.i686.rpm
java-1.6.0-sun-jdbc-1.6.0.31-1jpp.1.el6_2.i686.rpm
java-1.6.0-sun-plugin-1.6.0.31-1jpp.1.el6_2.i686.rpm
java-1.6.0-sun-src-1.6.0.31-1jpp.1.el6_2.i686.rpm

x86_64:
java-1.6.0-sun-1.6.0.31-1jpp.1.el6_2.i686.rpm
java-1.6.0-sun-1.6.0.31-1jpp.1.el6_2.x86_64.rpm
java-1.6.0-sun-demo-1.6.0.31-1jpp.1.el6_2.x86_64.rpm
java-1.6.0-sun-devel-1.6.0.31-1jpp.1.el6_2.i686.rpm
java-1.6.0-sun-devel-1.6.0.31-1jpp.1.el6_2.x86_64.rpm
java-1.6.0-sun-jdbc-1.6.0.31-1jpp.1.el6_2.x86_64.rpm
java-1.6.0-sun-plugin-1.6.0.31-1jpp.1.el6_2.x86_64.rpm
java-1.6.0-sun-src-1.6.0.31-1jpp.1.el6_2.x86_64.rpm

These packages are GPG signed by Red Hat for security. Our key and
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/#package

7. References:

https://www.redhat.com/security/data/cve/CVE-2011-3563.html
https://www.redhat.com/security/data/cve/CVE-2011-3571.html
https://www.redhat.com/security/data/cve/CVE-2011-5035.html
https://www.redhat.com/security/data/cve/CVE-2012-0498.html
https://www.redhat.com/security/data/cve/CVE-2012-0499.html
https://www.redhat.com/security/data/cve/CVE-2012-0500.html
https://www.redhat.com/security/data/cve/CVE-2012-0501.html
https://www.redhat.com/security/data/cve/CVE-2012-0502.html
https://www.redhat.com/security/data/cve/CVE-2012-0503.html
https://www.redhat.com/security/data/cve/CVE-2012-0505.html
https://www.redhat.com/security/data/cve/CVE-2012-0506.html
https://access.redhat.com/security/updates/classification/#critical
http://www.oracle.com/technetwork/topics/security/javacpufeb2012-366318.html
http://www.oracle.com/technetwork/java/javase/6u31-relnotes-1482342.html

8. Contact:

The Red Hat security contact is . More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2012 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.4 (GNU/Linux)

iD8DBQFPPVa5XlSAg2UNWIIRAn6xAJ932rg7KVwp+jyL7jwxMvOiZHAqtQCgmt4n
dZEXYZPhMUvix7Sd5jUeKng=
=Czkl
-----END PGP SIGNATURE-----





Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/5_rhel_updates_f24d.html)