4 Security Updates for Gentoo Linux
Posted on: 09/15/2013 09:16 AM

The following security updates has been released for Gentoo Linux: [ GLSA 201309-10 ] Adobe Reader: Arbitrary Code Execution, [ GLSA 201309-09 ] LibRaw, libkdcraw: Multiple vulnerabilities, [ GLSA 201309-08 ] FileZilla: Multiple vulnerabilities, and [ GLSA 201309-07 ] libotr: Arbitrary code execution

[ GLSA 201309-10 ] Adobe Reader: Arbitrary Code Execution
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201309-10
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: Adobe Reader: Arbitrary Code Execution
Date: September 15, 2013
Bugs: #483210
ID: 201309-10

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A vulnerability in Adobe Reader could result in execution of arbitrary
code or Denial of Service.

Background
==========

Adobe Reader is a closed-source PDF reader.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 app-text/acroread < 9.5.5 >= 9.5.5

Description
===========

An unspecified vulnerability exists in Adobe Reader.

Impact
======

An attacker could execute arbitrary code or cause a Denial of Service
condition.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Adobe Reader users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=app-text/acroread-9.5.5"

References
==========

[ 1 ] CVE-2013-3346
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-3346

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201309-10.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2013 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5




[ GLSA 201309-09 ] LibRaw, libkdcraw: Multiple vulnerabilities
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201309-09
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: LibRaw, libkdcraw: Multiple vulnerabilities
Date: September 15, 2013
Bugs: #471694, #482926
ID: 201309-09

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in LibRaw and libkdcraw, the
worst of which may lead to arbitrary code execution.

Background
==========

LibRaw is a library for reading RAW files obtained from digital photo
cameras. libkdcraw is a wrapper for LibRaw within KDE.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 media-libs/libraw < 0.15.4 >= 0.15.4
2 kde-base/libkdcraw < 4.10.5-r1 >= 4.10.5-r1
-------------------------------------------------------------------
2 affected packages

Description
===========

Multiple vulnerabilities have been discovered in LibRaw and libkdcraw.
Please review the CVE identifiers referenced below for details.

Impact
======

A remote attacker could entice a user to open a specially crafted file,
possibly resulting in arbitrary code execution or Denial of Service.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All LibRaw users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=media-libs/libraw-0.15.4"

All libkdcraw users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=kde-base/libkdcraw-4.10.5-r1"

References
==========

[ 1 ] CVE-2013-1438
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-1438
[ 2 ] CVE-2013-1439
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-1439
[ 3 ] CVE-2013-2126
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-2126
[ 4 ] CVE-2013-2127
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-2127

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201309-09.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2013 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5




[ GLSA 201309-08 ] FileZilla: Multiple vulnerabilities
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201309-08
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: FileZilla: Multiple vulnerabilities
Date: September 15, 2013
Bugs: #479880, #482672
ID: 201309-08

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in FileZilla, the worst of
which could result in arbitrary code execution.

Background
==========

FileZilla is an open source FTP client.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 net-ftp/filezilla < 3.7.3 >= 3.7.3

Description
===========

Multiple vulnerabilities have been discovered in FileZilla. Please
review the CVE identifiers referenced below for details.

Impact
======

A remote attacker could entice a user to connect to a malicious server,
resulting in possible arbitrary code execution or a Denial of Service.
Additionally, a local attacker could read sensitive memory, potentially
resulting in password disclosure.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All FileZilla users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-ftp/filezilla-3.7.3"

References
==========

[ 1 ] CVE-2013-4206
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-4206
[ 2 ] CVE-2013-4207
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-4207
[ 3 ] CVE-2013-4208
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-4208
[ 4 ] CVE-2013-4852
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-4852

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201309-08.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2013 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5




[ GLSA 201309-07 ] libotr: Arbitrary code execution
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201309-07
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: High
Title: libotr: Arbitrary code execution
Date: September 15, 2013
Bugs: #430486
ID: 201309-07

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A buffer overflow vulnerability in libotr could allow a remote attacker
to execute arbitrary code or cause a Denial of Service condition.

Background
==========

libotr is a portable off-the-record messaging library.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 net-libs/libotr < 3.2.1 >= 3.2.1

Description
===========

Multiple heap-based buffer overflows are present in the Base64 decoder
of libotr.

Impact
======

A remote attacker could send a specially crafted OTR message, resulting
in arbitrary code execution with the privileges of the process or a
Denial of Service condition.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All libotr users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-libs/libotr-3.2.1"

References
==========

[ 1 ] CVE-2012-3461
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-3461

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201309-07.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2013 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5







Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/4_security_updates_for_gentoo_linux.html)