4 Gentoo Updates
Posted on: 12/03/2013 07:40 AM

The following Gentoo updates has been released: [ GLSA 201312-04 ] libtheora: Arbitrary code execution, [ GLSA 201312-03 ] OpenSSL: Multiple Vulnerabilities, [ GLSA 201312-02 ] BusyBox: Multiple vulnerabilities, and [ GLSA 201312-01 ] GNU C Library: Multiple vulnerabilities

[ GLSA 201312-04 ] libtheora: Arbitrary code execution
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201312-04
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: libtheora: Arbitrary code execution
Date: December 03, 2013
Bugs: #298039
ID: 201312-04

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

An integer overflow in libtheora might allow remote attackers to
execute arbitrary code or cause a Denial of Service condition.

Background
==========

libtheora is the reference implementation of Theora, a free and open
video compression format from the Xiph.org Foundation.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 media-libs/libtheora < 1.1.1 >= 1.1.1

Description
===========

An integer overflow flaw has been discovered in libtheora.

Impact
======

A remote attacker could execute arbitrary code or cause a Denial of
Service condition.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All libtheora users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=media-libs/libtheora-1.1.1"

Packages which depend on this library may need to be recompiled. Tools
such as revdep-rebuild may assist in identifying some of these
packages.

References
==========

[ 1 ] CVE-2009-3389
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2009-3389

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201312-04.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2013 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5




[ GLSA 201312-03 ] OpenSSL: Multiple Vulnerabilities
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201312-03
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Low
Title: OpenSSL: Multiple Vulnerabilities
Date: December 03, 2013
Bugs: #369753, #406199, #412643, #415435, #455592
ID: 201312-03

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in OpenSSL allowing remote
attackers to determine private keys or cause a Denial of Service.

Background
==========

OpenSSL is an Open Source toolkit implementing the Secure Sockets Layer
(SSL v2/v3) and Transport Layer Security (TLS v1) as well as a general
purpose cryptography library.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 dev-libs/openssl < 1.0.0i *>= 0.9.8y
*>= 1.0.0j
2 dev-libs/openssl < 0.9.8y Vulnerable!
-------------------------------------------------------------------
NOTE: Certain packages are still vulnerable. Users should migrate
to another package if one is available or wait for the
existing packages to be marked stable by their
architecture maintainers.
-------------------------------------------------------------------
2 affected packages

Description
===========

Multiple vulnerabilities have been discovered in OpenSSL. Please review
the CVE identifiers referenced below for details.

Impact
======

Remote attackers can determine private keys, decrypt data, cause a
Denial of Service or possibly have other unspecified impact.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All OpenSSL 1.0.x users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-libs/openssl-1.0.0j"

All OpenSSL 0.9.8 users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-libs/openssl-0.9.8y"

References
==========

[ 1 ] CVE-2006-7250
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2006-7250
[ 2 ] CVE-2011-1945
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-1945
[ 3 ] CVE-2012-0884
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-0884
[ 4 ] CVE-2012-1165
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-1165
[ 5 ] CVE-2012-2110
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-2110
[ 6 ] CVE-2012-2333
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-2333
[ 7 ] CVE-2012-2686
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-2686
[ 8 ] CVE-2013-0166
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-0166
[ 9 ] CVE-2013-0169
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-0169

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201312-03.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2013 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5




[ GLSA 201312-02 ] BusyBox: Multiple vulnerabilities
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201312-02
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: BusyBox: Multiple vulnerabilities
Date: December 03, 2013
Bugs: #379857, #426504, #461372
ID: 201312-02

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in BusyBox, allowing remote
attackers to execute arbitrary code or cause a Denial of Service
condition.

Background
==========

BusyBox is set of tools for embedded systems and is a replacement for
GNU Coreutils.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 sys-apps/busybox < 1.21.0 >= 1.21.0

Description
===========

Multiple vulnerabilities have been discovered in BusyBox. Please review
the CVE identifiers referenced below for details.

Impact
======

A remote attacker could send a specially crafted DHCP request to
possibly execute arbitrary code or cause Denial of Service.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All BusyBox users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=sys-apps/busybox-1.21.0"

References
==========

[ 1 ] CVE-2006-1168
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2006-1168
[ 2 ] CVE-2011-2716
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-2716
[ 3 ] CVE-2013-1813
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-1813

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201312-02.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2013 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5




[ GLSA 201312-01 ] GNU C Library: Multiple vulnerabilities
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201312-01
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: High
Title: GNU C Library: Multiple vulnerabilities
Date: December 03, 2013
Bugs: #350744, #356567, #386323, #386327, #386329, #386333,
#386343, #386349, #393477, #404993
ID: 201312-01

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in GNU C Library, the worst of
which allowing arbitrary code execution and privilege escalation.

Background
==========

The GNU C library is the standard C library used by Gentoo Linux
systems.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 sys-libs/glibc < 2.15-r3 >= 2.15-r3

Description
===========

Multiple vulnerabilities have been discovered in GNU C Library. Please
review the CVE identifiers referenced below for details.

Impact
======

A local attacker could trigger vulnerabilities in dynamic library
loader, making it possible to load attacker-controlled shared objects
during execution of setuid/setgid programs to escalate privileges.

A context-dependent attacker could trigger various vulnerabilities in
GNU C Library, including a buffer overflow, leading to execution of
arbitrary code or a Denial of Service.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All GNU C Library users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=sys-libs/glibc-2.15-r3"

References
==========

[ 1 ] CVE-2009-5029
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2009-5029
[ 2 ] CVE-2010-3847
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2010-3847
[ 3 ] CVE-2011-0536
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-0536
[ 4 ] CVE-2011-1071
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-1071
[ 5 ] CVE-2011-1089
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-1089
[ 6 ] CVE-2011-1095
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-1095
[ 7 ] CVE-2011-1658
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-1658
[ 8 ] CVE-2011-1659
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-1659
[ 9 ] CVE-2012-0864
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-0864

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201312-01.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2013 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5







Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/4_gentoo_updates_9290.html)