3 Security Updates for Gentoo
Posted on: 10/23/2011 10:25 AM

The following three security updates has been released for Gentoo Linux: [ GLSA 201110-19 ] X.Org X Server: Multiple vulnerabilities, [ GLSA 201110-17 ] Avahi: Denial of Service, and [ GLSA 201110-18 ] rgmanager: Privilege escalation

[ GLSA 201110-19 ] X.Org X Server: Multiple vulnerabilities
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201110-19
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: X.Org X Server: Multiple vulnerabilities
Date: October 22, 2011
Bugs: #387069
ID: 201110-19

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities in the X.Org X server might allow local
attackers to disclose information.

Background
==========

The X Window System is a graphical windowing system based on a
client/server model.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 x11-base/xorg-server < 1.10.4-r1 *>= 1.9.5-r1
>= 1.10.4-r1

Description
===========

vladz reported the following vulnerabilities in the X.Org X server:

* The X.Org X server follows symbolic links when trying to access the
lock file for a X display, showing a predictable behavior depending
on the file type of the link target (CVE-2011-4028).
* The X.Org X server lock file mechanism allows for a race condition to
cause the X server to modify the file permissions of an arbitrary
file to 0444 (CVE-2011-4029).

Impact
======

A local attacker could exploit these vulnerabilities to disclose
information by making arbitrary files on a system world-readable or
gain information whether a specified file exists on the system and
whether it is a file, directory, or a named pipe.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All X.Org X Server 1.9 users should upgrade to the latest 1.9 version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=x11-base/xorg-server-1.9.5-r1"

All X.Org X Server 1.10 users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=x11-base/xorg-server-1.10.4-r1"

References
==========

[ 1 ] CVE-2011-4028
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-4028
[ 2 ] CVE-2011-4029
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-4029

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201110-19.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2011 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5



[ GLSA 201110-17 ] Avahi: Denial of Service
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201110-17
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: Avahi: Denial of Service
Date: October 22, 2011
Bugs: #335885, #355583
ID: 201110-17

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities were found in Avahi, allowing for Denial of
Service.

Background
==========

Avahi is a system which facilitates service discovery on a local
network.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 net-dns/avahi < 0.6.28-r1 >= 0.6.28-r1

Description
===========

Multiple vulnerabilities have been discovered in Avahi. Please review
the CVE identifiers referenced below for details.

Impact
======

A remote attacker could cause a Denial of Service.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Avahi users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-dns/avahi-0.6.28-r1"

References
==========

[ 1 ] CVE-2010-2244
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2010-2244
[ 2 ] CVE-2011-1002
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-1002

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201110-17.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2011 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5




[ GLSA 201110-18 ] rgmanager: Privilege escalation
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 201110-18
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: rgmanager: Privilege escalation
Date: October 22, 2011
Bugs: #352213
ID: 201110-18

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A vulnerability was found in rgmanager, allowing for privilege
escalation.

Background
==========

rgmanager is a clustered resource group manager.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 sys-cluster/rgmanager < 2.03.09-r1 >= 2.03.09-r1

Description
===========

A vulnerability has been discovered in rgmanager. Please review the CVE
identifier referenced below for details.

Impact
======

A local attacker could gain escalated privileges.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All rgmanager users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot -v ">=sys-cluster/rgmanager-2.03.09-r1"

References
==========

[ 1 ] CVE-2010-3389
http://nvd.nist.gov/nvd.cfm?cvename=CVE-2010-3389

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-201110-18.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2011 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5







Printed from Linux Compatible (http://www.linuxcompatible.org/news/story/3_security_updates_for_gentoo.html)